Server - Minor Version Upgrade with zypper

To perform the upgrade with Zypper, use the Zypper migration tool.

Procedure: Upgrading with zypper
  1. From the command prompt, as root, ensure the spacewalk services are not running:

    spacewalk-service stop
  2. Launch the Zypper migration tool:

    zypper migration

    Zypper will show the possible migration targets with detailed summaries.

  3. Select the appropriate target, and follow the prompts to complete the migration.

  4. Reboot the server.

  5. When rebooted the SUSE Manager spacewalk services are not running until you have migrated the PostgreSQL database to version 14.

  6. Log in on the text console as root. If you are upgrading from 4.1 or 4.2 to 4.3, run the database migration script:

    /usr/lib/susemanager/bin/pg-migrate-x-to-y.sh
  7. Ensure the spacewalk services are running:

    spacewalk-service start

If the process fails, check these issues first:

  • If Zypper does not have the migration tool available, install the zypper-migration-plugin package.

  • If there are older updates available, Zypper will notify you and ask to install them first. You must install all updates before performing the upgrade.