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About This Guide

This manual introduces you to the GNOME graphical desktop environment as implemented in
SUSE® Linux Enterprise Server, and shows you how to configure it to meet your personal needs
and preferences. It also introduces you to several programs and services. It is intended for users
who have experience using a graphical desktop environment such as macOS*, Windows*, or
other Linux desktops.

The manual is divided into the following parts:

Introduction
Get to know your GNOME desktop, learn how to cope with basic and daily tasks using the
central GNOME applications and various small utilities. Get an overview of the possibilities
that GNOME offers for modifying and individualizing the desktop according to your needs
and wishes. Learn how to use assistive technologies to improve accessibility in case of

vision or mobility impairment.

Connectivity, Files and Resources
Learn how to manage and exchange data on your system or on a network: connecting to a
network and sharing files, managing printers, or creating backups of your data. This part
also shows how to sign and encrypt your mails and documents and how to use file transfer

clients to transfer data from or to the Internet.

LibreOffice

Introduces the LibreOffice suite, including Writer, Calc, Impress, Base, Draw, and Math.

Internet, Communication and Collaboration
Use a Web browser and get to know the e-mailing and calendaring software. Communicate
with others using Instant Messaging or Voice over IP.

Graphics and Multimedia
Get to know GIMP, an image manipulation program that meets the needs of both amateurs
and professionals. Get introduced to your desktop's applications for playing movies. Learn

how to create data or audio CDs and DVDs for archiving your data.
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1 Available Documentation

@ Nota: Online Documentation and Latest Updates

Documentation for our products is available at https://documentation.suse.com/ 7, where
you can also find the latest updates, and browse or download the documentation in

various formats.

In addition, the product documentation is usually available in your installed system under /

usr/share/doc/manual.

The following documentation is available for this product:

Artigo “Inicializacao Rapida da Instalacdo”
Lists the system requirements and guides you step-by-step through the installation of SUSE

Linux Enterprise Server from DVD, or from an ISO image.

Livro “Deployment Guide”
Shows how to install single or multiple systems and how to exploit the product inherent
capabilities for a deployment infrastructure. Choose from various approaches, ranging
from a local installation or a network installation server to a mass deployment using a

remote-controlled, highly-customized, and automated installation technique.

Livro “Administration Guide”
Covers system administration tasks like maintaining, monitoring and customizing an

initially installed system.

Livro “Virtualization Guide”
Describes virtualization technology in general, and introduces libvirt—the unified

interface to virtualization—and detailed information on specific hypervisors.

Livro “Storage Administration Guide”
Provides information about how to manage storage devices on a SUSE Linux Enterprise

Server.

Livro “AutoYaST”
AutoYaST is a system for unattended mass deployment of SUSE Linux Enterprise Server
systems using an AutoYaST profile containing installation and configuration data. The
manual guides you through the basic steps of auto-installation: preparation, installation,

and configuration.
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Livro “Security and Hardening Guide”

Introduces basic concepts of system security, covering both local and network security
aspects. Shows how to use the product inherent security software like AppArmor or the

auditing system that reliably collects information about any security-relevant events.

Livro “Hardening Guide”

Deals with the particulars of installing and setting up a secure SUSE Linux Enterprise
Server, and additional post-installation processes required to further secure and harden
that installation. Supports the administrator with security-related choices and decisions.

Livro “System Analysis and Tuning Guide”

An administrator's guide for problem detection, resolution and optimization. Find how to
inspect and optimize your system by means of monitoring tools and how to efficiently
manage resources. Also contains an overview of common problems and solutions and of

additional help and documentation resources.

Livro “Subscription Management Tool Guide”

An administrator's guide to Subscription Management Tool—a proxy system for SUSE
Customer Center with repository and registration targets. Learn how to install and
configure a local SMT server, mirror and manage repositories, manage client machines,

and configure clients to use SMT.

Livro “"GNOME User Guide”

2

Introduces the GNOME desktop of SUSE Linux Enterprise Server. It guides you through
using and configuring the desktop and helps you perform key tasks. It is intended mainly
for end users who want to make efficient use of GNOME as their default desktop.

Comentdarios

Véarios canais de comentdrio estao disponiveis:

Solicitacdes de bugs e aperfeicoamentos

XV

Para ver as opc¢oes de servicos e suporte disponiveis ao seu produto, consulte http://
WWWw.suse.com/support/a.

A comunidade fornece ajuda para o openSUSE. Visite https://en.opensuse.org/
Portal:Support # para obter mais informacdes.

Para relatar bugs de um componente de produto, va para https://scc.suse.com/support/

requests 7, efetue login e clique em Criar Novo.

Comentarios | SLES 12 SP5
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Comentarios do usuario
No6s queremos saber a sua opinido e receber sugestoes sobre este manual e outras
documentacoes incluidas neste produto. Use o link “Report Bug” (Relatar Bug) ao lado de

cada titulo para enviar um feedback por meio do SUSE Bugzilla.

Correio
Para fazer comentérios sobre a documentacao deste produto, vocé também pode enviar
um e-mail para doc-team@suse. com. Inclua o titulo do documento, a versao do produto e
a data de publicacao da documentacao. Para relatar erros ou fazer sugestdes de melhorias,
descreva resumidamente o problema e informe o respectivo niimero de secao e pagina (ou
URL).

3 Convenc¢des da documentagao
Os seguintes avisos e convencoes tipograficas sdo usados nesta documentacao:

® /etc/passwd: nomes de diretério e arquivo

MARCADOR: substitua MARCADOR pelo valor real

® PATH: a variavel de ambiente PATH

1s, - -help: comandos, op¢Oes e parametros

® user: usuarios ou grupos

nome do pacote : nome de um pacote

® ALt , ALt —F1 : uma tecla ou uma combinacao de teclas a serem pressionadas; as teclas

sao mostradas em letras maitisculas como aparecem no teclado
® Arquivo, Arquivo > Gravar Como: itens de menu, botoes

o Este paragrafo é relevante apenas para a arquitetura AMD64/Intel 64. As setas
marcam o inicio e o fim do bloco de texto. ]
Este pardgrafo é relevante apenas para as arquiteturas Z e POWER da IBM.

As setas marcam o inicio e o fim do bloco de texto. {]

* Pinguins Dangcarinos (Capitulo Pinguins, 1Outro Manual): E uma referéncia a um capitulo

de outro manual.
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® Comandos que devem ser executados com privilégios root. Geralmente, vocé também
pode usar o comando sudo como prefixo nesses comandos para executa-los como usuério

nao privilegiado.

root # command
tux > sudo command

® Comandos que podem ser executados por usudrios sem privilégios.

tux > command

® Avisos

Atencdo: Mensagem de Aviso

Informacgoes vitais que vocé deve saber antes de continuar. Avisa sobre problemas

de seguranca, potencial perda de dados, danos no hardware ou perigos fisicos.

o Importante: Aviso Importante

Informacoes importantes que vocé deve saber antes de continuar.

@ Nota: Lembrete

Informacoes adicionais, por exemplo, sobre diferencas nas versdes do software.

@ Dica: Dica

Informacgoes tteis, como uma diretriz ou informacao pratica.
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1 Nog¢des basicas sobre a area de trabalho do
GNOME

Esta secdo descreve as convencoes, o layout e as tarefas comuns da area de trabalho do GNOME,

conforme implementado no seu produto.

O GNOME é uma interface gréafica de facil utilizacdo, que pode ser personalizada de acordo
com suas necessidades e preferéncias pessoais. Esta secao descreve a configuracao padrao do
GNOME. Se vocé ou o administrador do sistema modificar os padroes, alguns aspectos poderao

ser diferentes, como a aparéncia ou as combinacdes de teclas.

@ Nota: Configuracdes de sessdo incluidas
Algumas versoes do SUSE Linux Enterprise incluem trés configuragoes de sessao diferentes
com base no GNOME. Sao elas: GNOME, GNOME Classic e SLE Classic. A versao descrita
neste documento é a configuracao padrao do SUSE Linux Enterprise Desktop denominada
SLE Classic.

1.1 Efetuando login

Em geral, todos os usuarios devem se autenticar, exceto se Auto Login estiver habilitado para
determinado usudrio. Nesse caso, o usudrio especifico serd conectado automaticamente quando
o sistema for iniciado. Isso poderd economizar algum tempo, principalmente se o computador
for usado por uma tnica pessoa. Isso pode afetar a seguranca da conta. O Auto Login pode
ser habilitado ou desabilitado durante a instalacdo ou a qualquer momento, usando o médulo
Gerenciamento de Usudrios e Grupos do YaST. Para obter mais informacodes, consulte o Livro

“Deployment Guide”, Capitulo 16 “Gerenciando usudrios com o YaST".

Se o computador estiver funcionando em um ambiente de rede e vocé nao for a Ginica pessoa
que usa a maquina, geralmente vocé terd de fornecer seu nome de usudrio e senha ao iniciar

o sistema.
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linux-5fgn.suse

FIGURA 1.1: TELA DE LOGIN DO GNOME

PROCEDIMENTO 1.1: LOGIN NORMAL

1. Se o seu nome aparecer na lista, clique nele.
Se o0 seu nome de usuéario nao aparecer na lista, clique em Ndo listado? (Nao esta na lista?).

Em seguida, digite seu nome de usuéario e clique em Avangar.

2. Digite sua senha e clique em Logon.

1.1.1 Alternando o tipo de sessdo antes do login

Para tentar uma das outras configuracdes de sessdo do GNOME ou algum outro ambiente de

area de trabalho, siga as etapas abaixo.

1. Na tela de login, clique em seu nome de usudrio ou digite-o, como faz normalmente.

2. Para mudar o tipo de sessdo, clique no icone de engrenagem. Um menu é exibido.
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Cancelar

GNOME

SLE Classico

FIGURA 1.2: TELA DE LOGIN DO GNOME — TIPO DE SESSAO

3. No menu, selecione uma das entradas. Dependendo da sua configuracdo, pode haver

opcoes diferentes, mas a selecdo padrao é a seguinte.

GNOME
Configuracdo do GNOME 3 muito semelhante ao design de upstream. Seu foco é
interromper os usudrios o minimo possivel. No entanto, a inicializacao de aplicativos
e a comutacao entre eles funcionam de forma diferente das de muitos outros sistemas

operacionais de area de trabalho. Ela usa um tnico painel na parte superior da tela.

GNOME Classic
Configuracao do GNOME 3 desenvolvida para atrair os usuarios antigos do GNOME

2. A area de trabalho tem dois painéis, um na parte superior e outro na parte inferior.

lceWM
Area de trabalho bem bésica desenvolvida para usar poucos recursos. Ela podera ser

usada como fallback, se outras op¢des ndo funcionarem ou ficarem muito lentas.
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SLE Classic (padrao)
A éarea de trabalho padrao do SUSE Linux Enterprise, desenvolvida para atrair
usudrios de versoes mais antigas do SUSE Linux Enterprise e usuéarios do Microsoft*
Windows*. Essa area de trabalho é uma configuracdao do GNOME 3 e usa um dnico

painel posicionado na parte inferior da tela.

4. Digite sua senha na caixa de texto e clique em Logon.

Ap6s alternar para outro tipo de sessdo uma vez, a sessdo escolhida se tornaré a sessdo padrao.

Para reverté-lo, repita as etapas acima.

1.1.2 Ferramentas assistivas

No canto superior direito, ha os icones de status e o menu de tecnologias assistivas. Ao clicar
nos icones de status, é aberto um menu que permite definir o volume do som e reiniciar ou

desligar a maquina.

1.2 Itens basicos da area de trabalho

A éarea de trabalho do GNOME aparece depois que vocé efetua login pela primeira vez. Ela

mostra um painel na parte inferior com os seguintes elementos (da esquerda para a direita):

Menu Aplicativos

Clique em Aplicativos no canto esquerdo para abrir um menu com todos os programas
instalados. Eles sao classificados em categorias diferentes para melhor visualizacao. Os
subitens sdao abertos automaticamente quando vocé posiciona o mouse sobre eles.

Clique em Visdo geral de atividades na parte inferior do menu Aplicativos para abrir a visao
geral de atividades, de onde é possivel iniciar programas e gerenciar os que ja estdo em
execucao.

Héa uma descricdo mais detalhada da visdo geral de atividades na Secdo 7.2.7, “Visdo geral

de atividades”.

Menu Lugares
Clique em Locais para abrir um menu com atalhos aos seus diretérios pessoais, midias de

armazenamento conectadas e recursos de rede.
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Alternador de tarefas
Todos os aplicativos que estiverem abertos na area de trabalho (na area de trabalho ativa)
serdao exibidos no meio do painel. E possivel colocar esses aplicativos em primeiro plano

clicando nos nomes deles.

Indicador de notificacdo (nem sempre visivel)
Quando hé notificacbes, por exemplo, de novas mensagens de e-mail ou bate-papo, ou
referentes a atualizacOes de sistema, é exibido um indicador. O indicador é um circulo azul
com o ntimero de notifica¢oes disponiveis exibido no meio. Clique no indicador para abrir

a Bandeja de Mensagens, na qual é possivel interagir com todas as notificacgoes.

Alternador de areas de trabalho
Esse menu permite selecionar uma area de trabalho (também chamada de area de trabalho
virtual) na qual trabalhar. Esse recurso ajuda vocé a trabalhar com muitas janelas. Por
exemplo, é possivel mover as janelas necessarias de um projeto para a area de trabalho 1,

e as de outro projeto para a area de trabalho 2.

Data e horario
O-dia-atual-da:semana-e-o-horédrio-aparecem-a-direita-do-alternador de &reas de trabalho.
Clique nele para abrir um menu no qual vocé pode acessar um calendério e ajustar as

configuragoes de data e horério.

icones de status
No canto direito do painel, sdo exibidos icones que mostram o status atual da conexao de
rede, o volume do som e o status de energia/bateria.
Clique nos icones para abrir um menu no qual é possivel ajustar o volume do som, o brilho
da tela, a conexao de rede e as configuracoes de energia. Clique nele para exibir as opgoes
de logout ou troca de usudrio.
Os trés icones na parte inferior do menu permitem, da esquerda para a direita, abrir a caixa

de didlogo Configuracoes do GNOME, bloquear a tela e desligar ou reiniciar o computador.
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FIGURA 1.3: AREA DE TRABALHO DO GNOME — SLE CLASSIC

1.2.1 Visao geral de atividades

A visdo geral de atividades é um modo de tela inteira que engloba todas as formas de comutacao
entre uma atividade e outra. Ela apresenta visualizacoes de todas as janelas abertas e icones
dos aplicativos favoritos e em execucdo. Ela também integra as funcionalidades de pesquisa e

navegacao.

1.2.1.1  Abrindo a visao geral de atividades

Ha vérias formas de abrir a visdo geral de atividades:
® Abra o menu Aplicativos no painel inferior e selecione Visdo geral de atividades.
® Pressione Meta .

® Mova vigorosamente o cursor do mouse até o canto superior esquerdo (denominado hot

corner).

7 Visdo geral de atividades | SLES 12 SP5



1.2.1.2 Usando a visao geral de atividades

A seguir, ha uma explicacdo das partes mais importantes da visdo geral de atividades.

Painel

Painel é a barra posicionada na parte central esquerda. Ele inclui os aplicativos favoritos e
todos os aplicativos com janelas abertas. Se vocé mover o ponteiro do mouse sobre um dos
icones, o GNOME exibird o nome do aplicativo correspondente préximo. Uma luz clara
indica que o aplicativo estd em execucdo e tem, no minimo, uma janela aberta.

Clique o botao direito do mouse em um icone para abrir um menu com acoes diferentes,
dependendo do programa associado. Usando a opcdo Adicionar a Favoritos, é possivel
inserir o icone do aplicativo no Painel permanentemente. Para remover o icone de um
programa do Painel, selecione Remover de Favoritos. Para reposicionar um icone, use o

mouse para arrasta-lo até a nova posicao.

Caixa de pesquisa
Na parte superior, hd uma caixa de pesquisa que vocé pode usar para localizar aplicativos,
configuracoes e arquivos em seu diretério pessoal.
Para pesquisar, vocé ndo precisa clicar na caixa de pesquisa. Vocé podera comecar a digitar
diretamente apés abrir a visdo geral de atividades. A pesquisa comeca imediatamente, vocé

nao precisa pressionar Enter .

Seletor de area de trabalho
A direita, ha uma visdo geral das 4reas de trabalho disponiveis. Para alternar para a 4rea
de trabalho selecionada, clique na respectiva visualizacao.
Para mover uma janela de uma area de trabalho para outra, arraste a visualizacao da janela

de uma visualizacdo da area de trabalho para outra.

1.2.2 Iniciando programas

Para iniciar um programa, vocé tem varias opcoes:

® No painel inferior, clique em Aplicativos e selecione o programa desejado no menu

hierarquico.

® Abra a visao geral de atividades pressionando Meta . Agora, clique no icone do aplicativo
ou pesquise um aplicativo. Se vocé nao sabe o nome exato do aplicativo, pode pesquisar

nomes de categoria genéricos, como “editor de imagens”.
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H& mais informacoes sobre a visdo geral de atividades na Secdo 7.2.7, “Visdo geral de

atividades”.

® Se vocé sabe o comando exato para iniciar o programa, pressione Alt—F2 | digite o
comando na caixa de didlogo e pressione Enter .
Observe que o tnico botdo exibido na janela é denominado Fechar, que fecha a janela

realmente.

1.3 Pausando ou concluindo sua sessao

Quando vocé termina de usar o computador, ha vérias formas de concluir a sessdao. Qual forma
é ideal em determinada situacdo depende de quanto tempo vocé fica ausente e se vocé estd

preocupado com o consumo de energia, dentre outras coisas.

® Bloquear o computador. Pause a sessdo, mas mantenha o computador ligado. Garanta
que ninguém veja ou mude seu trabalho enquanto estiver fora durante um intervalo.
Outros usudrios podem efetuar login e trabalhar nesse meio tempo. Outros usuarios podem

encerrar o computador, mas um prompt os avisard que vocé ainda esta conectado.

¢ Efetuar logout. Conclua a sessdo atual, mas deixe o computador ligado para que outros

usudrios possam efetuar login.
® Desligar. Conclua a sessao atual e desligue o computador.

¢ Reiniciar. Conclua a sessao atual e reinicie o computador. A reinicializacdo é necessaria

para aplicar algumas atualizagoes de sistema.

® Suspender o computador. Pause a sessdo e coloque o computador em um estado no
qual ele consuma o minimo de energia. E possivel configurar o modo de suspensio para
bloquear sua tela, assim ninguém poderd ver nem modificar seu trabalho. Geralmente, o
acionamento do computador é muito mais rdpido do que sua inicializacao completa.

Esse modo também é conhecido como suspender para RAM, adormecido ou standby.

1.3.1 Bloqueando a tela

Para bloquear a tela, clique nos icones de status a direita do painel principal e clique no icone

de cadeado.
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Quando vocé bloqueia a tela, aparece primeiro uma cortina com relégio. Depois de algum tempo,
a tela ficara preta. Para desbloquear a tela, mova o mouse ou pressione uma tecla para exibir a

caixa de didlogo da tela bloqueada. Digite sua senha e pressione Enter para desbloquear a tela.

1.3.2 Efetuando logout ou alternando usuarios

1. Clique nos icones de status a direita do painel principal para abrir o menu.
2. Clique em seu nome de usuario.

3. Selecione uma das seguintes opcoes:

Efetuar Logout

Faz com que vocé efetue logout da sessao atual e retorne a tela de Login.

Alternar Usudrio

Suspende sua sessdo, permitindo que outro usudrio efetue login e use o computador.

Configuracgdes de conta

Vocé serd levado as configuracdes do usuario onde poderd mudar a senha.

1.3.3 Reiniciando ou encerrando o computador

1. Clique nos icones de status a direita do painel principal para abrir o menu.
2. Clique no icone Desligar na parte inferior direita do menu.

3. Selecione uma das seguintes opcoes:

Desligar
Efetua seu logout da sessdo atual e desliga o computador.
Reiniciar

Efetua seu logout da sessdo atual e reinicia o computador.

1.3.4 Suspendendo o computador

1. Clique nos icones de status a direita do painel principal para abrir o menu.
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2. Mantenha a tecla Alt pressionada. O icone de liga/desliga na parte inferior direita do

menu muda para um icone de pausa. Clique no icone de pausa.
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2 Working with Your Desktop

In this chapter you will learn how to work with files and burn CDs. You will also find out how

to perform regular tasks with your desktop.

2.1 Managing Files and Directories
You can open GNOME Files in multiple ways:

e Click Applications > Accessories > Files.

® Open the Activities Overview and search for files.

¢ On the desktop, double-click Home.

¢ Open the Places menu and select any entry, such as Home.
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FIGURA 2.1: FILE MANAGER

The elements of the GNOME Files window include the following:

Toolbar
The toolbar contains back and forward buttons, the path bar, a search function, elements
to let you change the layout of the content area, and the application menu.
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Menu
The menu is the last icon on the toolbar. It lets you perform many tasks, such as opening

the preferences dialog, creating a new directory or opening a new window or tab.

Sidebar
The sidebar lets you navigate between often-used directories and external or network

storage devices. To display or hide the sidebar, press F9 .

Content Area
Displays files and directories.

Use the icons in the top right part of the window to switch between list and grid icon view.

Context Menus
Open a context menu by right-clicking inside the content area. The items in this menu
depend on where you right-click.
For example, if you right-click a file or directory, you can select items related to the file or
directory. If you right-click the background of a content area, you can select items related
to the display of items in the content area.

Floating Statusbar

The floating statusbar appears when a file is selected. It displays the file name and size.

2.1.1  Key Combinations

The following table lists a selection of key combinations of GNOME Files.

TABELA 2.1: GNOME FILES KEY COMBINATIONS

Key Combination Description
Alt —« / ALt —- Go backward/go forward.
Alt — 1 Open the parent directory.
o, B, N E Select an item.
Alt — 1 or Enter Open an item.
Alt — Enter Open an item's Properties dialog.
Shift — Alt — Open an item and close the current directory.
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Key Combination Description

ctrl —L Transform the path bar from a button view to a text

box.

Exit this mode by pressing Enter (go to the location)

or Esc (toremain in the current directory).

/ Transform the path bar from a button view to a text
box and replace the current path with /.

Alt — Home Open your home directory.

Any number or letter key Start a search within the current directories and their
subdirectories. The character you pressed is used as
the first character of the search term. Search happens

as you type, you do not need to press Enter .

ctri — T Start a search within the current directories and their
subdirectories. The character you pressed is used as
the first character of the search term. Search happens

as you type, you do not need to press Enter .

Del Moves the selected file or directory to the trash, from

which it can be restored with Undo.

2.1.2 Compressing Files or Directories

Sometimes, it is useful to archive or compress files, for example:
® You want to attach an entire directory, including its subdirectories, to an e-mail.
® You want to attach a large file to an e-mail.

® You want to save space on your hard disk and have files you rarely use.

In all these cases, you can create a compressed file, such as a ZIP file, which can contain multiple
original files. How much smaller the compressed version is than the original depends on the
file type. Many video, image and office document formats are already compressed and will only

become marginally smaller.
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1. In the GNOME Files content area, right-click the directory you want to archive, then click

Compress.
2. Accept the default archive file name or provide a new one.

3. Select a file extension from the drop-down box.

e .zip files are supported on most operating systems, including Windows*.
® .tar.gz files are compatible with most Linux* and Unix* systems.

e .7z files usually offer better compression ratios than other formats, but are not as
widely supported.

4. Specify a location for the archive file, then click Create.

To extract an archived file, right-click the file, then select Extract Here. You can also double-

click the compressed file to open it and see which files are included.

For more information on compressed files, see Secdo 2.70, “Creating, Displaying, and Decompressing

Archives”.

2.1.3 Burning a CD/DVD

If your system has a CD or DVD writer, you can use GNOME Files to burn CDs and DVDs. If
you want to burn an audio CD or need more control over the result, see Copitulo 20, Brasero:
Burning CDs and DVDs.

1. Open GNOME Files.
2. Insert a blank medium.

3. Find the files you want to add to the medium and drag them to the sidebar item called
Blank CD-R Disc. (The label may read slightly differently, depending on the type of medium
you inserted.) When your mouse pointer is over the sidebar item, a small + should appear

next to the pointer.
4. When you have dragged all files onto the sidebar item Blank CD-R Disc, click it.
5. Provide a name next to Disc Name or keep the proposal.

6. Click Write to Disc.
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7. In the appearing dialog CD/DVD Creator, make sure the right medium is selected. Then
click Burn.
The files are burned to the disc. This can take a few minutes, depending on the amount

of data being burned and the speed of your burner.

8. After the medium has been burned, it will be ejected from the drive. In the window CD/

DVD Creator, you can click Close.

To burn an ISO disc image, first insert a medium, then double-click the ISO file in GNOME Files.
In the dialog Image Burning Setup, click Burn.

2.1.4 Creating a Bookmark

Use the bookmarks feature in GNOME Files to quickly jump to your favorite directories from
the sidebar.

1. Switch to the directory for which you want to create a bookmark in the content area.

2. Click the list icon, then select Bookmark this Location from the menu.

The bookmark now appears in the sidebar, with the directory name as the bookmark name.

3. (Opcional) If you want, you can change the name of the bookmark. This does not affect the
name of the bookmarked directory itself. To change the name, right-click the new sidebar

item and select Rename.

4. (Opcional) If you want, you can change the order in which the bookmarks are displayed.

To reorder, click a bookmark and drag it to the desired location.

To switch to a bookmarked directory, click the appropriate sidebar item.

2.1.5 Accessing Remote Files

You can use GNOME Files to access files on remote servers. For more information, see Capitulo 5,

Accessing Network Resources.
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2.2 Accessing Removable Media

To access CDs/DVDs or flash disks, insert or attach the medium. An icon for the medium is
automatically created on the desktop. For many types of removable media, a GNOME Files
window pops up automatically. If GNOME Files does not open, double-click the icon for that
drive on the desktop to view the contents. In GNOME Files, you will see an item for the medium

in the sidebar.

Atencao: Unmount to Prevent Data Loss
Do not physically remove flash disks immediately after using them. Even when the system
does not indicate that data is being written, the drive may not be finished with a previous

operation.

In the sidebar of GNOME Files, click the Eject icon next to the medium to safely remove

or unmount the drive.

2.3 Searching for Files

There are multiple ways to search for files or directories. In all cases, the search will be performed
on file and directory names. Searching by file size, modification date and other properties is
only partially possible in the preinstalled graphical tools. Such searches are easier to do on the

command line.

Using GNOME Files
In GNOME Files, navigate to the directory from which you want to start the search. Then
start typing the search term. To search for objects with a certain modification date or file

type, click the arrow-down icon of the search box and modify the properties.

Using the Activities Overview
Open the Activities Overview by pressing Meta . Then start typing the search term. The

search will be performed within your home directory.

Using the Desktop Search application
Click Applications > Accessories > Desktop Search. Enter the search term in the text box

Search. The search will be performed within your home directory.
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2.4 Copying Text Between Applications

Copy and paste works the same as in other operating systems. First select the text, so that it
appears highlighted, usually in blue. Then press Ctrl — ¢ . Now move the keyboard focus to the

right position. Finally, to insert the text, press Ctrl —V .

To copy or paste in the terminal, additionally press shift together with the above key
combinations.

An alternative way of using copy and paste is described in the following. First select the text. To
paste the text, middle-click over the position where you want the text to be pasted. As soon as
you make another selection, the text from the original selection will be replaced in the clipboard.
When copying information between programs, you must keep the source program open and

paste the text before closing it. When a program closes, any content from that application that

is on the clipboard is lost.

2.5 Managing Internet Connections

To surf the Web or send and receive e-mail messages, you must have configured an Internet
connection. If you have installed SUSE Linux Enterprise Server on a laptop or a mobile device,
NetworkManager is enabled by default. On the GNOME desktop, you can then establish Internet
connections with NetworkManager as described in Livro “Administration Guide”, Capitulo 38 “Using
NetworkManager”, Se¢éio 38.3 “Configuring Network Connections”.

Depending on your environment, you can choose in YaST which basic service to use for setting
up network connections (either NetworkManager or wicked). For details, see Livro “Administration
Guide”, Capitulo 17 “Basic Networking”, Secdo 17.4.1.1 “Configuring Global Networking Options”.

2.6 Exploring the Internet

The GNOME desktop includes Firefox, a Mozilla*-based Web browser. You can start it by clicking

Applications > Internet > Firefox.

You can type an address into the location bar at the top or click links in a page to move to
different pages, like in any other Web browser.

For more information, see Capitulo 14, Firefox: navegando na Web.
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2.7 E-mail and Scheduling

For reading and managing your mail and events, use Evolution. Evolution is a groupware

program that makes it easy to store, organize and retrieve your personal information.

Evolution seamlessly combines e-mail, a calendar, an address book, and a memo and task list in
one easy-to-use application. With its extensive support for communications and data interchange
standards, Evolution can work with existing corporate networks and applications, including

Microsoft* Exchange.
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To start Evolution, click Applications > Internet > Evolution.

The first time you start Evolution, it prompts you with a few questions to set up a mail account
and import mail from an old mail client. Then it shows you how many new messages you
have and lists upcoming appointments and tasks. The calendar, address book and mail tools are

available in the shortcut bar on the left.

For more information, see Capitulo 15, Evolution: E-Mailing and Calendaring.
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2.8 Opening or Creating Documents with LibreOffice

For creating and editing documents, LibreOffice is installed with the GNOME desktop.
LibreOffice is a complete set of office tools that can both read and save Microsoft Office file
formats. LibreOffice has a word processor, a spreadsheet, a database, a drawing tool and a

presentation program.
To start LibreOffice, click Applications > Office > LibreOffice.

For more information, see Capitulo 10, LibreOffice: The Office Suite.

2.9 Controlling Your Desktop’s Power Management

To see the state of the computer battery on your laptop, check the battery icon in the right
part of the panel. On certain events, such as a critically low battery state, GNOME will display
notifications informing you about the event.

You can open the power settings via Applications > System Tools > Settings > Power.

For more information, see Secdo 3.3.2, “Definindo configuracdes de energia”.

2.10 Creating, Displaying, and Decompressing
Archives

You can use the Archive Manager application (also known as File Roller) to create, view, modify
or unpack an archive. An archive is a file that acts as a container for other files. An archive can
contain many files, directories and subdirectories, usually in compressed form. Archive Manager
supports common formats such as zip, tar.gz, tar.bz2, 1zh, and rar. You can use Archive

Manager to create, open and extract a compressed non-archive file.
To start Archive Manager, click Applications > Utilities > Archive Manager.

If you already have a compressed file, double-click the file name in GNOME Files to view the

contents of the archive in Archive Manager.
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2.10.1 Opening an Archive

1. In Archive Manager, click Open.

3. Click Open.

21

2. Select the archive you want to open.

Archive Manager displays the following:

e The archive name in the titlebar.

Modificado

03 agosto 2016, 14:...
03 agosto 2016, 08....
03 agosto 2016, 07:...
03 agosto 2016, 07....
03 agosto 2016, 11:...
03 agosto 2016, 08....
03 agosto 2016, 07:...
03 agosto 2016, 13....
03 agosto 2016, 07:...
03 agosto 2016, 07....
03 agosto 2016, 08:...
03 agosto 2016, 14...
03 agosto 2016, 14:...
03 agosto 2016, 07...

03 agosto 2016, 07....
03 annetn 2001A 07

e The archive contents in the content area.

recognize, the application displays an error message.

To open another archive, click Open again. Archive Manager opens each archive in a new
window. To open another archive in the same window, you must first select Close from
the menu in the right part of the window to close the current archive, then click Open.

If you try to open an archive that was created in a format that Archive Manager does not

Opening an Archive | SLES 12 SP5



4. To display the archive's properties, click the last icon in the titlebar and select Properties.
Details like name, location, type, last modification, number of files, size, and compression

ratio are shown.

2.10.2 Extracting Files from an Archive

1. In Archive Manager, select the files that you want to extract.

2. Click Extract.

3. Specify the directory where Archive Manager will extracts the files.

4. Choose from the following extraction options:

Option Description

All files Extracts all files from the archive.

Selected files Extracts the selected files from the archive.

Files Extracts from the archive all files that match the

specified pattern.

Keep directory structure Reconstructs the directory structure when extracting
the specified files.

For example, you specify /tmp in the Filename text

box and extract all files. The archive contains a
subdirectory called doc. If you select the Keep directory
structure option, Archive Manager extracts the contents
of the subdirectory to /tmp/doc.

If you do not select the Keep directory structure option,
Archive Manager does not create any subdirectories.
Instead, it extracts all files from the archive, including

files from subdirectories, to /tmp.

Do not overwrite newer files If not active, the Archive Manager overwrites any files
in the destination directory that have the same name as
the specified files.
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Option Description

If you select this option, Archive Manager does not
extract the specified file if an existing file with the

same name already exists in the destination directory.

5. Click Extract.
To extract an archived file in a file manager window without opening Archive Manager,
right-click the file and select Extract Here.
The Extract operation extracts a copy of the specified files from the archive. The extracted
files have the same permissions and modification date as the original files that were added

to the archive.

The Extract operation does not change the contents of the archive.

2.10.3 Creating Archives

1. In Archive Manager, click the main menu icon in the top left part of the window and

select New Archive.
2. Specify the name and location of the new archive.
3. Select an archive type from the drop-down box.

4. Click Create.
Archive Manager creates an empty archive, but does not yet write the archive to disk.
Archive Manager writes a new archive to disk only when the archive contains at least one
file. If you create a new archive and quit Archive Manager before you add any files to the

archive, the archive will be deleted.

5. Add files and directories to the new archive:

a. Click Add Files and select the files or directories you want to add.

b. Click Add.

Archive Manager adds the files to the current directory in the archive.

You can also add files to an archive in a file manager window without opening Archive Manager.

See Secdo 2.1.2, “Compressing Files or Directories” for more information.
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2.11 Taking Screenshots

You can take a snapshot of your screen or of an individual application window by using the
Take Screenshots utility. Start it by pressing Print to take a screenshot of the entire desktop

or by pressing Alt —Print to take a screenshot of the currently active window or dialog.
The screenshots are automatically saved to your ~/Pictures directory.

You can also use GIMP to take screenshots. (For more information on GIMP, see Capitulo 18,
GIMP: Manipulating Graphics). In GIMP, click File > Create > Screenshot, select an area, choose a

delay and then click Snap.

2.12 Viewing PDF Files

Documents that need to be shared or printed across platforms can be saved as PDF (Portable
Document Format) files. Document Viewer (also known as Evince) can open PDF files and many
similar file types, such as XPS, DjVu, or TIFF.

@ Nota: Rare Display Issues
In rare cases, documents will not be displayed correctly in Document Viewer. This
can happen, for example, with certain forms, animations or 3D images. In such cases,
ask the authors of the file what viewer they recommend. However, in some cases the

recommended viewer will not work on Linux.
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FIGURA 2.3: DOCUMENT VIEWER

To open Document Viewer, double-click a PDF file in a file manager window. Document Viewer
will also open when you download a PDF file from a Web site. To open Document Viewer without

a file, select Applications > Office > Document Viewer.

To view a PDF file in Document Viewer, click the cog wheel icon to open the menu and select
Open. Now locate the desired PDF file and click Open.

Use the navigation icons at the top of the window or the thumbnails in the left panel to navigate
through the document. If your PDF document provides bookmarks, you can access them in the

left panel of the viewer.

2.13 Obtaining Software Updates

When you connect to the Internet, the updater applet automatically checks whether software
updates for your system are available. When important updates are available, you will receive

a notification on your desktop.

For detailed information on how to install software updates with the updater applet and how
to configure it, refer to the chapter about installing and removing software in Livro “Deployment

Guide”, Capitulo 13 “Instalando ou removendo software”, Secdo 13.5 “Mantendo o sistema atualizado”.
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2.14 For More Information

Along with the applications described in this chapter for getting started, you can use many other
applications on GNOME. Find detailed information about these applications in the other parts

of this manual.

To learn more about GNOME and GNOME applications, see http://www.gnome.org 7.

To report bugs or add feature requests, go to http://bugzilla.gnome.org 7.
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3 Personalizando configuracdes

Vocé pode mudar a aparéncia e o comportamento da area de trabalho do GNOME para adequé-

la as suas preferéncias e necessidades. Algumas possiveis mudancas de configuracoes sao:

® Configuracao de teclado e mouse, conforme descrito na Secdo 3.3.3, “Modificando os atalhos

de teclado” e na Secdo 3.3.4, “Configurando o mouse e o touchpad”

¢ Segundo plano da area de trabalho, conforme descrito na Secdo 3.2.7, “Mudando o segundo

plano da drea de trabalho”

® Sons, conforme descrito na Secdo 3.3.7, “Definindo configuracées de som”

E possivel mudar essas e outras configuragoes na caixa de didlogo Todas as configuragaes.

3.1 Caixa de dialogo Configuracdes do GNOME

O YaST é uma ferramenta de todo o sistema independente da area de trabalho usada
para configurar a maioria dos aspectos de instalacdo do produto, j4 a caixa de didlogo de
configuragoes é uma ferramenta de configuracdo do GNOME com foco mais voltado a aparéncia,

configuracoes pessoais e preferéncias da area de trabalho do GNOME.

Para acessar a caixa de didlogo de configuracées do GNOME, clique em Aplicativos > Ferramentas
do Sistema > Configuragdes. A caixa de didlogo é dividida nestas trés categorias:

Pessoal
Nessa categoria, vocé pode mudar o segundo plano da 4rea de trabalho ou a tela de
bloqueio e definir as configuracdes de idioma. Para obter mais informacoes, consulte a

Secdo 3.2, “Pessoal”.

Hardware
Permite configurar componentes de hardware, como monitores, impressoras, mouses/
touchpads, adaptadores de rede e dispositivos de som. E possivel também mudar as
configuracoes de combinacéo de teclas e configurar recursos de economia de energia. Para

obter mais informacdes, consulte a Secdo 3.3, “Hardware”.
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Sistema
Permite definir configuracoes do sistema, como data e horério, se é para iniciar o software
ao inserir discos flash ou compartilhar sua tela com outras pessoas. E possivel também
configurar contas de usudrios. E possivel também iniciar o YaST dessa tela, embora ele
também esteja disponivel separadamente no menu. Para obter mais informacdes, consulte

a Secdo 3.4, “Sistema”,

# Todas configuragdes | Q - X
Pessoal
- y LELE =
el « 2 = 0
) & & A T o
Contas on-line Editor dconf Ferramenta IcedTea-Web  Menu principal Notificacbes
de ajustes Control Panel
= @ @ [
! i 3 =
Pesquisa Pesquisae Plano de Privacidade Regido &
indexacdo fundo idioma
Hardware
A I — n =
B » Ik 2 ¢ =
Bluetooth Cor Energia Impressoras Mouse & Rede
touchpad
Som Tablet Wacom Teclado Telas

FIGURA 3.1: CAIXA DE DIALOGO CONFIGURAGOES DO GNOME

Para mudar algumas configuracoes de todo o sistema, o centro de controle solicita a senha root
e inicia o YaST. Essas configuracoes geralmente referem-se ao administrador (incluindo quase
todo o hardware, a interface grafica de usudrio, acesso a Internet, configuracoes de seguranca,
administracdo de usudrio, instalacao de software, atualizacoes e informac¢oes do sistema). Siga
as instrugoes no YaST para definir essas configuracGes. Para obter informacées sobre o uso do

YaST, consulte os textos da ajuda integrada do YaST ou o Livro “Deployment Guide”.
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Este capitulo explica as configura¢oes individuais que vocé pode mudar diretamente na caixa

de didlogo Configuracoes do GNOME, sem precisar usar o YaST.

3.2 Pessoal

As secOes a seguir apresentam exemplos de como configurar alguns aspectos pessoais da area

de trabalho do GNOME, como idiomas usados ou fundo da area de trabalho.

3.2.1 Mudando o segundo plano da area de trabalho

O segundo plano é a imagem ou a cor aplicada a &rea de trabalho. Vocé também pode

personalizar a imagem que aparece quando a tela estd bloqueada.

Para mudar o fundo da area de trabalho ou a tela de bloqueio:

1. Clique em Aplicativos > Ferramentas do Sistema > Configuragdes > Fundo.
2. Clique em Fundo ou Bloquear Tela.

3. Clique em Wallpapers (Papéis de Parede), Imagens ou Cores.
Os papéis de parede sao imagens pré-configuradas distribuidas com o sistema. Imagens
sdo suas préprias imagens do diretério Pictures (~/Pictures). Cores sdo as cores

predefinidas escolhidas por desenvolvedores do GNOME.

4. Escolha uma opc¢éao na lista.

5. Quando estiver satisfeito com suas escolhas, clique em Selecionar.

3.2.2 Definindo configuracdes de idioma

E possivel configurar o SUSE Linux Enterprise Server para usar qualquer um dos vérios idiomas.
A configuracao de idioma determina o idioma das caixas de didlogo e dos menus, e também
pode determinar o layout do teclado e do relégio.

Para definir as configuracoes de idioma, clique em Aplicativos > Ferramentas do

Sistema > Configuragoes > Regido e Idioma.
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Nesse local, é possivel escolher:

¢ Idioma da interface.
* Formatos de data e nimero, moeda e opcoes relacionadas.

* Fontes de entrada (layout do teclado). Para idiomas néo alfabéticos, pode haver outras

configuracoes.

@ Nota: As configurac¢des feitas usando ibus-setup ndo tém
efeito

No GNOME, as configuragoes feitas usando ibus-setup nao tém efeito. Apenas é possivel
usar o ibus-setup para configurar o IceWM. Em vez disso, use sempre o aplicativo de

Configuracgoes:
® Para mudar os métodos de entrada, use o painel Regido e Idioma.

* Para mudar a combinacao de teclas que alterna entre os métodos de entrada, use o
painel Teclado. Nele, escolha a categoria Digitacdo e a entrada Alternar para proxima

fonte de entrada.

3.3 Hardware

Nas secoes a seguir vocé encontra exemplos de como configurar alguns aspectos de hardware da
area de trabalho do GNOME, como as preferéncias de teclado ou mouse, o manuseio de unidades

removiveis ou a resolucao de tela.

3.3.1 Definindo configuracdes de Bluetooth

O médulo Bluetooth permite definir a visibilidade da sua méquina por Bluetooth e conectar-
se aos dispositivos Bluetooth disponiveis. Para configurar a conectividade Bluetooth, siga estas

etapas:

1. Clique em Aplicativos > Ferramentas do Sistema > Configuragoes > Bluetooth para abrir o

modulo de configuracoes de Bluetooth.

2. Para usar Bluetooth, ative o switch Bluetooth.
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3. Para tornar seu computador visivel por Bluetooth, ative o switch Visibilidade. O
computador inicia a pesquisa por outros dispositivos Bluetooth visiveis nas proximidades
e exibe os resultados na lista Dispositivos. A principio, a lista pode estar vazia.

@ Nota: Visibilidade temporaria
O switch Visibilidade foi criado para ser usado apenas temporariamente. Vocé
somente precisa ativd-lo para a configuracdo inicial de uma conexdo com um

dispositivo Bluetooth. Depois que a conexao for estabelecida, desative o switch.

4. No dispositivo que vocé deseja conectar, ative a conectividade e visibilidade por Bluetooth.

5. Se o dispositivo desejado foi encontrado e aparece na lista, clique nele para estabelecer
uma conexao.

Vocé deveré confirmar se os PINs dos dois dispositivos correspondem.

6. Em caso afirmativo, confirme isso tanto no computador quanto no dispositivo.
Ambos agora estdo emparelhados. No computador, o dispositivo aparece na lista como

Conectado.

(3] < | Bluetooth -j - o x

Visivel como “linux-visv.suse” e habilitado para transferéncias Bluetooth
de arquivos. Os arquivos transferidos serdo colocados na pasta de
Downloads.

Dispositivos
K013 Desconectado

All types Ndo foi configurado

Dependendo do tipo de dispositivo, vocé pode vé-lo agora como um dispositivo de
armazenamento no GNOME Files, definir um volume para ele nas configuracées de Som,

etc.

Para conectar-se a um dispositivo Bluetooth emparelhado, selecione-o na lista. Na caixa de
didlogo que aparece, ative o switch Conexdo. E possivel enviar arquivos ao dispositivo conectado
usando o botdo Enviar Arquivos. Se vocé estiver conectado a um dispositivo como celular, podera
usé-lo como dispositivo de rede ativando a opcao apropriada.
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Para remover um dispositivo conectado da lista no computador, clique em Remover Dispositivo

e confirme a opcdo. Para remover o emparelhamento completamente, vocé também precisa

remové-lo do dispositivo.

3.3.2 Definindo configuracdes de energia

. Clique em Aplicativos > Ferramentas do Sistema > Configuragoes > Energia para abrir o médulo

de configuracoes de Energia.

. Na parte superior da caixa de didlogo, vocé vé o estado atual da bateria.

. Na secao Economia de Energia da caixa de didlogo, defina o Brilho da Tela para economizar

energia. E possivel também definir se é para escurecer a tela apés um periodo de
inatividade e especificar o intervalo de tempo. Vocé também pode definir se é para desligar

a rede wireless ap6s o periodo de inatividade.

. Na secdo do botdo de energia e suspensdo da caixa de didlogo, defina a Suspensdo Automdtica.

Ao clicar nessa opc¢do, uma caixa de didlogo separada é aberta.

Nela, é possivel ativar intervalos de suspensao automaticos e de horéario associados. Se vocé
estiver usando um computador com bateria, podera definir essas opcoes separadamente
para quando o computador estiver executando com energia de bateria ou ligado na
tomada.

E possivel também definir a acio executada ao pressionar o botdio de energia. Escolha
Hibernar para usar um modo no qual o computador é desligado completamente, mas grava

sua sessdo ativa no disco rigido. Se preferir, escolha Suspender ou Nada.

3.3.3 Modificando os atalhos de teclado

Para

modificar os atalhos de teclado, clique Aplicativos > Ferramentas do

Sistema > Configuragoes > Teclado.
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|T| Teclado - x

Acessibilidade Lancar o navegador de ajuda Help
Capturas de tela Configuragtes Tools
Digitacdo Lancar calculadora Calculator
Janelas Lancar o cliente de e-mail Mail
Lancar navegador web WAWW
Mavegacdo Fasta pessoal Explorer
Sistema Pesquisa Search
Som e midia

Atalhos personal...

e -

Para editar um atalho, clique na linha e mantenha pressionada as novas teclas ou pressione a tecla Backspace
para limpar.

FIGURA 3.2: CAIXA DE DIALOGO TECLADO

A caixa de didlogo Teclado mostra os atalhos de teclado que sdo configurados no sistema. Clique

nas categorias a direita para ver os atalhos atuais.

Para editar uma combinacdo de teclas, primeiro clique na linha. Para definir uma nova
combinacao de teclas, pressione as teclas. Para desabilitar um atalho, em vez disso, pressione

<- .

Para configurar as opcoes de acessibilidade de teclado, consulte a Secdo 4.4, “Deficiéncias de
mobilidade”. Para configurar o layout de teclado, consulte a Secdo 3.2.2, “Definindo configuracdes

de idioma”.

3.3.4 Configurando o mouse e o touchpad

Para modificar as opg¢des de mouse e touchpad, clique em Aplicativos > Ferramentas do
Sistema > Configuragoes > Mouse e Touchpad.
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Mouse
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Touchpad
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FIGURA 3.3: CAIXA DE DIALOGO DE CONFIGURACOES DO MOUSE E TOUCHPAD

® Na secao Geral da caixa de didlogo, vocé pode definir a orientacdo do Botdo principal

(esquerda ou direita).

® Na secdo Mouse da caixa de didlogo, use a opcao de velocidade do mouse para ajustar a

sensibilidade do ponteiro do mouse.

® Na secao Touchpad da caixa de didlogo, é possivel ligar e desligar o touchpad. Use a opcao
de velocidade do touchpad para ajustar a sensibilidade do ponteiro do touchpad. Também

é possivel desabilitar o touchpad ao digitar e habilitar cliques tocando no touchpad.

® Para testar as configuracoes, clique em Testar suas configuragoes e teste o dispositivo

apontador.

Para saber a configuracdo das opcdes de acessibilidade do mouse, consulte a Secdo 4.4,

“Deficiéncias de mobilidade”.
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3.3.5 Instalando e configurando impressoras

O médulo Impressoras permite conectar-se a qualquer servidor CUPS local ou remoto disponivel

e configurar impressoras.

Para iniciar o médulo Impressoras, clique em Aplicativos > Ferramentas do
Sistema > Configuragoes > Impressoras. Para obter informacoes detalhadas, consulte o Capitulo 6,

Gerenciando impressoras.

3.3.6 Configurando telas

Para especificar resolucdo e orientacdo da tela ou configurar vérias telas, clique em

Aplicativos > Ferramentas do Sistema > Configuragoes > Telas.
PROCEDIMENTO 3.1: MUDANDO AS CONFIGURACOES DO MONITOR

1. Para encontrar o monitor certo, procure os nimeros exibidos no canto superior esquerdo
de todos os monitores depois que vocé abrir a caixa de didlogo Tela. Para definir as opgoes

de um monitor, clique no item do monitor na lista. Uma nova caixa de didlogo é aberta.

2. Se forem conectados varios monitores ao computador, a parte esquerda da caixa de didlogo

permitird escolher como usa-los. E possivel escolher entre:

Principal

A tela que mostra o painel e mensagens importantes.

Exibicdo Secunddria

Um monitor que expande a area de trabalho do monitor principal.

Espelho
Um monitor que espelha a imagem no monitor principal. Em termos de resolucéo,

o menor denominador comum sera usado.

Desabilitar

Uma tela que nao é usada.

Para girar a imagem exibida, use os botdoes com as setas apontando para a esquerda e
direita. Para espelhar a imagem exibida, use o botao com o icone de seta dupla.

E possivel definir uma resoluciio diferente mudando o valor de Resolu¢do. Nem todas as
resolucoes geram uma imagem nitida e sem distor¢oes. Para descobrir a melhor resolugao

para o seu monitor, consulte o manual.
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Cancelar

3. Ao concluir, clique em Aplicar.

Os monitores serao reajustados. Isso pode levar varios segundos, e a tela podera ficar preta

ou distorcida durante esse tempo.

Em seguida, uma caixa de didlogo de confirmacao seré exibida.

4. Se a configuracdo estiver correta, clique em Keep Changes (Manter Mudancas).

Se a configuracdo nao estiver como vocé deseja, clique em Revert Settings (Reverter

Configuracgdes) ou aguarde 20 segundos. As mudancas serdo revertidas.

Samsung Electric Company 20"

Principal

Mostrar a barra superior e a Visdo Geral de Atividades
nesta exibicdo

Exibigdo Secundaria

Juntar esta exibigdo com outra para criar uma area
de trabalho extra

Espelho
Maostrar a tela existente nas duas exibigdes

Desabilitar
N&o usar esta exibigao

2 e

Tamanho

Taxa de proporgao

Resolugio

Taxa de atualizagdo

20"

43

‘ 800 x 600 (4:3) ~ ‘
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FIGURA 3.4: CAIXA DE DIALOGO DE CONFIGURACOES DE RESOLUCAO DO MONITOR

PROCEDIMENTO 3.2: MUDANDO A ORGANIZACAO DE VARIOS MONITORES

36

Se vocé usa vdrias telas, configure como elas serdo organizadas para que possa usar o

ponteiro do mouse apropriadamente entre os monitores.

1. Clique em Arrange Combined Displays (Organizar Telas Combinadas).

2. Para encontrar o monitor certo, procure os ntimeros exibidos no canto superior esquerdo

de todos os monitores. Clique na imagem do monitor e arraste-a para mové-la.

3. Ao concluir, clique em Aplicar.

4. Se a configuracdo estiver correta, clique em Keep Changes (Manter Mudancas).
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Se a configuracdo ndo estiver como vocé deseja, clique em Revert Settings (Reverter

Configuracoes) ou aguarde 20 segundos. As mudancas serdo revertidas.

3.3.7 Definindo configuracdes de som

A ferramenta Som permite gerenciar dispositivos de som e definir efeitos sonoros. Na parte
superior da caixa de didlogo, é possivel selecionar o volume de saida geral ou desligar o som

completamente.

Para abrir as configuracbes de som, clique em Aplicativos > Ferramentas do

Sistema > Configuragoes > Som.

Volume de saida: & [ 0 o

|
Nao amplificado 1003

Saida Entrada Efeitos de som Aplicativos

Escolha um dispositivo para saida de som:

:—i-:'f Saida analdgica - ES1371 / Creative Labs CT2518/ES1373 (AudioPCl 64V/128 / Creative CT4810/CT5803/CT5806 [Sound Blaster PCI])

Configuragdes para o dispositivo selecionado:

Balanco:

Perfil: Saida de Estéreo analogico b I I Testar alto-falantes

FIGURA 3.5: DEFININDO CONFIGURACOES DE SOM

3.3.7.1  Configurando dispositivos de som

Use a guia Saida para selecionar o dispositivo de saida de som. Abaixo da lista, escolha a

configuracdo de dispositivo de som de sua preferéncia, por exemplo, balanco.
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Use a guia Entrada para definir o volume do dispositivo de entrada ou colocar a entrada
temporariamente no mudo. Se vocé tem mais de um dispositivo de som, poderd também
selecionar o dispositivo padrao de entrada de dudio na lista Escolha um dispositivo para entrada

de som.

3.3.7.2 Configurando efeitos sonoros

Use a guia Efeitos de som para configurar se é para reproduzir um som, e como reproduzi-lo,

quando aparecerem caixas de mensagem.

Especifique o volume no qual reproduzir os efeitos sonoros em Volume de alerta. Vocé também
pode ativar e desativar os efeitos.

Selecione o Som de alerta para usar.

3.3.8 Projeto de Rede

Para  configurar opgoes de rede, «clique em  Aplicativos > Ferramentas  do

Sistema > Configuragoes > Rede.
Na caixa de didlogo exibida, é possivel configurar conexdes com fio ou wireless, proxies e VPNs.

Para saber mais sobre a configuracdo de conexdes de rede, consulte o Livro “Administration Guide”,
Capitulo 38 “Using NetworkManager”.

3.4 Sistema

Nas préoximas se¢oes, vocé encontrard exemplos de como configurar alguns aspectos do sistema
da 4rea de trabalho do GNOME. Alguns deles sdo aplicativos preferenciais, mudanca de senha

de usuério e preferéncias de compartilhamento de sessao.

Para saber mais como configurar as tecnologias assistivas, consulte o Capitulo 4, Tecnologias

assistivas.
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3.4.1 Mudando sua senha

Por motivos de seguranca, convém mudar a senha de login periodicamente. Para mudar sua

senha:

—

. Clique em Aplicativos > Ferramentas do Sistema > Configuragdes > Usudrios.
2. Clique no botdao com pontos ao lado de Senha.
3. Na primeira caixa de texto, digite sua senha atual.

4. Na préxima caixa de texto, digite uma nova senha.
E possivel também clicar no icone de engrenagem no fim da caixa de texto para gerar

uma senha aleatoria.

5. Digite outra vez a nova senha na tdltima caixa de texto para confirmé-la.

6. Clique em Mudar.

3.4.2 Configurando aplicativos preferenciais

1. Para mudar o aplicativo padrdo de vérias tarefas comuns, como navegac¢do na Internet,
envio de e-mails ou reproducao de arquivos multimidia, clique em Aplicativos > Ferramentas

do Sistema > Configuracoes > Detalhes.
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FIGURA 3.6: APLICACOES PREFERENCIAIS

2. Clique em Aplicativos padroes.

3. Selecione um dos aplicativos disponiveis na caixa suspensa. E possivel escolher um

aplicativo para gerenciar Web, correio, calendério, musica, videos ou fotografias.

3.4.3 Definindo as preferéncias de compartilhamento de sessao

Para abrir uma caixa de didlogo de configuracdo para compartilhar uma sessdao de area de
trabalho do GNOME entre varios usuérios e definir as preferéncias de compartilhamento de
sessdo, clique em Aplicativos > Ferramentas do Sistema > Configuragdes > Compartilhamento.

Importante: O compartilhamento de sessdes da area de
trabalho afeta a seguranca do sistema

O compartilhamento de sessoes de area de trabalho pode ser um risco a seguranca. Use

as opcoes de restricao disponiveis.
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Antes de compartilhar qualquer coisa, vocé precisa ativar o switch na parte superior da caixa
de dialogo. O switch também ajudara se vocé precisar desabilitar rapidamente todas as opcoes
de compartilhamento.

¢ Para compartilhar seu diretério ptblico pela rede, clique em Compartilhamento de Arquivos
Pessoais e ative Share Public Folder On This Network (Compartilhar Pasta Pudblica nesta

Rede). Vocé também pode definir uma senha.

® Para compartilhar sua sessdo de &rea de trabalho com outros usuérios, clique em
Compartilhamento de tela e ative Permitir controle remoto. Para permitir que outros usuérios

controlem sua tela, ative também Controle Remoto. Vocé também pode definir uma senha.

¢ Para habilitar o login por SSH, clique em Login Remoto.

Todas as telas de compartilhamento incluem um endereco que vocé pode dar a outros usuérios
para que eles contatem vocé. Para copiar um endereco de compartilhamento, clique nele e

selecione Copiar. Em seguida, é possivel copia-lo em um software de e-mail ou mensagem.

3.4.4 Definindo configuracdes administrativas com o YaST

Para sua conveniéncia, o YaST esta disponivel nos dois menus Configuracoes e Aplicativos do
GNOME. Para obter informacgoes sobre o uso do YaST, consulte o Livro “Deployment Guide”.
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4 Tecnologias assistivas

A éarea de trabalho do GNOME inclui tecnologias assistivas para dar suporte a
usudrios com as mais variadas deficiéncias e necessidades especiais e interagir com
os dispositivos comuns de assisténcia. Este capitulo descreve varios aplicativos
com tecnologia assistiva projetados para atender as necessidades dos usuarios com
deficiéncias fisicas, como visao reduzida ou dificuldades motoras.

4.1 Habilitando as tecnologias assistivas

Para configurar os recursos de acessibilidade, abra a caixa de didlogo Configuracoes do GNOME
(por exemplo, em Aplicativos > Ferramentas do Sistema > Configuragoes) e clique em Acessibilidade.

Cada recurso assistivo pode ser habilitado separadamente nesta caixa de didlogo.

Se vocé precisar de acesso mais direto a cada recurso assistivo, ative Sempre mostrar o menu de
acessibilidade na caixa de didlogo Acesso Universal. Um novo menu aparecera no painel inferior.

4.2 Deficiéncias visuais

Na secdo Seeing (Visdo) da caixa de didlogo Acesso Universal, é possivel habilitar recursos que
auxiliam pessoas com dificuldade de visdo.

® A ativacao de Alto Contraste habilita os icones de alto contraste em preto e branco na area
de trabalho do GNOME.

® A ativacdo de Texto Grande amplia a fonte usada na interface do usudrio.

* A ativacio de Zoom habilita o ampliador de tela. E possivel definir o comportamento

desejado de ampliacao e do ampliador, incluindo os efeitos de cor.

® Se o Leitor de Tela estiver ativado, qualquer elemento de IU ou texto que receber o foco

do teclado sera lido em voz alta.

e Se as Teclas Sonoras estiverem ativadas, sera tocado um som sempre que as teclas

Num Lock ou Caps Lock estiverem ativadas.
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4.3 Deficiéncias auditivas

Na secdo Deficiéncias Auditivas da caixa de didlogo Acessibilidade, é possivel habilitar recursos

que auxiliam pessoas com dificuldade de audicao.

Se os Visual Alerts (Alertas Visuais) estiverem ativados, o titulo de uma janela ou a tela inteira

piscard quando ocorrer um som de alerta.

4.4 Deficiéncias de mobilidade

Nas sec¢oes Digitagdo e Pointing and Clicking (Apontar e Clicar) da caixa de didlogo Acessibilidade,
é possivel habilitar recursos que auxiliam pessoas com deficiéncias de mobilidade.

¢ Se o Teclado na Tela estiver ativado, um teclado virtual aparecera sempre que vocé precisar

digitar texto. E possivel usar o teclado na tela clicando nas teclas virtuais.

¢ Clique em Assisténcia de digitacdo (AccessX) para abrir uma caixa de didlogo na qual é

possivel habilitar varios recursos para facilitar a digitacao.

e Com a opg¢ao Habilitar por teclado, vocé pode ativar ou desativar os recursos de
acessibilidade usando o teclado.

® As Teclas de Aderéncia permitem digitar combinacoes de teclas com uma tecla de
cada vez, sem ter que pressionar mais de uma tecla ao mesmo tempo. Por exemplo,
o atalho Alt —-| alterna entre as janelas.
Com as teclas de aderéncia desativadas, vocé tem que pressionar e segurar as duas
teclas ao mesmo tempo. Com as teclas de aderéncia ativadas, pressione Alt e depois

»| para executar a mesma acao.

® Ative as Teclas de Desaceleragdo para definir um atraso entre o pressionamento de
uma tecla e a exibicdo da letra na tela. Isso significa que vocé precisa pressionar e

segurar cada tecla que deseja digitar por um tempo até ela aparecer. Use as teclas de
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desaceleracdo se vocé costuma pressionar sem querer varias teclas a0 mesmo tempo
ao digitar ou se tiver dificuldade em pressionar a tecla certa no teclado logo na

primeira vez.

® Ative as Teclas de Repercussdo para ignorar pressionamentos de teclas que sejam
repetidos rapidamente. Isso podera ajudar, por exemplo, se vocé tiver tremores que
lhe fazem pressionar uma tecla varias vezes, quando gostaria de pressiona-la apenas

uma vez.
e Ative as Teclas do Mouse para controlar o ponteiro do mouse usando o teclado numérico.

¢ Clique em Click Assist (Assisténcia de Clique) para abrir uma caixa de didlogo na qual
é possivel habilitar varios recursos que facilitam o clique: clique secundéario simulado e
clique com foco.

¢ Habilite o Clique Secunddrio Simulado para ativar o clique secundario (normalmente o
botao direito do mouse) pressionando e segurando o botao principal por um periodo
predefinido de atraso de aceitagdo. Isso sera ttil se vocé tiver dificuldades em mover
os dedos de uma mao separadamente ou se o seu dispositivo apontador tiver apenas

um botao.

¢ Ative o Hover Click (Clique com Foco) para acionar um clique focalizando o ponteiro
do mouse sobre um objeto na tela. Isso serd 1til se vocé tiver dificuldades em mover o
mouse e clicar ao mesmo tempo. Se esse recurso estiver ativado, uma pequena janela
de clique com foco sera aberta sobre todas as outras janelas. E possivel usd-la para
escolher o tipo de clique desejado quando vocé focalizar algo. Quando vocé focaliza
o ponteiro do mouse sobre um botdo e ndo o movimenta, o ponteiro muda de cor
gradualmente. Quando o ponteiro tiver mudado completamente de cor, o botao sera
clicado.

¢ Use o controle deslizante para ajustar o Atraso do clique duplo de acordo com as suas
necessidades.

4.5 Para obter mais informacgdes

H& mais informac¢oes na Ajuda do GNOME, que também estd disponivel online em https://

help.gnome.org/users/gnome-help/3.20/a11y.html.en .
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5 Accessing Network Resources

From your desktop, you can access files and directories or certain services on remote hosts or
make your own files and directories available to other users in your network. SUSE® Linux

Enterprise Server offers the following ways of accessing and creating network shared resources.

Network Browsing
Your file manager, GNOME Files, lets you browse your network for shared resources and

services. Learn more about this in Secdo 5.3, “Accessing Network Shares”.

Sharing Directories in Mixed Environments
Using GNOME Files, configure your files and directories to share with other members of
your network. Make your data readable or writable for users from any Windows or Linux

workstation. Learn more about this in Secdo 5.4, “Sharing Directories”.

Managing Windows Files
SUSE Linux Enterprise Server can be configured to integrate into an existing Windows
network. Your Linux machine then behaves like a Windows client. It takes all account
information from the Active Directory domain controller, just as the Windows clients do.

Learn more about this in Secdo 5.5, “Managing Windows Files”.

Configuring and Accessing a Windows Network Printer
You can configure a Windows network printer through the GNOME control center. Learn

how to do this in Secdo 5.6, “Configuring and Accessing a Windows Network Printer”.

5.1 Connecting to a Network

You can connect to a network with wired and wireless connections. To view your network
connection, check the network icon in the right part of the main panel. If you click the icon,
you can see more details in the menu. Click the connection name to see more details and access

the settings.

To learn more about connecting to a network, see Livro “Administration Guide”, Capitulo 38 “Using

NetworkManager”.
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5.2 General Notes on File Sharing and Network
Browsing

o Importante: Contact Your Administrator Before Setup

Whether and to what extent you can use file sharing and network browsing and in
your network highly depends on the network structure and on the configuration of your

machine.

Before setting up either of them, contact your system administrator. Check whether your
network structure supports a feature and whether your company's security policies permit
it.

Network browsing, be it SMB browsing for Windows shares or SLP browsing for remote services,
relies heavily on the machine's ability to send broadcast messages to all clients in the network.
These messages and the clients' replies to them enable your machine to detect any available

shares or services.

For broadcasts to work effectively, your machine must be part of the same subnet as all other
machines it is querying. If network browsing does not work on your machine or the detected
shares and services do not meet your expectations, contact your system administrator to ensure

that you are connected to the appropriate subnet.

To allow network browsing, your machine needs to keep several network ports open to send
and receive network messages that provide details on the network and the availability of shares
and services. The standard SUSE Linux Enterprise Server is configured for tight security and has

a firewall that protects your machine against the Internet.

To adjust the firewall configuration, you either need to ask your system administrator to put
your interface into the internal zone or to tear down the firewall entirely (depending on your
company's security policy). If you try to browse a network while a restrictive firewall is running
on your machine, GNOME Files warns you that your security restrictions are not allowing it to

query the network.
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5.3 Accessing Network Shares

Networking workstations can be set up to share directories. Typically, files and directories are
marked to allow users remote access. These are called network shares. If your system is configured
to access network shares, you can use your file manager to access these shares and browse them
just as easily as if they were located on your local machine. Your level of access to the shared
directories (whether read-only or write access, as well) is dependent on the permissions granted

to you by the owner of the shares.

To access network shares, open GNOME Files and click Other Locations in the sidebar. GNOME
Files displays the servers and networks that you can access. Double-click a server or network
to access its shares. You might be required to authenticate to the server by providing a user
name and password. Common network shares are SFTP-accessible resources (SSH File Transfer

Protocol) or Windows shares.
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[ Documentos Redes
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FIGURA 5.1: NETWORK FILE BROWSER

48 Accessing Network Shares | SLES 12 SP5



PROCEDIMENTO 5.1: ADDING A NETWORK PLACE

1. Open GNOME Files and click Other Locations in the sidebar. It shows a Connect to Server

text box.
2. Enter the server address.

3. Click Connect.

5.4 Sharing Directories

Sharing and exchanging documents is a must-have in corporate environments. GNOME Files
offers you file sharing, which makes your files and directories available to both Linux and

Windows users.

5.4.1 Enabling Sharing on the Computer

Before you can share a directory, you must enable sharing on your computer. To enable sharing:
1. Start YaST from the main menu.

2. Enter the root password.

3. In the category Network Services, click Windows Domain Membership.

4. Click Allow Users to Share Their Directories, then click OK.

5.4.2 Enabling Sharing for a Directory

To configure file sharing for a directory:

1. Open GNOME Files.

2. Right-click a directory, select Properties and click Share.
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3. Select Share this folder.

4. If you want other people to be able to write to the directory, select Allow others to create
and delete files in this folder. To allow access for people without a user account check Guest

Access.
5. Click Create Share.

6. If the directory does not already have the permissions that are required for sharing, a

dialog appears. Click Add the permissions automatically.

The directory icon changes to indicate that the directory is now shared.

o Importante: Samba Domain Browsing and Firewalls

Samba domain browsing only works if your system's firewall is configured accordingly.
Either disable the firewall entirely or assign the browsing interface to the internal firewall

zone. Ask your system administrator how to proceed.
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5.5 Managing Windows Files

With your SUSE Linux Enterprise Server machine being an Active Directory client, you can
browse, view and manipulate data located on Windows servers. The following examples are the

most prominent ones:

Browsing Windows Files with GNOME Files

Use GNOME Files's network browsing features to browse your Windows data.

Viewing Windows Data with GNOME Files
Use GNOME Files to display the contents of your Windows user directory as you would for

displaying a Linux directory. Create new files and directories on the Windows server.

Manipulating Windows Data with GNOME Applications
Many GNOME applications allow you to open files on the Windows server, manipulate

them and save them back to the Windows server.

Single Sign-On
GNOME applications, including GNOME Files, support Single Sign-On. This means that you
do not need to re-authenticate when you access other Windows resources. These can be
Web servers, proxy servers or groupware servers like Microsoft Exchange*. Authentication
against all these is handled silently in the background using the user name and password

you provided when you logged in.
To access your Windows data using GNOME Files, proceed as follows:
1. Open GNOME Files and click Network in the Places pane.
2. Double-click Windows Network.
3. Double-click the icon of the workgroup containing the computer you want to access.

4. Click the computer’s icon (and authenticate if prompted to do so) and navigate to the

shared directory on that computer.

To create directories in your Windows user directory using GNOME Files, proceed as you would

when creating a Linux directory.

51 Managing Windows Files | SLES 12 SP5



5.6 Configuring and Accessing a Windows Network
Printer

Being part of a corporate network and authenticating against a Windows Active Directory server,
you can access corporate resources such as printers. GNOME allows you to configure printing

from your Linux client to a Windows network printer.

To configure a Windows network printer for use through your Linux workstation, proceed as

follows:

1. Start the GNOME control center from the main menu by clicking Applications > System
Tools > Settings > Printers.

@ Nota: Starting the CUPS Service

The CUPS service is not started by default after installation of SUSE Linux Enterprise
Server. If the Printers dialog shows a message that the printing service is currently

not available, you need to start the CUPS service manually.

Start it by opening a shell and typing:

sudo systemctl start cups

2. Click Unlock and enter the root password.

3. Click the plus icon.

4. Select a Windows printer connected via Samba.

To print to the Windows network printer configured above, select it from the list of available

printers.
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6 Gerenciando impressoras

O SUSE® Linux Enterprise Server facilita a impressdao de documentos, esteja o computador
conectado diretamente a uma impressora ou remotamente em uma rede. Este capitulo descreve

como configurar impressoras no SUSE Linux Enterprise Server e gerenciar servicos de impressao.

6.1 Instalando uma impressora

Antes de instalar uma impressora, vocé precisa saber a senha de root e as informacoes sobre a
impressora. Dependendo de como vocé conecta a impressora, talvez precise do URI, endereco
ou host TCP/IP e do driver da impressora. O SUSE Linux Enterprise Server ja vem com alguns
drivers de impressora comuns. Se ndo conseguir encontrar um driver para a impressora, verifique

o site na Web do fabricante.

1. Clique em Aplicativos > Ferramentas do Sistema > Configuragoes > Impressoras.
2. Clique em Desbloquear e digite a senha root.

3. Clique no icone de adicao.

4. Se houver muitas impressoras na lista, filtre-as digitando o endereco IP ou uma palavra-

chave no campo de pesquisa na parte inferior da caixa de didlogo.

5. Selecione uma impressora na lista de impressoras disponiveis e clique em Adicionar.

A impressora instalada é exibida no painel Impressoras. Vocé ja pode usar a impressora com

qualquer aplicativo.
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7

Fazendo backup dos dados do usuario

A ferramenta Backup é uma estrutura simples que permite aos usuéarios fazer

backup e restaurar seus préprios dados, como diretérios pessoais ou arquivos

selecionados. E possivel criar backups programados ou por solicitacdo e reproduzir

um estado anterior desses dados.

7.1

Criando backups

Primeiramente, especifique os dados e programe quando fazer o backup.
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. Clique em Aplicativos > Ferramentas do Sistema > Backup.

. Ao abrir o aplicativo pela primeira vez, vocé verd uma tela de boas-vindas. Clique em

Apenas mostrar minhas configuragoes de backup.

. Na guia Visdo Geral, é possivel ativar e desativar Backups automdticos. E possivel também

exibir a visao geral das configuracoes atuais.

. Na guia Armazenamento, selecione o Local do Backup e a Pasta na qual gravar o backup.

. Na guia Pastas, selecione os diretérios para incluir no backup e os que serao ignorados. Por

exemplo, para fazer backup do seu diretério pessoal, com excecao do diretério Downloads,
adicione o diretério pessoal a categoria Pastas para backup e o diretério Downloads a

categoria Pastas para ignorar.

. Na guia Programar, selecione a frequéncia dos backups automaéticos (didria ou semanal)

e por quanto tempo manté-los.

. (Opcional) Para executar um backup imediatamente, retorne para a guia Visdo Geral e

clique em Fazer Backup Agora.

a. Escolha se o backup deve ser protegido por senha.
Em caso afirmativo, digite uma senha nas duas caixas ao lado de Encryption Password
(Senha de Criptografia) e Confirmar Senha.
Em caso negativo, clique em Allow Restoring Without a Password (Permitir
Restauracao sem Senha).
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b. Clique em Continuar para iniciar o processo de backup. Ao término do backup, a

janela sera fechada.

7.2 Restaurando dados

Para restaurar um estado anterior dos dados, faca o seguinte:
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1.

2.

3.

Selecione Aplicativos > Ferramentas do Sistema > Backup.
Na guia Visdo Geral, clique em Restaurar.

Escolha o local do qual restaurar. Clique em Encaminhar. A ferramenta pesquisa os backups

armazenados nesse local.
Escolha uma data. Clique em Encaminhar.

Escolha se é para restaurar os arquivos para o local original ou para outro diretério. Clique

em Para frente para ver um resumo de suas opgoes.

. Clique em Restaurar para iniciar o processo de restauracao.
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8 Passwords and Keys: Signing and Encrypting Data

The GNOME Passwords and Keys program is an important component of the encryption
infrastructure on your system. With this program, you can create and manage PGP and SSH

keys, import, export and share keys, back up your keys and keyring, and cache your passphrase.

Start the program by choosing Applications > Utilities > Passwords and Keys
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FIGURA 8.1: PASSWORD AND KEYS MAIN WINDOW

8.1 Signing and Encryption

Signing. Attaching electronic signatures to pieces of information, such as e-mail messages or
software to prove its origin. To keep someone else from writing messages using your name, and
to protect both you and the people you send them to, you should sign your mails. Signatures
help you check the sender of the messages you receive and distinguish authentic messages from
malicious ones.

Software developers sign their software so that you can check the integrity. Even if you get the

software from an unofficial server, you can verify the package with the signature.
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Encryption. You might also have sensitive information you want to protect from other parties.
Encryption helps you transform data and make it unreadable for others. This is important for
companies so they can protect internal information and their employees' privacy.

8.2 Generating a New Key Pair

To exchange encrypted messages with other users, you must first generate your own pair of

keys. It consists of two parts:

® Public Key. This key is used for encryption. Distribute it to your communication partners,

so they can use it to encrypt files or messages for you.

® Private Key. This key is used for decryption. Use it to make encrypted files or messages

from others (or yourself) legible again.

o Importante: Access to the Private Key

If others gain access to your private key, they can decrypt files and messages intended

only for you. Never grant others access to your private key.

8.2.1 Creating OpenPGP Keys

OpenPGP is a non-proprietary protocol for encrypting e-mail with the use of public-key
cryptography based on PGP. It defines standard formats for encrypted messages, signatures,

private keys, and certificates for exchanging public keys.
1. Click Applications > Utilities > Passwords and Keys.

2. Click File > New.

3. Select PGP Key and click Continue.

4. Specify your full name and e-mail address.

5. Click Advanced key options to specify the following advanced options for the key.

Comment

An optional comment.
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Encryption Type
Specifies the encryption algorithms used to generate your keys. DSA ElGamal is the
recommended choice because it lets you encrypt, decrypt, sign, and verify as needed.

Both DSA (sign only) and RSA (sign only) allow only signing.

Key Strength
Specifies the length of the key in bits. The longer the key, the more secure it is
(provided a strong passphrase is used). Keep in mind that performing any operation
with a longer key requires more time than it does with a shorter key. Acceptable
values are between 1024 and 4096 bits. At least 2048 bits are recommended.

Expiration Date
Specifies the date at which the key will cease to be usable for performing encryption
or signing operations. You will need to either change the expiration date or generate
a new key or subkey after this amount of time passes. Sign your new key with your
old one before it expires to preserve your trust status.

6. Click Create to create the new key pair.
The Passphrase for New PGP Key dialog opens.

7. Specify the passphrase twice for your new key, then click OK.
When you specify a passphrase, use the same practices you use when you create a strong

password.

8.2.2 Creating Secure Shell Keys

Secure Shell (SSH) is a method of logging in to a remote computer to execute commands on that
machine. SSH keys are used in key-based authentication system as an alternative to the default
password authentication system. With key-based authentication, there is no need to manually

type a password to authenticate.

1. Click Applications > Utilities > Passwords and Keys.
2. Click File > New.

3. Select Secure Shell Key, then click Continue.

4. Specify a description of what the key is to be used for.

You can use your e-mail address or any other reminder.
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5. Optionally, click Advanced key options to specify the following advanced options for the

key.

Encryption Type. Specifies the encryption algorithms used to generate your keys. Select
RSA to use the Rivest-Shamir-Adleman (RSA) algorithm to create the SSH key. This is the
preferred and more secure choice. Select DSA to use the Digital Signature Algorithm (DSA)
to create the SSH key.

Key Strength. Specifies the length of the key in bits. The longer the key, the more secure
it is (provided a strong passphrase is used). Keep in mind that performing any operation
with a longer key requires more time than it does with a shorter key. Acceptable values
are between 1024 and 4096 bits. At least 2048 bits is recommended.

. Click Just Create Key to create the new key, or click Create and Set Up to create the key

and set up another computer to use for authentication.

. Specify the passphrase for your new key, click OK, then repeat.

When you specify a passphrase, use the same practices you use when you create a strong

password.

8.3 Modifying Key Properties

You can modify properties of existing OpenPGP or SSH keys.

8.3.1 Editing OpenPGP Key Properties

The descriptions in this section apply to all OpenPGP keys.
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1. Click Applications > Utilities > Passwords and Keys.
2. Double-click the PGP key you want to view or edit.

3. Use the options on the Owner tab to add a photo to the key or to change the passphrase

associated with the key.
Photo IDs allow a key owner to embed one or more pictures of themselves in a key. These
identities can be signed like normal user IDs. A photo ID must be in JPEG format. The

recommended size is 120 X 150 pixels.
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If the chosen image does not meet the required file type or size, Passwords and Keys can

resize and convert it on the fly from any image format supported by the GDK library.

. Click the Names and Signatures tab to add a user ID to a key.

See Secdo 8.3.1.1, “Adding a User ID” for more information.

. Click the Details tab, which contains the following properties:

Key ID: The Key ID is similar to the Fingerprint, but the Key ID contains only the last eight
characters of the fingerprint. It is generally possible to identify a key with only the Key

ID, but sometimes two keys might have the same Key ID.

Type: Specifies the encryption algorithm used to generate a key. DSA keys can only sign.
ElGamal keys are used to encrypt.

Strength: Specifies the length, in bits, of the key. The longer the key, the more security it

provides. However, a long key will not compensate for the use of a weak passphrase.
Fingerprint: A unique string of characters that exactly identifies a key.
Created: The date the key was created.

Expires: The date the key can no longer be used (a key can no longer be used to perform
key operations after it has expired). Changing a key's expiration date to a point in the
future re-enables it. A good general practice is to have a master key that never expires and
multiple subkeys that do expire and are signed by the master key.

Override Owner Trust: Here you can set the level of trust in the owner of the key. Trust
is an indication of how sure you are of a person's ability to correctly extend the Web of
trust. When there is a key that you have not signed, the validity of the key is determined

from its signatures and how much you trust the people who made those signatures.
Export Secret Key: Exports the key to a file.

Subkeys: See Secdo 8.3.1.2, “Editing OpenPGP Subkey Properties” for more information.
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Click Close.

8.3.1.1 Adding a User ID

User IDs allow multiple identities and e-mail addresses to be used with the same key. Adding

a user ID is useful, for example, when you want to have an identity for your job and one for

your friends. They take the following form:

Name (COMMENT) <E-MAIL>
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1.

2.

3.

Click Applications » Utilities > Passwords and Keys.
Double-click the PGP key you want to view or edit.
Click the Names and Signatures tab, then click Add Name.

Specify a name in the Full Name field.
You must enter at least five characters in this field.

. Specify an e-mail address in the E-Mail Address field.

Your e-mail address is how most people will locate your key on a key server or other key

provider. Make sure it is correct before continuing.

. In the Key Comment field, specify additional information that will display in the name of

your new ID.

This information can be searched for on key servers.

. Confirm your changes and enter the passphrase when prompted for it.
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8.3.1.2 Editing OpenPGP Subkey Properties

Each OpenPGP key has a single master key used to sign only. Subkeys are used to encrypt and
to sign as well. In this way, if your subkey is compromised, you do not need to revoke your
master key.

1. Click Applications > Utilities > Passwords and Keys.
2. Double-click the PGP key you want to edit.
3. Click the Details tab, then click to show the Subkeys category.

4. Use the buttons on the left of the dialog to add, delete, expire, or revoke subkeys.
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AFCBD7C2006D4A77 RSA Assinar, Certificar 2016-08-03 MNunca Bom 2048
] Expirar 8843B6631082A662 RSA  Criptografar 2016-08-03 MNunca Bom 2048

¥ Revogar

Excluir

Ajuda Fechar

T

Each subkey has the following information:
ID: The identifier of the subkey.

Type: Specifies the encryption algorithm used to generate a subkey. DSA keys can only

sign, ElGamal keys are used to encrypt, and RSA keys are used to sign or to encrypt.
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Usage: Shows if the key can be used to sign, to certify, or also to encrypt.
Created: Specifies the date the key was created.

Expires: Specifies the date the key can no longer be used.

Status: Specifies the status of the key.

Strength: Specifies the length, in bits, of the key. The longer the key, the more security it

provides. However, a long key will not compensate for the use of a weak passphrase.

5. Click Close.

8.3.2 Editing Secure Shell Key Properties

The descriptions in this section apply to all SSH keys.

1. Click Applications > Utilities > Passwords and Keys.
2. Double-click the Secure Shell key you want to view or edit.

3. Use the options on the Key tab to change the name of the key or the passphrase associated
with the key.

4. Click the Details tab, which contains the following properties:
Algorithm: Specifies the encryption algorithm used to generate a key.

Strength: Indicates the length in bits of a key. The longer the key, the more security it

provides. However, a long key does not make up for the use of a weak passphrase.
Location: The location where the private key has been stored.

Fingerprint: A unique string of characters that exactly identifies a key.

Export Complete Key: Exports the key to a file.

63 Editing Secure Shell Key Properties | SLES 12 SP5



Chave Detalhes

Detalhes técnicos:

Algoritmo: RSA
Forga: 2064
Localizagdo: /home/ABC/.ssh/id_rsa

Impressdo digital: b7:75:d5:65:2e:4e:2e:52:2b:21:7f:73:52:84:99:a5

Exportar chave completa ‘

‘ Ajuda ‘ ‘ Fechar ‘

5. Click Close.

8.4 Importing Keys

Keys can be exported to text files. These files contain human-readable text at the beginning and

at the end of a key. This format is called an ASCII-armored key.

To import keys:
1. Click Applications > Utilities > Passwords and Keys.
2. Click File > Import.

3. Select a file containing at least one ASCII-armored public key.

4. Click Open to import the key.
You can also paste keys inside Passwords and Keys:

1. Select an ASCII-armored public block of text, then copy it to the clipboard.
2. Click Applications > Utilities > Passwords and Keys.

3. Click Edit > Paste
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8.5 Exporting Keys

To export keys:

1. Click Applications > Utilities > Passwords and Keys.
2. Select the keys you want to export.

3. Click File > Export.

4. Specify a file name and location for the exported key.

5. Click Save to export the key.
You can also export keys to the clipboard in an ASCII-armored block of text:

1. Click Applications > Utilities > Passwords and Keys.
2. Select the keys you want to export.

3. Click Edit > Copy.

8.6 Signing a Key

Signing another person's key means that you are giving trust to that person. Before signing a
key, carefully check the key's fingerprint to ensure that the key really belongs to that person.

Trust is an indication of how sure you are of a person's ability to correctly extend the Web of
trust. When there is a key that you have not signed, the validity of the key is determined from

its signatures and how much you trust the people who made those signatures.
1. Click Applications > Utilities > Passwords and Keys.
2. Select the key you want to sign from the My Personal Keys or Other Keys tabs.

3. Click File > Sign.
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4. Select how carefully the key has been checked, then indicate if the signature should be

local to your keyring, and if your signature can be revoked:

q Ao assinar, vocé indica que confia que esta chave pertence a:

Tux Linux <tux{@example.com>

Quio cuidadosamente vocé verificou essa chave?

2) De modo algum ) Despreocupadamente ) Cuidadosamente

De modo algum: significa que vocé acredita que a chave pertence a quem diz ser dona

dela, mas vocé ndo pdde ou ndo verificou se & verdade.

Comeo outros verSo essa assinatura:

|_J Outros ndo podem ver essa assinatura

¥ Eu posso revogar esta assinatura mais tarde.

Assinar chave como:

Signatario: | Tux Linux <tux@example.com> W
Ajuda Cancelar ‘ <9 Assinar |
5. Click Sign.

8.7 Password Keyrings

You can use password keyring preferences to create or remove keyrings, to set the default
keyring for application passwords or to change the unlock password of a keyring. To create a

new keyring, follow these steps:
1. Click Applications > Utilities > Passwords and Keys.
2. Click File > New > Password Keyring, then click Continue.

3. Enter a name for the keyring and click Add.

4. Set and confirm a new Password for the keyring and click Create.
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To change the unlock password of an existing keyring, right-click the keyring in the Passwords

tab and click Change Password. You need to provide the old password to be able to change it.

To change the default keyring for application passwords, right-click the keyring in the Passwords
tab and click Set as Default.

8.8 Key Servers

You can keep your keys up-to-date by synchronizing keys periodically with remote keyservers.
Synchronizing will ensure that you have the latest signatures made on all of your keys, so that
the Web of trust will be effective.

1. Click Applications > Utilities > Passwords and Keys.

2. Click Edit > Preferences, then click the Key Servers tab.

Servidores de chaves

Localizar chaves através de: hkp://pool.sks-keyservers.net
Adicionar ldap://keyserver.pgp.com
Remover
Publicar chaves para: Menhum: ndo publicar chaves -
Obter chaves automaticamente de servidores de chaves
Sincronizar automaticamente chaves modificadas com os servidores
Ajuda Fechar

Passwords and Keys provides support for HKP and LDAP keyservers.

HKP Key Servers: HKP key servers are ordinary Web-based key servers, such as the popular
hkp://pgp.mit.edu:11371, also accessible at http://pgp.mit.edu 2.

LDAP Key Servers: LDAP key servers are less common, but use the standard LDAP protocol
to serve keys. ldap://keyserver.pgp.com is a good LDAP server.

You can Add or Remove key servers to be used using the buttons on the left. To add a new

key server, set its type, host and port, if necessary.
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3. Set whether you want to automatically publish your public keys and which keyserver to
use. Set whether you want to automatically retrieve keys from key servers and whether

to synchronize modified keys with keyservers.

4. Click Close.

8.9 Key Sharing

Key Sharing is provided by DNS-SD, also known as Bonjour or Rendezvous. Enabling key sharing
adds the local Passwords and Keys users' public key rings to the remote search dialog. Using these

local key servers is generally faster than accessing remote servers.
1. Click Applications > Utilities > Passwords and Keys.
2. Click Edit > Preferences, then click the Key Servers tab.

3. Select Automatically synchronize modified keys with key servers.

4. Click Close.
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9 gFTP: Transferring Data from the Internet

gFTP is a multithreaded file transfer client. It supports the FTP, FTPS (control
connection only), HTTP, HTTPS, SSH, and FSP protocols. Furthermore, it allows
the transfer of files between two remote FTP servers via FXP. To start gFTP, click

Applications > Internet > gFTP.

FTP Local Remoto Marcadores Transferéncias Log Ferramentas Ajuda

|i1 Méaquina: v | Porta: v | Usuario: ¥ | Senha: FTP L3

lihome;’tux| l il v
[Local] [Todos os Arquivos]
D
< | Nome do arqui Tamanho | Usudrio <. | Nome do arqui Tamanho | Usuario G
.cache 126 tux
.config 290 tux
.dbus 22 tux .
gftp 46 tux &
.gnome?2 12 tux

Nome do arqui | Progresso

Alexandre Folle de Menezes <afmenez@terra.com.br>
Raphael Higino <raphaelh@uai.com.br>

baseado na versdo em Portugués Ibérico por

Duarte Loreto <happygquy_pt@hotmail.com>

FIGURA 9.1: GFTP—MAIN WINDOW

9.1 ASCIl Compared to Binary Transfers

There are two common ways of transferring files via FTP: ASCII and binary. ASCII mode transfers
files as text. ASCII files are . txt, .asp, .html, and . php files, for example. Binary mode transfers
files as raw data. Binary files are .wav, .jpg, .gif, and mp3 files, for example.

To change the transfer mode, click the FTP menu and select Binary or Ascii.

When transferring ASCII files from Linux/Unix to Windows or vice versa, open the Preferences
dialog by clicking FTP > Preferences. Switch to the FTP tab and select Transfer Files in ASCII Mode
to ensure that newline characters are correctly converted. This option will automatically be
disabled in Binary mode.
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9.2 Connecting to a Remote Server
To connect to a remote server, do the following:

1. Click Remote > Open Location.
2. Specify a URL to connect to and click Connect.

3. Specify your user name and click Connect. Then specify your password and click Connect.

To connect anonymously, leave the user name blank.

4. If the connection is successful, the right part of the gFTP window lists files from the remote

computer. The file listing on the left side continues to show files from your local computer.

You can now upload and download files via drag and drop or by using the arrow buttons.

To bookmark a site you access frequently, click Bookmarks > Add Bookmark. Specify a name for
the bookmark, then click Add. The new bookmark is added to your list of bookmarks.

9.3 Transferring Files

In the following figure, the file list on the right contains the remote server's directory of files.
The file list on the left side contains your local computer's directory of files (on your hard disk

or network).
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FTP Local Remoto Marcadores Transferéncias Log Ferramentas Ajuda

: ‘r.H; ‘ Maquina: | ‘ - |Porta: | ‘ - |Usuz‘ario: ‘ ‘ - |Senha: | ||FTP - ”@‘
| froot ‘ - | | /pub/people/ug/autoyast ‘ - |
[Local] [Todos os Arquivos] R 192.168.3.2 [FTP] [Todos os Arguivos]* .
‘ o H MNome do arqu H Tamanho H Usuario H Grupo H Data ‘_»‘ ‘ o H MNome do arqu H Tamanho H Usuario H Grupo H Data
© ) 186 root oot “Thu Aug 4 : . ) 0 user ”group Wed Aug
B .cache 82 root root Thu Aug 4 B B839D6FZE.asc 3.536 user group Wed Aug
[ .config 200 root root Thu Aug 4 =] gftp_transfer.pr 10.039 user group Wed Aug
E .dbus 22 root root Thu Aug 4
E .gftp 46 root root Thu Aug 4 :

[ .gnome2 12 root root Thu Aug 4 ‘ Go
[E5 .gnome2_privat 0 root root Thu Aug 4 o
[ .gnupg 180 root root Thu Aug 4

Mome do arqu H Progresso

Carregando lista do diretorio /pub/people/ug/autoyast do servidor (LC_TIME=pt_BR.UTF-8)
PASY

227 Entering Passive Mode (192,168,3,2,175,202)

LIST -aL

150 Opening ASCIl mode data connection for /bin/ls.

226 Transfer complete. 260 bvtes transferred. 0.25 KB/sec.

FIGURA 9.2: GFTP FILE TRANSFER
To download files, select the files you want to download in the remote list of files, then click
the arrow button pointing to the left. The progress of each download is listed in the field in

the middle of the window. If the transfer is successful, the files appear in the directory listing
on the left.

To upload a file, select the files you want to upload in your local directory listing on the left,
then click the arrow button pointing to the right. The progress of each download is listed in the
field in the middle of the window. If the transfer is successful, the files appear in the remote
directory listing on the right.

To modify preferences for your downloads, select FTP > Preferences from the menu.

9.4 Setting Up an HTTP Proxy Server

To set up an HTTP proxy server, do the following:
1. From the menu, select FTP > Preferences, then select the FTP tab.

2. Enter the Proxy hostname and Proxy port. If applicable, also provide your login credentials

for the proxy server. Choose a proxy type from the Proxy Server Type drop-down box.
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3. Click the HTTP tab, and enter the same proxy server information in the dialog as described

above. Port numbers for FTP and HTTP proxy may differ.

4. Click OK.

9.5 For More Information

You can find more information about gFTP at http://www.gftp.org 7.

72 For More Information | SLES 12 SP5


http://www.gftp.org

10
11
12

13

LibreOffice

LibreOffice: The Office Suite 74
LibreOffice Writer 88
LibreOffice Calc 100

LibreOffice Impress, Base, Draw e Math 106



10 LibreOffice:; The Office Suite

LibreOffice is an open source office suite that provides tools for all types of office
tasks such as writing texts, working with spreadsheets, or creating graphics

and presentations. With LibreOffice, you can use the same data across different
computing platforms. You can also open and edit files in other formats, including
Microsoft* Office* formats, then save them back to this format, if needed. This

chapter contains information that applies to all LibreOffice modules.

10.1 LibreOffice Modules

LibreOffice consists of several application modules (subprograms) which are designed to
integrate with each other. While this chapter contains information that applies to all LibreOffice
modules, the following chapters and sections contain information on individual modules. Find
a short description and where each module is described in Tobela 70.1, “The LibreOffice Application
Modules”.

A full description of each module is available in the application help, described in Secdo 70.70,

“For More Information”.

TABELA 10.1: THE LIBREOFFICE APPLICATION MODULES

Module Purpose Described in
Writer Word processor module Capitulo 11
Calc Spreadsheet module Capitulo 12
Impress Presentation module Secdo 13.1
Base Database module Secdo 13.2
Draw Module for drawing vector graphics Secdio 13.3
Math Module for generating mathematical formulas Secdo 13.4
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10.2 Starting LibreOffice

To start LibreOffice, click Applications > Office > LibreOffice. In the LibreOffice start center, choose

the type of document you want to create.

There are multiple methods to directly start one of the LibreOffice modules:

¢ If any LibreOffice module is open, you can start any of the other modules by clicking

File > New and then selecting the type of document you want to create.
® You can also start individual LibreOffice modules from the menu Applications.

¢ As an alternative, use the command libreoffice and one of the options --writer, --
calc, --impress, --draw, or --base to start the respective module.
LibreOffice has many command line options, especially for allowing document
conversions. To learn more about the command line options of LibreOffice, see
libreoffice --help or the man page of LibreOffice (man libreoffice(1)).

Before you start working with LibreOffice, you may be interested in changing some options from

the preferences dialog. Click Tools > Options to open it. The most important ones are:

LibreOffice > User Data
Specify your user data such as company, first and last name, street, city, and other useful
information. This data has many uses: It is used in the comment functions of Writer and

Calc, for authorship information in PDF documents, and for serial letters in Writer.

LibreOffice > Fonts
Map font names to installed fonts. This can be useful if you exchange documents with

others and the document you received contains fonts that are not available on your system.

Load/Save > General
Contains loading and saving specific options. For example, you can choose whether to

always create a backup copy and which file format LibreOffice should use by default.

To learn more about configuring LibreOffice, see Secdo 70.7, “Changing the Global Settings”.

75 Starting LibreOffice | SLES 12 SP5



10.3 The LibreOffice User Interface

The user interface of most of LibreOffice is very similar across its modules:

Menu Bar
At the top of the application, there is the menu bar which gives access to almost all
functionality of LibreOffice. The menu bar can be customized to include more or fewer

functions. You can also add and remove menus.

Toolbars
By default, the toolbars are positioned directly below the menu bar. The toolbars comprise
the most used and most important items of the module.
To dock a toolbar to any other side of the window, drag it to the right position. To make
a toolbar float, drag it into the middle of the window. They can be customized to include

more or fewer functions. You can also add and remove toolbars.

Side Bar

By default, the side bar is positioned at the right side of the LibreOffice window. On the
first start of LibreOffice, it is only visible as several icons stacked vertically. Clicking one
of the icons opens a panel with more elements. Click the icon again to close the panel.
Similarly to the toolbars, the side bar comprises the most important functions.

To dock the side bar to the left or right side of the window, drag it to the right position.
To make the side bar float, drag it into the middle of the window. To hide the side bar,
click the vertical arrowhead button on the document-facing side of the side bar.

You can hide or show side bar panels but cannot customize their functionality.

Statusbar
The statusbar is displayed at the bottom of the window. It mainly shows information about
the document, such as the number of words (in Writer) or the sum of values of selected
cells (in Calc). However, it can also be used to change the zoom or language settings. Many

elements open additional menus or dialogs on left click, right click, or double click.

For more information on customizing LibreOffice, see Secdo 70.6, “Customizing LibreOffice”.
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10.4 Compatibility with Other Office Applications

The native file format of LibreOffice is the OpenDocument format. OpenDocument is an ISO-
standardized format for office documents that is based on XML. However, LibreOffice can
also work with documents, spreadsheets, presentations, and databases in many other formats,
including Microsoft Office formats. Files in Microsoft Office formats can be opened and saved

back normally.

10.4.1 Opening Documents from Other Office Suites

If you use LibreOffice in an environment where you need to share documents with Microsoft
Word users, you should have little or no trouble exchanging document files. However, very
complex documents can require editing after opening. Complex documents are documents
containing, for example, complicated tables, Microsoft Office macros, or unusual fonts,

formatting, or graphical objects.

In case there should ever be issues with opening documents, try the following strategies:

® Text Documents. Consider opening text documents in the original application and saving
them as RTF or plain text (TXT). However, saving as plain text means that all formatting

will be lost.

® Spreadsheets. Consider opening spreadsheets in the original application and saving them
as Excel files. If this does not work, try the CSV format. However, saving as CSV means

that all formatting, cell type definitions, formulas, and macros will be lost.

10.4.2 Converting Documents to the OpenDocument Format

LibreOffice can read, edit, and save documents in several formats. It is not necessary to convert
files from those formats to the OpenDocument format used by LibreOffice to use those files.
However, if you want to convert the files, you can do so. To convert several documents, such

as when first switching to LibreOffice, do the following:

1. Select File > Wizards > Document Converter.

2. Choose the file format from which to convert.

3. Click Next.
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4. Specify where LibreOffice should look for templates and documents to convert and in
which directory the converted files should be placed.
Documents retrieved from a Windows partition are usually in a subdirectory of /windows.

5. Make sure that all other settings are correct, then click Next.

6. Review the summary of the actions to perform, then start the conversion by clicking
Convert.
The amount of time needed for the conversion depends on the number of files and their

complexity. For most documents, conversion does not take long.

7. When everything is done, close the Wizard.

10.4.3 Sharing Files with Users of Other Office Suites

LibreOffice is available for several operating systems. This makes it an excellent tool when a
group of users frequently need to share files and do not use the same system on their computers.

When sharing documents with others, you have several options:

If the recipient needs to be able to edit the file
Save the document in the format the other user needs. For example, to save as a Microsoft
Word file, click File > Save As, then select the Microsoft Word file type for the version of

Word the other user needs.

If the recipient only needs to read the document
Export the document to a PDF file with File > Export as PDF. PDF files can be read on any

platform using a PDF viewer.

Sharing a document for editing
Agree on a common exchange format that works for everyone. TXT and RTF formats,

although limited in formatting, can be a good option for text documents.

E-mailing a document as a PDF

Click File > Send > E-mail as PDF. Your default e-mail program opens with the file attached.

E-mailing a document to a Microsoft Word user
Click File > Send > E-mail as Microsoft Word. Your default e-mail program opens with the
file attached.
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10.5 Saving Files with a Password

You can save files, no matter in which LibreOffice format, with a password. Unlike older versions
of LibreOffice, the encryption applied to the document with recent versions of LibreOffice is
very strong. However, this encryption does not protect file names and file sizes of encrypted
files. If that is important to you, see the alternate encryption methods described in Livro “Security
and Hardening Guide”, Capitulo 12 “Encrypting Partitions and Files”.

1. To save a file with a password, select File > Save or File > Save As.

2. In the dialog that opens, activate the check box Save with password at the bottom and
click Save.

3. Type and confirm your password, then click OK.

The next time you open the file, you will be prompted for the password.

To change the password, do either of the following:

® Overwrite the same file by selecting File » Save As. Make sure Save with Password is

deactivated.

® Select File > Properties and click Change Password to access the password dialog.

10.6 Customizing LibreOffice

You can customize LibreOffice to best suit your needs and working style. Toolbars, menus, and
key combinations can all be reconfigured to help you more quickly access the features you use
the most.

You can also assign macros to application events if you want specific actions to occur when
those events take place. For example, if you always work with a specific spreadsheet, you can
create a macro that opens the spreadsheet and assign the macro to the Start Application event.

This section contains simple, generic instructions for customizing your environment. The
changes you make are effective immediately. This means you can see if the changes are what
you wanted and go back and modify them if they are not. See the LibreOffice help files for

detailed instructions.

To access the customization dialog in any open LibreOffice module, select Tools > Customize.
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Menus ‘ Menus de contexto l Teclado ‘ Barras de ferramentas ‘ Eventos |

Menus do LibreOffice Writer

Menu Elnserir v |

Conteido do menu

Quebra manual...

Figura...
Multimidia
@ Grafico...
Objeto
Forma
Fontwork...
T Caixa de texto
_+ Anotagdo

[=] e
Entradas ‘e Quebra de pagina

Salvar em [LibreOFﬁce Writer v |

Descrigdo

l Menu |v ‘

Adicionar... l
Modificar |v |

€5

. Ajuda ‘

FIGURA 10.1: CUSTOMIZATION DIALOG IN WRITER

@ Nota: Further Information

Click Help for more information about the options in the Customize dialog.

PROCEDIMENTO 10.1: CUSTOMIZING TOOLBARS

80

l OK H Cancelar H Redefinir ‘

1. In the customization dialog, click the tab Toolbar.

2. From the drop-down box Toolbar, select the toolbar you want to customize.

3. Activate the check boxes next to the commands you want to appear on the toolbar, and
deactivate the check boxes next to the commands you do not want to appear. A short
description for each command is shown at the bottom of the dialog.
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4. With Save In, select whether to save your customized toolbar in the current LibreOffice
module or in the current document. If you decide to save it in the LibreOffice module,
the customized toolbar is used whenever you open that module. If you decide to save it
together with the current document, the customized toolbar is used whenever you open

that document.

5. Repeat to customize additional toolbars.

6. Click OK.

To switch back to the original settings again, open the customization dialog, click the Toolbar

drop-down box and select Restore Default Settings. Click Yes and Reset to proceed.

PROCEDIMENTO 10.2: SHOWING OR HIDING BUTTONS IN THE TOOLBAR
1. Click the arrow icon at the right edge of the toolbar you want to change.
2. Click Visible Buttons to display a list of buttons.

3. Select the buttons in the list to enable (check) or disable (uncheck) them.

PROCEDIMENTO 10.3: CUSTOMIZING MENUS

You can add or delete items from current menus, reorganize menus, and even create new
menus.

1. Click Tools > Customize > Menus.
2. Select the menu you want to change, or click New to create a new menu.
3. Modify, add, or delete menu items as desired.

4. Click OK.

PROCEDIMENTO 10.4: CUSTOMIZING KEY COMBINATIONS

You can reassign currently assigned key combinations and assign new ones to frequently

used functions.
1. Click Tools > Customize > Keyboard.
2. Select the keys you want to assign to a combination.
3. Select a Category and an appropriate function.

4. Click Modify to assign the function to the key or Delete to remove an existing assignment.

5. Click OK.
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PROCEDIMENTO 10.5: CUSTOMIZING EVENTS

LibreOffice also provides ways to assign macros to events such as application start-up or

the saving of a document. The assigned macro runs automatically whenever the selected

event occurs.

1. Click Tools > Customize > Events.

2. Select the event you want to change.

3. Assign or remove macros for the selected event.

4. Click OK.

10.7 Changing the Global Settings

Global settings can be changed in any LibreOffice module by clicking Tools > Options on the

menu bar. This opens the window shown in the figure below. A tree structure is used to display

categories of settings.

-

v v w wwwow

LibreOffice

Geral

Memoaria

Exibir

Imprimir

Caminhos

Cores

Fontes

Seguranca

Personalizacdo

Cores da aplicagdo

Acessibilidade

Avangado

Opgbes do IDE do Basic

OpenCL
Carregar/Salvar
Configuracdes de idioma
LibreOffice Writer
LibreOffice Writer/Web
LibreOffice Base
Graficos
Internet

Ajuda |

Enderego

Empresa:
Nome/Sobrenome/Iniciais:
Rua:

CEP/Cidade:

Pais/regido:

Titulo/Cargo:

Telefone (Res./Com.):

Fax/E-mail:

FIGURA 10.2: THE OPTIONS WINDOW
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[+ Utllizar dados para propriedades do documento

| OK || Cancelar || Redefinir |
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The settings categories that appear depend on the module you are working in. For example, if
you are in Writer, the LibreOffice Writer category appears in the list, but the LibreOffice Calc
category does not. The LibreOffice Base category appears in both Calc and Writer. The Module

column in the table shows where each setting category is available.

The following table lists the settings categories along with a brief description of each category:

TABELA 10.2: GLOBAL SETTING CATEGORIES
Settings Category Description Module

LibreOffice Basic settings, including your user data (such as  All
your address and e-mail), important paths, and

settings for printers and external programs.

Load/Save Settings related to the opening and saving of All
several file types. There is a dialog for general
settings and several special dialogs to define how

external formats should be handled.

Language Settings Settings related to languages and writing aids, All
such as your locale and spell checker settings.
This is also the place to enable support for Asian

languages.

LibreOffice Writer Settings related to word processing, such as the Writer
basic units, fonts and layout that Writer should

use.

LibreOffice Writer/ Settings related to the HTML authoring features =~ Writer
Web of LibreOffice.

LibreOffice Calc Settings related to spreadsheets, such as Calc
spreadsheet appearance, Microsoft Excel

compatibility options, and calculation options.

LibreOffice Impress Settings related to presentations, such as enabling Impress
the smartphone remote control and the grid of

the page to use.
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Settings Category Description Module

LibreOffice Draw Settings related to drawings, such as the grid of Draw

the page to use.

LibreOffice Base Allows setting and editing database connections  Base

and registered databases.

Charts Allows defining the default colors used for newly  All

created charts.

Internet Allows configuring a proxy and the e-mail All

software to use.

o Importante: Settings Apply Globally

All settings listed in the table apply globally for the specified modules. That means, they
are used as defaults for every new document you create.

10.8 Using Templates

A template is a document containing only the styles—and content— that you want to appear in
every document of that type. When a document is created or opened with the template, the styles
are automatically applied to that document. Templates greatly enhance the use of LibreOffice

by simplifying formatting tasks for a variety of different types of documents.

For example, in a word processor, you can write letters, memos, and reports, all of which look
different and require different styles. Or, for example, for spreadsheets, you could use different
cell styles or headings for certain types of spreadsheets. If you use templates for each of your

document types, the styles you need for each document are always readily available.

LibreOffice comes with a set of predefined templates. You can also find additional templates
on the Internet, for example at http://templates.libreoffice.org 7. For details, see Secdo 70.70, “For

More Information”.

Creating your own templates requires some planning. You need to determine how you want the

document to look, so you can create the styles you need in that template.
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A detailed explanation of templates is beyond the scope of this section. Procedimento 10.6,

“Creating LibreOffice Templates” only shows how to generate a template from an existing document.

PROCEDIMENTO 10.6: CREATING LIBREOFFICE TEMPLATES

For text documents, spreadsheets, presentations, and drawings, you can create a template

from an existing document as follows:

1. Start LibreOffice and open or create a document that contains the styles and content that

you want to re-use for other documents of that type.
2. Click File > Templates > Save as Template.

3. Choose a directory to save the image in by double-clicking one of the directory icons.
If you are in a subdirectory and want to go up again, use the path bar displayed above

the directories.
4. From the toolbar, choose Save.

5. Specify a name for the template.

6. Click OK.

@ Nota: Converting Microsoft Word Templates

You can convert Microsoft Word templates like you would convert any other
Word document. For more information, see Secdo 70.4.2, “Converting Documents to the

OpenDocument Format”.

10.9 Setting Metadata and Properties

When exchanging documents with other people, it is sometimes useful to store metadata like
the owner of the file, who it was received from, and a URL. LibreOffice lets you attach such
metadata to the file. This helps you track metadata which you do not want to or cannot save in
the content of the file. This feature is also the basis for later sorting, searching and retrieving

your documents based on metadata.
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As an example, we assume you want to set these properties to your file:

* A title, subject, and some keywords
¢ The owner of the file
® Who sent you the file
To attach such metadata to your document, proceed as follows:
PROCEDIMENTO 10.7: SETTING PROPERTIES
1. Click File > Properties. A dialog opens. It has, among others, the following tabs:
2. Change to the Description tab and insert title, subject, and your keywords.
3. Switch to the Custom Properties tab.
4. To add a row for a property, click Add.

5. In the Name column, click the drop-down box for the entry. A list of properties appears,

from it, choose Owner.
6. Insert the name of the owner in the Value column.

7. Repeat from Passo 4 but as the name of the property, this time, choose Received from.
Optionally, repeat from Passo 4 for more properties.

To remove a property, click the red icon at the end of the corresponding row.

8. Leave the dialog with OK.

9. Save the file.

10.10 For More Information

LibreOffice contains extensive online help. In addition, a large community of users and
developers support it. The following list shows some places where you can go for additional

information.

LibreOffice Application Help (Help > LibreOffice Help)

Extensive help on performing any task in LibreOffice.

https://www.libreoffice.org #

Home page of LibreOffice
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https://ask.libreoffice.org #

Official question and answer page for LibreOffice.

http://www.taming-libreoffice.com/#

Taming LibreOffice: books, news, tips and tricks.

http://www.pitonyak.org/oo.php @

Extensive information about creating and using macros.

http://extensions.libreoffice.org/ &

Extension and template directory for LibreOffice.

https://www.worldlabel.com/Pages/openoffice-template.htm <&

Templates for creating labels with LibreOffice.
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11 LibreOffice Writer

LibreOffice Writer is a full-featured word processor with page and text formatting
capabilities. Its interface is similar to interfaces of other major word processors,
and it includes some features that are usually found only in desktop publishing

applications.

This chapter highlights a few key features of Writer. For more information about
these features and for complete instructions for using Writer, look at the LibreOffice

help or at the sources listed in Secdo 70.70, “For More Information”.

Much of the information in this chapter can also be applied to other LibreOffice
modules. For example, other modules use styles similarly to how they are used in
Writer.

11.1 Creating a New Document
There are multiple ways to create a new Writer document:

® From Scratch. To create a new empty document, click File > New > Text Document.

® Using a Wizard. To use a standard format and predefined elements for your own

documents, use a wizard. Click File > Wizards > Letter and follow the steps.

® From a Template. To use a template, click File > New > Templates and open, for example,
Business Correspondence. From the list of text document templates, select the one that fits

your needs.

For example, to create a business letter, click File >» Wizards > Letter. Using the wizard, you can
easily create a basic document using a standard format. A sample wizard dialog is shown in

Figura 11.1.
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FIGURA 11.1: A LIBREOFFICE WIZARD

Enter text in the document window as desired. Use the tools for applying and changing styles
or the tools for direct formatting to adjust the appearance of the document. Use the File menu
or the relevant buttons in the toolbar to print and save your document. With the options under

Insert, add extra items to your document, such as a table, picture, or chart.

11.2 Formatting with Styles

The traditional way of formatting office documents is direct formatting. That means, you use a
button, such as Bold, which sets a certain property (in this case, a bold typeface). With styles,
you can bundle a set of properties (for example, font size and font weight) and give them a
speaking name, such as Headline, first level. Using styles, rather than direct formatting has the

following advantages:
® Gives your pages, paragraphs, texts, and lists a consistent look.
® Makes it easy to consistently change formatting later.
¢ Allows reuse and import of styles from another document.

¢ Change one style and its properties are passed on to its descendants.
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EXEMPLO 11.1: USE OF STYLES

Imagine that you emphasize text by selecting it and clicking the button Bold. Later, you
decide you want the emphasized text to be italicized. Now, without styles, you need to

find all bold text and manually change it to italics.

If you had used a character style from the beginning, however, you would only need
to change the style from bold to italics once. All text formatted with a style changes its

appearance as the style is changed.

LibreOffice can use styles for applying consistent formatting to various elements in a document.

The following types of styles are available in Writer:
TABELA 11.1: TYPES OF STYLES
Type of Style Function

Paragraph Applies standardized formatting to the various types of
paragraphs in your document. For example, apply a paragraph
style to a first-level heading to set the font and font size, spacing
above and below the heading, location of the heading, and other

formatting specifications.

Character Applies standardized formatting for types of text. For example,
if you want emphasized text to appear in italics, you can create
an emphasis style that italicizes selected text when you apply the

style to it.

Frame Applies standardized formatting to frames. For example, if your
document uses marginal notes, you can create frames with
specified borders, location, and other formatting, so that all of

your marginal notes have a consistent appearance.

Frames are also used for captioning images: A frame can keep
the caption and the image together. Here, you can use frame
style to make sure that all your images have the same size and

background color, for example.

Page Applies standardized formatting to a specified type of page. For
example, if every page of your document contains a header and
footer except for the first page, you can use a first page style that
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Type of Style Function

disables headers and footers. You can also use different page
styles for left and right pages so that you have bigger margins on
the insides of pages and your page numbers appear on an outside

corner.

List Applies standardized formatting to specified list types. For
example, you can define a checklist with square check boxes and
a bullet list with round bullets, then easily apply the correct style

when creating your lists.

Direct formatting overrides any styles you have applied. For example, format a piece of text
both with a character style and using the button Bold. Now, the text will be bold, no matter

what is set in the style.

To remove all direct formatting, first select the appropriate text, then right-click it and choose

Clear Direct Formatting.

Likewise, if you manually format paragraphs using Format > Paragraph, you can end up with
inconsistent paragraph formatting. This is especially true if you copy and paste paragraphs from
other documents with different formatting. However, if you apply paragraph styles, formatting
remains consistent. If you change a style, the change is automatically applied to all paragraphs

formatted with that style.

11.2.1 The Side Bar Panel Styles and Formatting

The side bar panel Styles and Formatting is a versatile formatting tool for applying styles to text,
paragraphs, pages, frames, and lists. To open this panel, click Styles > Styles and Formatting, click

the button Styles and Formatting (a T) in the side bar or press Fi1 .
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FIGURA 11.2: STYLES AND FORMATTING PANEL

LibreOffice comes with several predefined styles. You can use these styles as they are, modify
them, or create new styles. Use the icons at the top of the panel to display formatting styles
for the most common elements such as paragraphs, frames, pages or lists. To learn more about
styles, continue with the instructions below.

11.2.2 Applying a Style

To apply a style, select the element you want to apply the style to, and double-click the style in
the panel Styles and Formatting. For example, to apply a style to a paragraph, place the cursor
anywhere in that paragraph and double-click the desired paragraph style.
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Alternatively, use the paragraph style selector in the toolbar Formatting.

11.2.3 Changing a Style

By changing styles, you can change formatting throughout a document, rather than applying

the change separately everywhere you want to apply the new formatting.

To change an existing style, proceed as follows:
1. In the panel Styles and Formatting, right-click the style you want to change.
2. Click Modify.

3. Change the settings for the selected style.
For information about the available settings, refer to the LibreOffice online help.

4. Click OK or Apply.

11.2.4 Creating a Style

LibreOffice comes with a collection of styles to suit many needs of most users. However, if you
need a style that does not yet exist and want to create your own style, follow the procedure

below:

PROCEDIMENTO 11.1: CREATING A NEW STYLE
1. Open the panel Styles and Formatting with Styles > Styles and Formatting, or pressing F11 .

2. Make sure you are in the list of styles for the type of style you want to create.
For example, if you are creating a character style, make sure you are in the character style

list by clicking the corresponding icon in the panel Styles and Formatting.
3. Right-click anywhere in the list of styles in the panel Styles and Formatting.
4. To open the style dialog, click New. The Organizer tab is preselected.

5. Configure three basic properties of the new style:

Name

The name of your style. Choose any name you like.
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Next Style
The style that follows your style. The style selected here is used when starting a new
paragraph by pressing Enter . This is useful, for example, for headlines, after which

you usually want to start a normal paragraph of text.

Inherit From
A style that your style depends on. If the selected style is changed, your style changes
as well. For example, to make headers consistent, create a “parent” header style and
have subsequent headers depend on it. This is useful when you only want to change

the properties that need to be different.

For details about the style options available in any tab, click the Help button of the dialog.

6. Confirm with OK. This closes the window.

11.2.4.1  Example: Defining a Note Style

Let us assume, you need a note with a different background and borders. To create such a style,

proceed as follows:
PROCEDIMENTO 11.2: CREATING A NOTE STYLE
1. Press F1l1 . The panel Styles and Formatting opens.

2. Make sure you are in the Paragraph Style list by checking that the pilcrow icon () is

selected.
3. Right-click anywhere in the list of styles in the panel Styles and Formatting and select New.

4. Specify the following parameters in the tab Organizer:

Name Note

Next Style Note

Inherit from - None -
Category Custom Styles
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5. Change the indentation in the tab Indents & Spacing, using the text field Before Text. If you
also want more space above and below individual paragraphs, change the values in the

Above paragraph and Below paragraph accordingly.
6. Switch to the tab Background and choose a color for the background.

7. Switch to the tab Borders and determine your line arrangements, line style, color and other

parameters.
8. Confirm with OK. This closes the window.

9. Select your text in your document and double-click the style Note. Your style parameters

are applied to the text.

11.2.4.2 Example: Defining an Even-Odd Page Style

If you want to create double-sided printouts of your documents, especially if they are supposed
to be bound, use templates for even and odd pages. To create page styles for this, proceed as

follows:

PROCEDIMENTO 11.3: CREATE AN EVEN (LEFT) PAGE STYLE

1. Press F11 . The panel Styles and Formatting opens.

2. Make sure you are in the list Page Style by checking that the paper sheet icon is selected.
3. Right-click anywhere in the list of styles in the panel Styles and Formatting and select New.

4. Enter the following parameters in the tab Organizer:

Name Left Content Page

Next Style Leave empty, will be changed later
Inherit from not applicable

Category not applicable

5. Change additional parameters as you like in the other tabs. You can also adapt the page

format and margins (tab Page) or any headers and footers.

6. Confirm with OK. This closes the window.
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PROCEDIMENTO 11.4: CREATE AN ODD (RIGHT) PAGE STYLE

1. Follow the instruction in Procedimento 11.3, “Create an Even (Left) Page Style” but use the string

Right Content Page in the Organizer tab.
2. Select the entry Left Content Page from the drop-down box Next Style.

3. Choose the same parameters as you did for the left page style. If you used different sizes

for the left and right margin of your even page, mirror these values in your odd pages.

4. Confirm with OK. This closes the window.

Then connect the left page style with the right page style:

PROCEDIMENTO 11.5: CONNECT THE RIGHT PAGE STYLE WITH THE LEFT PAGE STYLE
1. Right-click the entry Left Content Page and choose Modify.

2. Choose Right Content Page from the drop-down box Next Style.

3. Confirm with OK. This closes the window.

To attach your style, make sure your page is a left (even) page and double-click Left Content Page.
Whenever your text exceeds the length of a page, the following page automatically receives the

alternative page style.

11.3 Working with Large Documents

You can use Writer to work on large documents. Large documents can be either a single file or

a collection of files assembled into a single document.

11.3.17  Navigating in Large Documents

The Navigator tool displays information about the contents of a document. It also lets you quickly
jump to different elements. For example, use the Navigator to get a quick overview of all images

included in a document.

To open the Navigator, click View > Navigator or press F5 . The elements listed in the Navigator

vary with the document loaded in Writer.

The Navigator is also an element of the side bar: There, it can be opened using the button

Navigator (a compass).
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Double-click an item in the Navigator to jump to that item in the document.
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FIGURA 11.3: NAVIGATOR TOOL IN WRITER

11.3.2 Using Master Documents

If you are working with a very large document, such as a book, it can be easier to manage
the book with a master document, rather than keeping the book in a single file. A master
document enables you to quickly apply formatting changes to a large document or to jump to
each subdocument for editing.

A master document is a Writer document that serves as a container for multiple Writer files.
You can maintain chapters or other subdocuments as individual files collected in the master
document. Master documents are also useful if multiple users are working on a single document.
You can separate each user’s section of the document into subdocuments collected in a master
document, allowing multiple writers to work on their subdocuments at the same time without
fear of overwriting the work of others.

PROCEDIMENTO 11.6: CREATING A MASTER DOCUMENT

1. Click New > Master Document.
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or

Open an existing document and click File > Send > Create Master Document.
2. The Navigator window will open. In it, select Insert (=), then choose File.

3. Select a file to add an existing file to the master document.

PROCEDIMENTO 11.7: ADDING A NEW DOCUMENT TO A MASTER DOCUMENT
1. In the window or panel Navigator, choose Insert (=), then select New Document.
2. A file chooser opens, to allow saving the new document. Specify a name, then click Save.

3. When you are done editing the new document, save it. Then switch back to the master

document.

4. Update the master document with the contents of the new document. To do so, right-click

the entry of your new document in the Navigator, then click Update > Selection.

To enter some text directly into the master document, select Insert > Text.

The LibreOffice help files contain more complete information about working with master

documents. Look for the topic named Using Master Documents and Subdocuments.

@ Dica: Styles and Templates in Master Documents

The styles from all of your subdocuments are imported into the master document. To
ensure that formatting is consistent throughout your master document, use the same

template for each subdocument. Doing so is not mandatory.

However, if subdocuments are formatted differently, you might need to do some
reformatting to successfully bring subdocuments into the master document without
creating inconsistencies. For example, if two documents within a master document
include styles with the same name, the master document will use the formatting specified

for the style in the document imported first.

11.4 Using Writer as an HTML Editor

In addition to being a full-featured word processor, Writer also functions as an HTML editor.
You can style HTML pages like any other document, but there are specific HTML Styles that
help with creating good HTML. You can view the document as it will appear online, or you can
directly edit the HTML code.
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PROCEDIMENTO 11.8: CREATING AN HTML PAGE

1.

2.

8.

Click File > New > HTML Document.

Press F11 to open the panel Styles and Formatting.

. At the bottom of the panel Styles and Formatting, click the drop-down box to open it.

Select HTML Styles.

. Create your HTML page, using the styles to tag your text.
. Click File > Save As.

. Select the location where you want to save your file and name the file. Make sure that in

the bottom drop-down box, HTML Document is selected.

Click OK.

To edit HTML code directly or to see the HTML code created when you edit the HTML file as
a Writer document, click View >» HTML Source. In HTML Source mode, the Formatting and Styles

list is not available.

The first time you switch to HTML Source mode, you are prompted to save the file as HTML,

if you have not already done so.

To switch back from HTML Source mode to Web Layout, click View > HTML source again.
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12 LibreOffice Calc

Calc is the LibreOffice spreadsheet module. Spreadsheets consist of several sheets, containing
cells which can be filled with elements like text, numbers, or formulas. A formula can manipulate
data from other cells to generate a value for the cell in which it is inserted. Calc also allows you
to define ranges, filter and sort data and creates charts from data to present it graphically. Using
pivot tables, you can combine, analyze or compare larger amounts of data.

This chapter can only introduce some very basic Calc functionality. For more information and for
complete instructions, see the LibreOffice application help and the sources listed in Secdo 70.70,

“For More Information”.

@ Nota: VBA Macros

Calc can process many VBA macros in Excel documents. However, support for VBA macros
is not complete. When opening an Excel spreadsheet that makes heavy use of macros,

you might discover that some do not work.

12.1 Creating a New Document
There are two ways to create a new Calc document:

® From Scratch. To create a new empty document, click File > New > Spreadsheet.

® From a Template. To use a template, click File > New > Templates and open, for example,

Finances. From the list of spreadsheet templates, select the one that fits your needs.

Access the individual sheets by clicking their respective tabs at the bottom of the window.

Enter data in the cells as desired. To adjust the appearance, either use the Formatting toolbar
or side bar panel, or use the Format menu—or define styles as described in Secdo 72.2, “Using
Formatting and Styles in Calc”. Use the File menu or the relevant buttons in the toolbar to print

and save your document.
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12.2 Using Formatting and Styles in Calc

Calc comes with a few built-in cell and page styles to improve the appearance of your
spreadsheets and reports. Although these built-in styles are adequate for many uses, you will

probably find it useful to create styles for your own frequently used formatting preferences.
PROCEDIMENTO 12.1: CREATING A STYLE
1. Click Format > Styles > Styles and Formatting or press F1l .

2. At the top of the panel Styles and Formatting, click either Cell Styles (a green cell) or Page

Styles (a document).
3. Right-click anywhere in the list of styles in the panel Styles and Formatting. Then click New.

4. Specify a name for the style and use the various tabs to set the desired formatting options.

5. When you are done configuring the style, click OK.

PROCEDIMENTO 12.2: MODIFYING A STYLE
1. Click Format > Styles > Styles and Formatting.

2. At the top of the panel Styles and Formatting, click either Cell Styles (a green cell) or Page

Styles (a document).
3. Right-click the name of the style you want to change, then click Modify.

4. Change the desired formatting options.

5. When you are done configuring the style, click OK.

To apply a style to specific cells, select the cells you want to format. Then double-click the style

you want to apply in the Styles and Formatting window.

12.3 Working With Sheets

Sheets are a good method to organize your calculations. For example, if you have a business,

accounting might be much clearer if you create a sheet for each month.

To insert a new sheet after the last sheet, click the button + next to the sheet tabs.
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To insert one or more new sheets into your spreadsheet from a file or at a specific position at

once, do the following:

PROCEDIMENTO 12.3: INSERTING NEW SHEETS

1. Right-click a sheet tab and select Insert Sheet. A dialog opens.

2. Decide whether the new sheet should be positioned before or after the selected sheet.

3. To create a new sheet, make sure the New Sheet radio button is activated. Enter the number
of sheets and the sheet name. Skip the rest of this step.

Alternatively, to import a sheet from another file, do the following:

a. (Opcional) Select From file and click Browse.

b. (Opcional) Select the file name and confirm with OK. All the sheet names are now

displayed in the list.

C. (Opcional) Select the sheet names you want to import by holding the shift key

and clicking them.

4. To add the sheet or sheets, confirm with OK.

To rename a sheet, right-click the tab of the sheet and select Rename Sheet. Alternatively, you

can also double-click the sheet tab.

To delete one or multiple sheets, do the following: Select the sheet you want to delete. To select
more than one sheet, hold down shift while making the selection. Then right-click the tab of

the sheet, choose Delete Sheet and confirm with Yes.

12.4 Conditional Formatting

Conditional formatting is a useful feature to highlight certain values in your spreadsheet. For
example, define a condition and if the condition is true, a style is applied to each cell that
fulfills this condition.

@ Nota: Enable AutoCalculate

Before you apply conditional formatting, choose Tools > Cell Contents > AutoCalculate. You

should see a check mark in front of AutoCalculate.
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PROCEDIMENTO 12.4: USING CONDITIONAL FORMATTING

103

1. Define a style first. This style is applied to each cell when your condition is true. Use

Format > Styles and Formatting or press F11 . For more information, see Procedimento 12.1,
“Creating a Style”. Confirm with OK.

. Select the cell range where you want to apply your condition.
. Select Format > Conditional Formatting > Condition from the menu. A dialog opens.

. You now see a template for a new condition. Conditions can operate in multiple modes:

Cell value is
The condition tests if a cell matches a certain value. Next to the first drop-down box,
select an operator such as equal to, less than, or greater than.

Formula is

The condition tests if a certain formula returns true.

Date is

The condition tests if a certain date value is reached.

All Cells
This mode allows creating data visualizations that depend on the value of a cell,
similarly to Cell value is. However, with All Cells, you can use one condition to apply
an entire range of styles.
The types of styles that can be used are color scales (cell background color), data
bars (bars with changing width in the cell) and icon sets (an icon in the cell).
For example, a color scale allows assigning 0 a black background and 100 a green
background. All values in between are calculated automatically. For example, 50
receives a dark green background.

. For this example, keep the default: Cell value is.
. Select an operator and the value of the cell you want to test for.

. Choose the style you want to apply when this condition is true or click New Style to define

d new appearance.

. If you need additional conditions, click Add. Then repeat the previous steps.

. Confirm with OK. Now the style of your cells has changed.
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12.5 Grouping and Ungrouping Cells

Grouping a cell range allows hiding parts of a spreadsheet. This makes spreadsheets more
readable, as you can hide all the parts you are not currently interested in. It is possible to group

rows or columns and nest groups in other groups.

To group a range, proceed as follows:
PROCEDIMENTO 12.5: GROUPING A SELECTED CELL RANGE

1. Select a cell range in your spreadsheet.

2. Select Data > Group and Outline > Group. A dialog appears.

3. Decide if you want to group your selected range by rows or by columns. Confirm with OK.

After grouping selected cells, a line indicating the grouped cell range appears in the upper-left
margin. Fold or unfold the cell range with the + and — icons. The numbers at the top left of the

margins display the depth of your groups and can be clicked too.

To ungroup a cell range, click into a cell which belongs to a group and select Data > Group and

Outline > Ungroup. The line in the margin disappears. The innermost group is always deleted first.

12.6 Freezing Rows or Columns as Headers

If you have a spreadsheet with lots of data, scrolling usually makes the header disappear.

LibreOffice can lock rows or columns or both, so they remain fixed as you scroll around.

To freeze a single row or a single column, proceed as follows:

PROCEDIMENTO 12.6: FREEZING A SINGLE ROW OR COLUMN

1. To create a frozen area before a row, click the header of the row (1, 2, 3, ...).
Alternatively, to create a frozen area above a column, click the header of the column (A,
B, C,...).

2. Select View > Freeze Rows and Columns. A dark line appears, indicating the frozen area.

It is also possible to freeze both rows and columns:

PROCEDIMENTO 12.7: FREEZING ROW AND COLUMN

1. Click into the cell to the right of the column and below the row you want frozen. For
example, if your header occupies the space from Al to B3, click cell C4.
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2. Select View > Freeze Rows and Columns. A dark line appears, indicating which area is frozen.

To unfreeze, select View > Freeze Rows and Columns. The check mark before the menu item

disappears.
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13 LibreOffice Impress, Base, Draw e Math

Além do LibreOffice Writer e do LibreOffice Calc, o LibreOffice também inclui os médulos
Impress, Base, Draw e Math. Com eles, é possivel criar apresentacoes, gerar bancos de dados,

desenhar graficos e diagramas e criar férmulas matematicas.

13.1 Usando apresentacdes com o Impress

Use o LibreOffice Impress para criar apresentagoes para exibicao em tela ou impressao. Se vocé ja
tiver usado algum outro software de apresentacao, o Impress facilitard a mudanca. Ele funciona

de forma bem semelhante aos outros softwares de apresentacao.

13.1.1  Criando uma apresentacdo

Ha véarias formas de criar um novo documento do Impress:

® Do Zero. Para criar um novo documento vazio, clique em Arquivo > Novo > Apresentacdo.

¢ Usando um Assistente. Para usar um formato padrdo e elementos predefinidos em seus
documentos, utilize um assistente. Clique em Arquivo > Assistentes > Apresentacdo e siga as

etapas.

® De um Gabarito. Para usar um gabarito, clique em Arquivo > Novo > Modelos e abra,
por exemplo, Planos de fundo para apresentacdes. Na lista de gabaritos de apresentacao,

selecione o mais adequado as suas necessidades.

O seguinte procedimento descreve como criar uma apresentacdo usando o assistente. Proceda

da seguinte maneira:

PROCEDIMENTO 13.1: CRIANDO UMA APRESENTAGAO COM O ASSISTENTE
1. Inicie o LibreOffice.
2. Selecione Arquivo > Assistentes > Apresentagdo.

3. Escolha Do modelo. Selecione Planos de fundo para apresenta¢des no menu popup para

definir o fundo de sua preferéncia e clique em Préximo.
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() Apresentacdo vazia

Tipo

(») A partir do modelo

() Abrir uma apresentacdo existente
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logatipo
agqui

|» Visualizar

l Ajuda H Cancelar H <<\/oltar HPréximo» l Criar

4. Selecione um meio de saida. O meio de saida é o formato da apresentacao final, como:
Overhead sheet (Transparéncia), Papel, uma apresentacdo de slides em Tela 4:3 ou Tela
Ampla 16:9, entre outras opcoes.

Para ver uma miniatura de suas opgoes, verifique se Visualizar esta ativado. Se todas as

opcoes estiverem definidas conforme o desejado, clique em Préximo.

5. Para usar efeitos nas transicoes de slide, selecione um Efeito e a respectiva Velocidade. O

efeito é visualizado imediatamente.

6. Use o tipo de apresentacao padrao ou escolha Automdtico para especificar o tempo que

cada pagina é exibida e o tempo de pausa entre as apresentacdes.

7. Se todas as opcdes estiverem definidas conforme o desejado, clique em Criar.

A apresentacdo é aberta e estd pronta para ser editada.
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13.1.2 Usando paginas master

As péaginas master proporcionam a apresentacao uma aparéncia consistente, pois definem quais

fontes e outros elementos de design serdo usados. O Impress usa dois tipos de paginas master:

Slide master

Contém elementos que aparecem em todos os slides. Por exemplo, vocé pode desejar que o
logotipo de sua empresa apare¢a no mesmo local em todos os slides. O slide master também
determina o estilo de formatacdo de texto para o cabecalho e a estrutura de tépicos de
todos os slides que usam a péagina master, assim como as informacoes que vocé desejar

que aparecam no cabecalho ou rodapé.

Master de notas

Determina a formatac@o e a aparéncia das notas na apresentacao.

13.1.2.1  Criando um slide master

O Impress é fornecido com uma colecdo de paginas master pré-formatadas. Para personalizar

ainda mais as apresentacoes, crie seus proprios slides masters.
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1. Inicie o Impress com uma apresentacao existente ou crie uma nova conforme descrito na

Secdo 13.1.1, “Criando uma apresentacGo”.

Clique em Exibir > Slide mestre.
Isso abre o slide master atual na Exibicdo Mestre. A barra de ferramentas Exibicdo Mestre

é exibida.
Clique o botao direito do mouse no painel esquerdo e clique em Novo mestre.

Edite o slide master até obter a aparéncia desejada.
A tela master permite editar estilos de contorno formatando diretamente o texto de

amostra no slide.

. Para concluir a edicdo dos slides master, na barra de ferramentas Exibi¢cdo Mestre, clique

em Fechar Exibi¢do Mestre. Se preferir, escolha Ver > Normal.
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@ Dica: Colete slides master em um gabarito

Ap6s criar todos os slides master que vocé deseja usar nas apresentacoes, vocé podera
grava-los em um gabarito do Impress. Assim, sempre que vocé desejar criar apresentacoes

que usem esses slides master, abra uma nova apresentacao com o gabarito.

13.1.2.2 Aplicando um slide master

E possivel aplicar os slides masters a slides selecionados ou a todos os slides de uma apresentacao.

1. Abra a sua apresentagao.

2. (Opcional) Para aplicar um slide master a vérios slides, mas nao a todos os slides: Selecione
os slides aos quais deseja aplicar o slide master.
Para selecionar vérios slides, pressione Ctrl no Painel de Slides enquanto clica nos slides

que vocé deseja usar.

3. No painel Tarefas, abra Pdginas mestres e clique na pagina master que deseja aplicar. O

slide master é aplicado a(s) pagina(s) correspondente(s).

Se nao for exibido o Painel de Tarefas, clique em Exibir > Painel de Tarefas.

13.2 Usando bancos de dados com o Base

O LibreOffice inclui o médulo de banco de dados Base. Use o Base para projetar um banco de
dados para armazenar varios tipos de informagoes. De um simples bloco de enderecos ou livro

de receitas até um sistema de gerenciamento de documentos sofisticado.

Tabelas, formularios, consultas e relatérios podem ser criados manualmente ou usando
assistentes préaticos. Por exemplo, o Assistente de Tabelas contém varios campos comuns para
uso comercial e pessoal. Os bancos de dados criados no Base podem ser usados como fontes de
dados, como por exemplo durante a criacao de cartas.

Uma explicacdo detalhada do design de bancos de dados com o Base estd fora do escopo
deste documento. Encontre mais informacdes nas fontes relacionadas na Secdo 70.70, “For More

Information”.
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13.2.1  Criando um banco de dados usando opc¢des predefinidas

O Base é fornecido com vérios campos de bancos de dados predefinidos para ajudé-lo a criar um

banco de dados. Um assistente guia vocé pelas etapas de criacdo de um novo banco de dados.

As etapas desta secao sdo especificas para a criacdo de um bloco de enderegos usando campos

predefinidos, mas nao é dificil segui-las para usar os campos predefinidos para qualquer uma

das opcoes de bancos de dados internas.

O processo para criar um banco de dados pode ser dividido em véarios subprocessos:

1. Criando o banco de dados

2. Configurando a tabela do banco de dados

3. Criando um formuldrio

4. Modificando o formuldrio

13.2.1.1 Criando o banco de dados
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1. Inicie o LibreOffice Base.

O Assistente de Banco de Dados é iniciado.

E possivel escolher entre criar um banco de dados HSQLDB ou Firebird.

HSQLDB Embutido (padréo)
Esse formato de banco de dados também esté disponivel em versdes mais antigas do
OpenOffice.org e do LibreOffice. Ele depende da instalacao do Java no computador.

Firebird Embutido
Esse formato de banco de dados pode ser usado apenas em versoes mais recentes do
LibreOffice. Ele ndo depende do Java. Quando vocé executa operacoes em grandes

bancos de dados, o Firebird pode ter melhor desempenho.

. Continue com Avangar.

Clique em Sim, registre o banco de dados para mim para disponibilizar as informacoées do
banco de dados a outros médulos do LibreOffice e marque as caixas de selecao para Abrir
o banco de dados para edi¢do e Criar tabelas usando o Assistente de Tabelas. Em seguida,

clique em Concluir.

V4 para o diretério no qual deseja gravar o banco de dados, especifique um nome para

ele e clique em Salvar.
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13.2.1.2 Configurando a tabela do banco de dados

Ap6s criar o banco de dados, caso tenha marcado a caixa de selecao Create tables using the table

wizard (Criar tabelas usando o Assistente de Tabelas), o Assistente de Tabelas sera aberto. Do

contrario, va para a area Tarefa e clique em Usar assistente para criar tabela. Em seguida, defina

os campos que vocé deseja usar na tabela do banco de dados.

Neste exemplo, configure um banco de dados de enderecos.
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1. Para este exemplo, clique em Pessoal.

A lista Tabelas de exemplo muda para mostrar as tabelas predefinidas para uso pessoal
em que estd o gabarito de tabela de endereco. O gabarito de tabela listado em Comerciais

contém tabelas comerciais predefinidas.

. Na lista Exemplos de tabelas, clique em Enderegos.

Os campos disponiveis para o bloco de enderecos predefinido sio mostrados no menu

Campos disponiveis.

. No menu Campos disponiveis, clique nos campos que vocé deseja usar no bloco de

enderecos.
Clique para selecionar um item de cada vez. Se preferir, selecione varios itens pressionando

e segurando a tecla shift e clique em cada item separadamente.

. Clique nos icones de seta tinica para a direita e seta tnica para a esquerda para incluir ou

remover os itens selecionados da lista Campos selecionados.
Para mover todos os campos disponiveis para o menu Campos selecionados, clique no icone

de seta dupla para a direita.

. Use os icones de seta para cima e seta para baixo para ordenar as entradas selecionadas e,

em seguida, clique em Préximo.

Os campos aparecem na tabela e nos formularios na ordem em que sao listados.
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Etapas Selecione os campos de sua tabela
_ Este Assistente ira ajuda-lo a criar uma tabela para seu banco de dados. Apds selecionar uma

2.Definir tipos e formatos
3. Definir chave primaria

4. Criar tabela

categoria de tabela e uma tabela de exemplo, escolha os campos que deseja incluir na tabela.
Vocé pode incluir campos de uma ou mais tabelas de exemplo.

Categoria
() Neg6cios

Exemplos de tabelas

= Pessoal

IEnderecos

v

Campos disponiveis

Campos selecicnados

Cidade

Foto | |[Endereco
[Titulo ~— | |Sobrenome .
|Hobbies | =2 | CodigoPostal | A |

|Apelido

|f | PaisOuRegiao | |

|[EnviarCartao
|IDEndereco
iDataNascimento

| << |

|" Ajuda | | < Voltar | | Avancar > | | Concluir | | Cancelar

6. Verifique se todos os campos estdo definidos corretamente.
E possivel mudar o nome, o tipo, os caracteres maximos do campo e se ele é ou nédo

obrigatério. Neste exemplo, deixe as configuracdes como estdo e clique em Avangar.

7. Verifique se as op¢oes Criar uma chave primdria e Adicionar automaticamente uma chave
primdria estao ativadas. Além disso, ative Valor automdtico.

Continue com Avangar.

8. Insira um nome para a tabela e ative Criar um formuldrio com base nessa tabela.

Clique em Concluir.

13.2.1.3 Criando um formulario

Em seguida, crie o formulério para usar ao digitar dados no bloco de enderecos.

Apés a etapa anterior, vocé ja deverd estar no Assistente de formuldrios. Do contrério, va para
a janela principal para abri-lo. Em Tabelas, clique o botao direito do mouse na tabela correta.

Clique em Assistente de formuldrios.

1. No Assistente de Formuldrios, clique no icone de seta dupla para a direita para mover todos

os campos disponiveis para a lista Campos no formuldrio, depois clique em Avancar.

2. Para adicionar um subformulério, ative Adicionar subformuldrio e clique em Préximo.
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Para este exemplo, aceite as sele¢oes padrao.
3. Selecione como vocé deseja organizar o formulério e clique em Avangar.

4. Selecione O formuldrio deve exibir todos os dados e deixe todas as caixas de selecao

desativadas, depois clique em Préximo.

5. Aplique um estilo e uma borda de campo e clique em Avangar.

Para este exemplo, aceite as sele¢oes padrao.

6. Dé um nome ao formuléario, ative Modificar o formuldrio e clique em Concluir.

13.2.1.4 Modificando o formulario

Depois que o formulario for definido, vocé podera modificar sua aparéncia conforme preferir.

Apés a etapa anterior, vocé ja devera estar no editor Formuldrio do banco de dados. Do contrario,
selecione o formulério certo clicando em Formuldrios na barra lateral da janela principal. Em
seguida, na area Formuldrios, clique o botao direito do mouse no formulario correto. Selecione
Editar.

1. Organize os campos no formulério arrastando-os para os novos locais.

Por exemplo, mova o campo Nome para que ele apareca a direita do campo Sobrenome.

2. Ao concluir a modificacdo do formulario, grave-o e feche-o.

13.2.1.5 Outras etapas
Ap6s criar as tabelas e formulérios do banco de dados, vocé estara pronto para digitar os dados.
Vocé também pode elaborar consultas e relatérios para ajudar a classificar e exibir os dados.

Consulte a ajuda online do LibreOffice e outras fontes relacionadas na Secdo 70.70, “For More
Information” para obter informacoes adicionais sobre o Base.

13.3 Criando graficos usando o Draw

Use o LibreOffice Draw para criar graficos e diagramas. Vocé pode exportar seus desenhos nos
formatos de graficos vetoriais mais comuns e importa-los para qualquer aplicativo que permita
importacdo de graficos, inclusive os outros médulos do LibreOffice. Também é possivel criar
versoes do Adobe* Flash* (SWF) de seus desenhos.
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PROCEDIMENTO 13.2: CRIANDO GRAFICOS
1. Inicie o LibreOffice Draw.

2. Use a barra de ferramentas Desenho a direita da janela para criar um gréafico. Para criar

uma nova forma ou um objeto de texto, use os botdes de forma da barra de ferramentas:

® Para criar uma forma ou objeto de texto tnico, clique uma vez em um botédo de

forma. Em seguida, clique e arraste sobre o documento para criar um objeto.

® Para criar uma forma ou objeto texto multiplo, clique duas vezes em um botao de
forma. Em seguida, clique e arraste sobre o documento para criar os objetos. Quando

terminar, clique no icone do ponteiro do mouse na barra de ferramentas.

3. Grave o gréfico.

Para embutir um grafico existente do Draw em um documento do LibreOffice, selecione
Inserir > Objeto > Objeto OLE. Selecione Criar do arquivo e clique em Pesquisar para navegar para

o arquivo do Draw a ser inserido.
Para editar o grafico mais tarde por conta prépria, ative Link para o arquivo.

Se vocé inserir um arquivo como objeto OLE, podera editar o objeto mais tarde clicando nele

duas vezes.

PROCEDIMENTO 13.3: ABRINDO O DRAW DE OUTROS MODULOS DO LIBREOFFICE

Um recurso particularmente Gtil do Draw é a capacidade de abri-lo de outros médulos
do LibreOffice para vocé criar um desenho que seja importado automaticamente para o

seu documento.

1. Em um médulo do LibreOffice (por exemplo, no Writer), clique em Inserir > Objeto > Objeto
OLE > Desenho do LibreOffice > OK.

A interface do usuério do Writer sera substituida pela do Draw.
2. Crie seu desenho.

3. Clique no documento, fora do frame do Draw.

O desenho seréa inserido automaticamente no documento.
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13.4 Criando formulas matematicas com o Math

Geralmente é dificil incluir formulas matematicas complexas nos documentos. Para facilitar
esta tarefa, o editor de equacao do LibreOffice Math permite criar férmulas usando operadores,
funcdes e assistentes de formatacio. E possivel gravar essas férmulas como um objeto que pode
ser importado para outros documentos. As funcées mateméticas podem ser inseridas em outros

documentos do LibreOffice como qualquer outro objeto gréfico.

@ Nota: O Math é para criacdo de férmulas matematicas

O Math ndo é uma calculadora. As funcoes que ele cria sdo objetos graficos. Mesmo que

elas sejam importadas para o Calc, essas funcoes ndo poderdo ser avaliadas.

Para criar uma férmula, faca o seguinte:

1. Inicie o LibreOffice Math.
2. Clique em Arquivo > Novo > Férmula. A janela da férmula é aberta.

3. Digite sua férmula na parte inferior da janela. Por exemplo, o teorema binomial na sintaxe
do LibreOffice Math é:

(a + b)*2 =a"2 +2ab+ b2
O resultado aparece na parte superior da janela.

4. Use o painel da barra lateral Elementos da Férmula ou clique o botado direito do mouse
na parte inferior da janela para inserir outros termos. Se precisar de simbolos, use

Ferramentas > Simbolos para inserir, por exemplo, Grego ou outros caracteres especiais.

5. Grave o documento.
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O resultado é mostrado na Figura 13.1, “Formula matemdtica no LibreOffice Math”:
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FIGURA 13.1: FORMULA MATEMATICA NO LIBREOFFICE MATH

E possivel incluir sua férmula no Writer, por exemplo. Para fazer isso, proceda da seguinte

maneira:

1. Crie um novo documento do Writer ou abra um existente.

OLE.

3. Selecione Criar a partir do arquivo.

em Abrir.

5. Confirme com OK. A férmula é inserida na posicao do cursor atual.

2. Selecione Inserir > Objeto > Objeto OLE no menu principal. Aparece a janela Inserir objeto

4. Clique em Pesquisar para localizar sua férmula. Para escolher o arquivo de férmula, clique

Para editar a férmula mais tarde por conta prépria, ative Link para o arquivo.
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14 Firefox: navegando na Web

O browser da Web Mozilla Firefox esta incluido no SUSE® Linux Enterprise
Server. Com recursos como navegacao com guias, bloqueio de janelas popup e
gerenciamento de downloads, o Firefox combina as mais recentes tecnologias de
navegacao e seguranca com uma interface facil de usar. O Firefox permite acessar
facilmente diversos mecanismos de pesquisa para ajudar vocé a encontrar as

informacoes necessarias.

14.1 Iniciando o Firefox

Para iniciar o Firefox, selecione Aplicativos > Internet > Firefox.

14.2 Navegando em sites na Web

A aparéncia do Firefox é similar a de outros browsers. Isso é mostrado na Figura 14.1, “Janela do
browser Firefox”. Na parte superior da janela, vocé encontra a barra de localizacao para enderecos
da Web e a barra de pesquisa. Favoritos também estao disponiveis para acesso rapido na barra
de ferramentas dos favoritos. Para obter mais informagoes sobre os varios recursos do Firefox,

use o menu Ajuda na barra de menus.

@ Nota: Utilizando a barra de menus

Embora a maioria das funcées do Firefox esteja disponivel no botdo de trés linhas (=),
algumas estdo disponiveis apenas na barra de menus.

Por padrao, a barra de menus do Firefox fica oculta. Para mostra-la temporariamente,
pressione Alt . Ela permanecera exibida até vocé clicar em algum outro lugar na janela

do Firefox.

Para habilitar a barra de menus do Firefox permanentemente, primeiro pressione Alt ,

depois escolha Exibir > Barras de ferramentas e ative Barra de menus.
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FIGURA 14.1: JANELA DO BROWSER FIREFOX

14.2.1 Barra de Localizacdo

Quando vocé digita na barra de localizagdo, aparece uma caixa suspensa de preenchimento
automatico. Ela mostra todos os enderecos de localizacao anteriores e favoritos que incluem os
caracteres que vocé estd digitando. A frase correspondente é realcada em negrito. As entradas

visitadas mais frequentemente e recentemente sdo listadas primeiro.

As entradas de lista da lista de favoritos sdo marcadas com uma estrela. Os favoritos com tags
sdo marcados com um rétulo adicional seguido dos nomes das tags. As entradas de lista do
histérico de navegacdo nao sao marcadas. Para pesquisar apenas em seus favoritos, digite *

como o primeiro caractere da pesquisa.

Use t+ e ¢ ouaroda do mouse para navegar pela lista. Pressione Enter ou clique em uma
entrada para ir para a pagina selecionada. Del remove uma entrada da lista se a entrada
pertencer ao histérico. As entradas adicionadas aos favoritos sé6 podem ser removidas quando

se apaga o favorito associado.
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14.2.2 Ampliando

O Firefox oferece duas opcoes de zoom: zoom de pagina (o padrdo) e zoom de texto. O zoom

da pagina amplia a pagina inteira como esti, com todos os respectivos elementos expandidos

igualmente, incluindo os graficos. J4 o zoom de texto muda apenas o tamanho do texto.

Para alternar entre zoom de pagina e texto, escolha Exibir > Zoom > Somente do texto. Para ampliar

ou reduzir, use a roda do mouse enquanto pressiona a tecla Ctrl ouuse Ctrl—+ e Ctrl— -

Para redefinir o fator de zoom, use Ctrl—0 .

14.2.3 Navegacdo por guias

A navegacao com guias permite carregar varios sites na Web em uma tnica janela. Para alternar

entre as paginas em uso, clique nas guias na parte superior da janela. Se vocé usa frequentemente

mais de uma pagina da Web de uma vez, a navegacédo com guias facilita alternar entre as paginas.

Abrindo guias

Para abrir uma nova guia, na barra de menus, selecione Arquivo > Nova aba ou pressione

ctrl — T . Esse procedimento abre uma guia vazia na janela do Firefox. Para abrir um link
em uma pagina da Web ou um favorito em uma guia, clique o botdo do meio do mouse
nele. Se preferir, clique o botao direito do mouse em um link e selecione Abrir em nova aba.
Também € possivel abrir um endereco na barra de localizagdo em uma nova guia clicando

no meio do mouse ou pressionando Ctrl — Enter .

Fechando guias

Clique o botao direito do mouse em uma guia para abrir o menu de contexto, que permite
acessar as opcOes de gerenciamento de guias como fechar, recarregar ou marcar como
favorito. Para fechar uma guia, vocé também pode usar Ctrl —W ou clicar no botdo
Fechar aba. E possivel restaurar qualquer guia fechada escolhendo Histérico > Abas fechadas
recentemente na barra de menus. Para reabrir a dltima guia fechada, escolha Reabrir aba

no menu de contexto ou pressione Ctrl —shift —T .

Classificando guias

120

Por padrao, as guias sdo armazenadas na ordem em que vocé as abriu. Para reorganizar a
ordem das guias, arraste e solte uma guia na posicao desejada. Se vocé abrir um ntimero
grande de guias, nem todas poderao ser exibidas na barra de guias ao mesmo tempo. Use
as setas no fim da barra para mover para a esquerda ou clique o botao direito do mouse na
seta para baixo na extremidade direita da barra de guias para ver a lista de todas as guias.
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Arrastando e soltando
Arrastar e soltar também funciona com guias. Arraste um link para uma guia existente
para abri-lo nessa guia ou arraste e solte um link em um espaco vazio da barra de guias
para abrir uma nova guia. Arraste e solte uma guia fora da barra de guias para abri-la em

uma nova janela do browser.

14.2.4 Usando o painel lateral

Use a lateral esquerda da janela do browser para ver os favoritos ou o histérico de navegacao. As
extensdes também podem permitir novas maneiras de usar o painel lateral. Para exibir a barra

lateral, na barra de menus, selecione Exibir > Barra lateral e selecione o contetido desejado.

14.3 Localizando informacdes

H& duas maneiras de localizar informacoes no Firefox: para pesquisar a Internet com um
mecanismo de pesquisa, use a barra de pesquisa. Para pesquisar a padgina que esta exibida, use

a barra de localizacao.

14.3.1 Localizando informacdes na Web

O Firefox dispoe de uma barra de pesquisa capaz de acessar diferentes mecanismos como Google,
Yahoo ou Amazon. Por exemplo, para localizar informacoes sobre o SUSE usando o mecanismo
atual, clique na barra de pesquisa, digite SUSE e pressione Enter . Os resultados sdo exibidos

na janela.

Para escolher outro mecanismo de pesquisa, digite o termo de pesquisa e clique em um dos

icones de provedor de pesquisa na parte inferior da janela popup que aparece.

14.3.1.1 Personalizando a barra de pesquisa
Para adicionar ou apagar um mecanismo de pesquisa ou mudar a ordem deles, faca o seguinte.
1. Clique no icone a esquerda da barra de pesquisa.

2. Na janela popup, selecione Alterar configuragdes de pesquisa. A caixa de didlogo Pesquisar
mostra o mecanismo de pesquisa que esta definido como padrao e outros mecanismos de

pesquisa disponiveis.
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3. Para mudar a ordem das entradas, use o mouse para arrasta-las.
Para apagar uma entrada, selecione-a e clique em Remover.
Para adicionar um mecanismo de pesquisa, clique em Adicionar mecanismos de pesquisa. O

Firefox exibe uma péagina da Web com os plug-ins de pesquisa disponiveis. Para instalar

um plug-in de pesquisa, selecione-o e clique em Adicionar ao Firefox.

@ Geral Pesquisar
Q, Pesquisar
Contelido Mecanismo de pesquisa padrao
pesq B
Escolha o mecanismo de pesquisa padréo. O Firefox iré usa-lo na barra de endereco, barra de
pesquisa e na pagina inicial.
G Google -
¥ Fornecer sugest8es de pesquisa

Mostrar sugestdes de pesquisa na barra de localizagéio

€) Sync

Mecanismos de pesquisa em um clique

& Avancado
A barra de pesquisa permite pesquisar em mecanismos alternativos. Escolha um.

Mecanismo de pesquisa Palavra-chave

Google

(4]

Yahoo

¥ E

Bing

BuscaPé

=

©

DuckDuckGo

MercadoLivre

< 0

Twitter

L N N T T N

w Wikipedia (pt)
Restaurar mecanismos de pesquisa padrdo Remove

Adicionar mecanismos de pesquisa...

FIGURA 14.2: FIREFOX: GERENCIAR MECANISMOS DE PESQUISA

Alguns sites na Web oferecem mecanismos de pesquisa que vocé pode adicionar diretamente a
barra de pesquisa. Sempre que vocé visitar esse tipo de site na Web, o icone a esquerda da barra
de pesquisa terd um sinal de adicao +. Clique no icone e selecione Adicionar.

14.3.1.2 Adicionando palavras-chave as pesquisas online

O Firefox permite definir suas préprias palavras-chave: abreviacoes usadas como atalhos de URL
para determinado mecanismo de pesquisa. Se vocé definiu ws como uma palavra-chave para a
pesquisa na Wikipédia, por exemplo, pode digitar ws TERMODEPESQUISA na barra de localizacao
para pesquisar por TERMODEPESQUISA na Wikipédia.

Para atribuir um atalho para um mecanismo de pesquisa da barra de pesquisa, clique no icone
a esquerda da barra de pesquisa e selecione Alterar configuragbes de pesquisa. Selecione um
mecanismo de pesquisa, clique duas vezes na coluna Palavra-chave, digite uma palavra-chave

e pressione Enter .
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Também é possivel definir uma palavra-chave para qualquer campo de pesquisa em um site na

Web. Proceda da seguinte maneira:

1. Clique o botdo direito do mouse no campo de pesquisa e escolha Criar palavra-chave da
pesquisa no menu exibido. A caixa de didlogo Add Bookmark (Adicionar a favoritos) é

exibida.
2. Em Nome, digite um nome descritivo para essa palavra-chave.

3. Digite a sua Palavra-chave para esta pesquisa.

4. Clique em Salvar.

@ Dica: Palavras-chave para sites na Web usados com frequéncia

O uso de palavras-chave ndo se restringe aos mecanismos de pesquisa. Vocé também pode
adicionar uma palavra-chave a um favorito (pelas propriedades do favorito). Por exemplo,
se vocé atribuir suse ao favorito da home page do SUSE, podera abri-lo digitando suse

na barra de localizacao.

14.3.2 Pesquisando na pagina atual

Para pesquisar em uma pagina da Web, na barra de menus, clique em Editar > Localizar ou
pressione Ctrl —F . A barra de localizacdo é aberta. Geralmente, aparece uma barra na parte
inferior da janela. Digite a consulta na caixa de texto. O Firefox encontra a primeira ocorréncia
da frase digitada. Vocé pode encontrar outras ocorréncias da frase pressionando F3 ou o botdo
Next (Avancar) na barra de localizacdo. Se clicar no botao Real¢ar tudo, todas as ocorréncias da
frase serao realcadas. Marque a opcao Diferenciar maitisc./mintisc. para que a consulta diferencie
maitsculas de mintsculas.

O Firefox também oferece duas opcoes de localizacdo rapida. Clique em qualquer lugar em
que deseja iniciar a pesquisa na pagina da Web, digite / seguido, sem espaco, do termo de
pesquisa. A primeira ocorréncia do termo de pesquisa é realcada enquanto vocé digita. Use F3
para localizar a préxima ocorréncia. Também é possivel limitar a localizacdo rdpida apenas a

links. Esta opg¢do de pesquisa fica disponivel quando vocé digita
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14.4 Gerenciando marcadores

Os marcadores oferecem uma maneira facil de gravar links nos seus sites favoritos. O Firefox ndo
s6 facilita bastante a adicao de novos favoritos com apenas um clique do mouse, como também
oferece vérias formas de gerenciar grandes colecoes de favoritos. E possivel classificar favoritos

em pastas, classificd-los com tags ou filtra-los com pastas de favoritos inteligentes.

Adicione um favorito clicando na estrela na barra de localizacdo. A estrela ficard azul para
indicar que a pagina foi adicionada aos favoritos. O favorito serd gravado na pasta Ndo
organizados sob o titulo da pagina. Para mudar o nome e a pasta do favorito ou adicionar tags,
ap6s adicioné-lo aos favoritos, clique na estrela novamente. Uma janela popup é aberta para

vocé fazer as mudancas.

Para adicionar aos favoritos todas as guias abertas, clique o botdo direito do mouse em uma
guia e escolha Adicionar todas as abas. O Firefox solicita que vocé crie uma nova pasta para os

links das guias.

Para remover um favorito, abra o local adicionado como favorito. Em seguida, clique na estrela

e clique em Excluir.

14.4.1 Organizando favoritos

A Biblioteca pode ser usada para gerenciar as propriedades (nome e endereco) de cada favorito
e organizar os favoritos em pastas e secoes. Ele se assemelha a Figura 74.3, “Biblioteca de Favoritos

do Firefox”.

o o<:>> Organizar~  Exibir~  Importar e backup + Localizar nos favoritos Q
~ (@ Historico Nome Etiquetas Endereco
| Hoje B Barra de favoritos
<L Downloads T/ Menu de favoritos

* Etiquetas 4 N&o organizados
|+ Favoritos
4 Barra de favoritos

» =1 Menu de favoritos
[ Ndo organizados

Nome: | Favoritos

FIGURA 14.3: BIBLIOTECA DE FAVORITOS DO FIREFOX
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Para abrir a Biblioteca, na barra de menus, clique em Favoritos > Exibir todos os favoritos. A
janela da biblioteca estd dividida em duas partes: o painel esquerdo é a visdo em &arvore das
pastas, o painel direito mostra as subpastas e os favoritos da pasta selecionada. Use Exibir para

personalizar o painel direito. O painel esquerdo contém trés pastas principais:

Histérico
Contém todo o seu histérico de navegacdo. Nao é possivel mudar essa lista, apenas apagar

entradas dela.

Tags
Lista os favoritos de cada tag que vocé especificou. Consulte a Secdo 74.4.2, “Togs” para

obter mais informacdes sobre tags.

Favoritos

Essa categoria contém as trés pastas principais de favoritos:

Barra dos favoritos
Contém os favoritos e as pastas exibidas abaixo da barra de localizagdo. Consulte

Secdo 14.4.4, “A Barra de Ferramentas de Favoritos” para obter mais informacgoes.

Menu Favoritos
Inclui os favoritos e as pastas que podem ser acessadas pela entrada Favoritos no menu

principal ou no menu lateral dos favoritos.

N&o organizados
Contém todos os favoritos criados com um unico clique na estrela na barra de

localizacéo. Esta pasta sé estd visivel na biblioteca e na barra lateral dos favoritos.

Organize seus favoritos usando o painel direito. Escolha acbes para pastas ou favoritos no
menu de contexto aberto quando vocé clica o botao direito do mouse em um item ou no menu
Organizar. As propriedades de uma pasta ou um favorito escolhido podem ser editadas na parte
inferior do painel direito. Por padrao, apenas o Nome, o Endereco e os Marcadores sao exibidos

para um favorito. Clique na seta ao lado de Mais para acessar todas as propriedades.

Para reorganizar os favoritos, use o mouse para arrasta-los. E possivel usar esse procedimento
para mover um favorito ou uma pasta para outra pasta ou mudar a ordem dos favoritos em

uma pasta.
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14.4.2 Tags

As tags oferecem um modo pratico de arquivar um favorito sob véarias categorias. Vocé
pode marcar um favorito com quantos termos desejar. Por exemplo, para acessar todos os
sites marcados com suse, digite suse na barra de localizacdo. Para cada tag, um item é
automaticamente criado na pasta Tags recentes da biblioteca. Arraste e solte um item de uma

tag na barra de ferramentas de favoritos para acessa-lo facilmente.

Para adicionar tags a um favorito, abra o favorito no Firefox e clique na estrela amarela na
barra de localizacdo. A caixa de didlogo Editar este favorito aparece para vocé adicionar uma
lista de tags separadas por virgulas. Também é possivel adicionar tags pela caixa de didlogo
de propriedades do favorito, que vocé pode abrir na biblioteca ou clicando o botao direito do

mouse em um favorito no menu ou na barra de ferramentas.

14.4.3 Importando e exportando favoritos

Para importar favoritos de outro browser ou de um arquivo no formato HTML, abra a biblioteca
escolhendo, na barra de menus, Favoritos > Exibir todos os favoritos. Para iniciar o Assistente
de Importacao, clique em Importar e backup > Importar favoritos em HTML e escolha o local de
importacdo. Clique em Avangar para iniciar a importacédo. As importa¢oes de um arquivo HTML
sdo feitas como estao.

A exportacao de favoritos também é feita em Importar e backup na janela da biblioteca. Para
gravar seus favoritos como um arquivo HTML, escolha Exportar favoritos como HTML. Para criar
um backup dos favoritos, escolha Backup. O Firefox usa o formato de arquivo JavaScript Object

Notation (. json) para os backups.

Para restaurar um backup de favoritos, clique em Importar e backup > Restaurar. Em seguida,
localize o backup que deseja restaurar.

14.4.4 A Barra de Ferramentas de Favoritos

ABarra dos favoritos aparece abaixo da barra de localizacdo e possibilita o acesso rdpido aos
favoritos. Vocé também pode adicionar, organizar e editar favoritos diretamente. Por padrao,
a barra de ferramentas Favoritos é preenchida com um conjunto predefinido de favoritos

organizados em vdrias pastas (consulte a Figura 4.1, “Janela do browser Firefox”).
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Para gerenciar a Barra dos favoritos, use a biblioteca conforme descrito na Secdo 714.4.7,
“Organizando favoritos”. Seu conteido estd localizado na pasta Barra dos favoritos. Também é
possivel gerenciar diretamente a barra de ferramentas. Para adicionar uma pasta, favorito ou
separador, clique o botao direito do mouse em um espaco vazio na barra de ferramentas e
selecione a entrada apropriada no menu popup. Para adicionar a pagina atual a barra, clique no
icone da pagina da Web na barra de localizacdo e arraste-o até a posi¢do desejada na barra de
ferramentas de favoritos. Ao passar o cursor do mouse sobre uma pasta de favoritos existente,

ela é automaticamente aberta, permitindo que vocé coloque o favorito nessa pasta.

Para gerenciar determinada pasta ou favorito, clique o botao direito do mouse nele. Sera aberto
um menu que o deixard Apagar o item ou mudar suas Propriedades. Para mover ou copiar uma

entrada, escolha Cortar ou Copiar e Colar para colocé-la na posicao desejada.

14.5 Usando o gerenciador de downloads

Monitore os downloads atuais e antigos com o gerenciador de downloads. Para iniciar o
gerenciador de downloads, na barra de menus, clique em Ferramentas > Downloads. Durante o
download de um arquivo, uma barra de progresso indica o status do download. Caso necessério,
pause o download e continue-o mais tarde. Para abrir um arquivo obtido por download com o
aplicativo associado, clique em Abrir. Para abrir o local em que o arquivo foi gravado, escolha
Abrir pasta. Remover do histdrico apenas apaga a entrada do gerenciador de downloads, mas nao
apaga o arquivo do disco rigido.

Por padrdo, o download de todos os arquivos é feito em ~/Downloads. Para mudar esse

comportamento, na barra de menus, clique em Editar > Preferéncias. V4 para Geral. Em

Downloads, escolha outro local ou Sempre perguntar onde salvar arquivos.

@ Dica: continuando os downloads

Se o browser falhar ou fechar durante o download, todos os downloads pendentes serao
automaticamente retomados em segundo plano na préxima vez que o Firefox for iniciado.
Um download que tenha sido pausado antes do fechamento do browser podera ser

retomado manualmente por meio do gerenciador de downloads.
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14.6 Seguranca

J& que navegar na Internet estd cada vez mais arriscado, o Firefox oferece varias medidas para
tornar a navegacdo mais segura. Ele verifica automaticamente se vocé est tentando acessar
sites conhecidos por conter software prejudicial (malware) ou roubar dados sigilosos (phishing)
e o impede de entrar nesses sites. O ID instantdneo do site permite verificar facilmente a
legitimidade de um site, e um gerenciador de senha e bloqueador de popup oferecem seguranca
adicional. Com a Navegacao privativa, é possivel navegar pela Internet sem que o Firefox registre

os dados em seu computador.

14.6.1 Identidade do site instantanea

O Firefox permite a vocé verificar rapidamente a identidade de uma pagina da Web. O icone
na barra de localizacdo ao lado do endereco indica quais informacoes de identidade estao

disponiveis e se a comunicacao é criptografada:

Globo Cinza
O site nao fornece nenhuma informacao de identidade, e a comunicacdo entre o servidor

Web e o browser néo é criptografada. Nao troca informacoes confidenciais com esses sites.

Tridngulo Cinza
Este site pertence a um dominio que foi verificado por um certificado, portanto, pode ter
certeza de que estd conectado exatamente ao site que aparece. No entanto, o site tentou
carregar elementos adicionais, como imagens ou scripts, usando uma conexao nao segura.

O Firefox bloqueou esses itens. Portanto, a padgina pode parecer com defeito.

Cadeado Cinza
Este site pertence a um dominio que foi verificado por um certificado, portanto, pode ter
certeza de que estd conectado exatamente ao site que aparece. A comunicacado com um

site que tenha um “cadeado cinza” é sempre criptografada.

Cadeado Verde
Este site se identifica completamente por um certificado que garante a propriedade alegada
pela pessoa ou organizacdo. Isso é importante principalmente ao trocar dados muito
sigilosos (por exemplo, nas transacoes de dinheiro pela Internet). Nesse caso, vocé pode ter
certeza de que esté no site do seu banco na Web quando ele envia informag¢oes completas
de identidade. A comunicacao com um servidor que tenha um “cadeado verde” é sempre
criptografada.
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Para ver informagoes detalhadas de identidade, clique no icone do site na Web na barra de
localizacao. Na janela popup exibida, clique em Mais informagdes para abrir a janela Informagoes
da pdgina. Nela, vocé vé o certificado e o nivel de criptografia do site, além das informacoes
sobre senhas e cookies armazenados.

Na tela Permissoes, vocé pode definir as permissoes de carregamento de imagens, popups, cookies
e instalacdo para cada site. A tela Midia lista todas as imagens, os graficos em segundo plano e
os objetos embutidos de um site e exibe mais informacdes sobre cada item juntamente com uma

visualizacdo. E possivel também gravar itens individuais.

N ) =
G I=ZE =
Geral Midia  Permissbes Seguranca

SUSE Doc: SUSE linux Enterprise Desktop 12 - Table of Contents:

Endereco: https://www.suse.com/pt-br/documentation/sled-12/
Tipo: text/html

Renderizacdo: Modo de concordancia padrado

Codificacdo do texto: UTF-8

Tamanho: 16,8 KB (17.204 bytes)

Modificada em: Qui 22 Jun 2017 12:33:19 IST

4 Tags meta (5)

Nome Valor
content-language En-Us
|viewport width=device-width, initial-scale=1
|x-ua-compatible ie=edge

FIGURA 14.4: JANELA DE INFORMACOES SOBRE PAGINA DO FIREFOX

14.6.2 Importando certificados

O Firefox vem com um armazenamento de certificados para identificacdo das autoridades de
certificacao (CA). Ao usar esses certificados, o browser verifica automaticamente os certificados
emitidos pelos sites na Web. Se um site na Web emitir um certificado que néo tenha sido assinado
por uma das CAs do armazenamento de certificados, ele ndo sera confidvel. Isso garante que

nenhum certificado falsificado seja aceito.

Em geral, grandes organiza¢Oes usam suas proprias autoridades de certificacdo internamente
e distribuem os respectivos certificados pelo armazenamento de certificados de todo o sistema

localizado em /etc/pki/nssdb. Para configurar o Firefox (e outras ferramentas da Mozilla,
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como Thunderbird) para usar esse armazenamento de CAs de todo o sistema, além do seu
proprio, exporte a varidvel NSS _USE SHARED DB. Por exemplo, é possivel adicionar a seguinte
linha a ~/ .bashrc:

export NSS USE SHARED DB=1

Se preferir, ou além disso, é possivel importar certificados manualmente. Para fazer isso, na
barra de menus, abra a caixa de didlogo Preferéncias clicando em Editar > Preferéncias. Selecione
Avangado > Certificados > Exibir certificados > Seus certificados > Importar e selecione o certificado

que sera importado. Importe apenas certificados nos quais vocé confia plenamente!

14.6.3 Gerenciamento de Senhas

Toda vez que vocé digita um nome de usudrio e uma senha em um site na Web, o Firefox
oferece para armazenar esses dados. Uma janela popup é aberta na parte superior da pagina,
perguntando se vocé deseja que o Firefox memorize a senha. Se vocé aceitar clicando em
Lembrar, a senha serd armazenada em seu disco rigido em um formato criptografado. Da préxima

vez que vocé acessar esse site, o Firefox preenchera automaticamente os dados de login.

Para revisar ou gerenciar as senhas, abra o gerenciador de senhas clicando em
Editar > Preferéncias > Seguranca > Senhas memorizadas na barra de menus. O gerenciador de
senhas é aberto com uma lista de sites e os nomes de usuéario correspondentes. Por padrao, as
senhas nao sdo exibidas. Clique em Exibir senhas memorizadas para exibi-las. Para apagar uma
ou todas as entradas da lista, clique em Remover ou Remover tudo, respectivamente.

Para proteger as senhas contra acesso nao autorizado, vocé pode definir uma senha master
que serd necessiria ao gerenciar ou adicionar senhas. Na barra de menus, clique em

Editar > Preferéncias, escolha a categoria Seguranga e ative Usar uma senha mestra.

14.6.4 Navegacao privativa

Por padrao, o Firefox monitora seu histérico de navegacao armazenando conteddo e links dos
sites na Web visitados, cookies, downloads, senhas, termos de pesquisa e dados de férmula. A
coleta e o armazenamento desses dados torna a navegacao mais rapida e pratica. No entanto,
quando vocé usa um terminal puiblico ou o computador de um colega, por exemplo, convém
desativé-la. No modo Navegacao privativa, o Firefox ndo monitora seu histérico de navegacao

nem armazena em cache o contetido das péginas visitadas.
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Para habilitar o modo Navegacao privativa, na barra de menus, clique em Arquivo > Nova
janela privativa. O site na Web atual e todas as guias abertas serdo substituidos pela tela
de informacOes Navegacdo privativa. Enquanto vocé navegar no modo privativo, a string

(navegagdo privativa) serd exibida na barra de titulo da janela.
Feche a janela privativa para desabilitar a Navegacao privativa.

Para tornar a Navegacdo privativa o modo padrdo, abra a guia Privacidade na janela de
preferéncias, conforme descrito na Secdo 14.7.1, “Preferéncios”, defina a opcao O Firefox deve:

como Usar minhas configuragodes para historico e escolha Usar sempre navegagdo privativa.

Atencdo: favoritos e downloads

Downloads e favoritos gerados durante o modo Navegacao privativa sdo mantidos.

14.7 Personalizando o Firefox
O Firefox pode ser personalizado de forma abrangente.

® Para mudar o comportamento do Firefox, altere suas preferéncias.
¢ Adicione funcionalidades instalando extensoes.

® Mude a aparéncia instalando temas.

Para gerenciar extensoes, temas e plug-ins, o Firefox dispée do gerenciador de complementos.

14.7.1 Preferéncias

O Firefox oferece uma enorme variedade de opcoes de configuracao. Elas estao disponiveis em
Editar > Preferéncias na barra de menus. Cada opcao estd descrita em detalhes na Ajuda online,

que pode ser acessada clicando no icone de ponto de interrogacdo na caixa de didlogo.
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FIGURA 14.5: JANELA PREFERENCIAS

14.7.1.1 Gerenciamento de sessodes

Por padrao, o Firefox restaura automaticamente a sua sessdo (janelas e guias) somente apds
uma falha ou reinicializacdo por causa de uma extensdo. Entretanto, é possivel configura-lo
para restaurar uma sessao toda vez que ele for iniciado: Abra a caixa de didlogo Preferéncias,
conforme descrito na Secdo 14.7.1, “Preferéncias”, e va para a categoria Geral. Defina a opcao Ao

iniciar o Firefox: como Abrir janelas e abas da tiltima sessdo.
Se vocé tiver vérias janelas abertas, elas s6 serdo restauradas da préxima vez que vocé fechar

todas elas de uma vez com a opg¢ao Arquivo > Sair (na barra de menus) ou com as teclas Ctrt —Q .

Se vocé fechar as janelas uma por uma, apenas a tltima janela sera restaurada.

14.7.1.2 Preferéncias de idioma para sites na Web

Ao enviar uma solicitacdo ao servidor Web , o browser sempre envia as informacgoes sobre o
idioma preferencial do usuério. Sites disponiveis em mais de um idioma (e que sdo configurados
para avaliar esse parametro de idioma) exibem suas paginas no idioma solicitado pelo browser.

No SUSE Linux Enterprise Server, o idioma preferencial é pré-configurado para usar o mesmo
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idioma da area de trabalho. Para mudar essa configuracdo, abra a janela Preferéncias, conforme
descrito na Secdo 14.7.1, “Preferéncios”, va para a categoria Contetido e clique em Selecionar para
escolher o idioma preferencial.

14.7.1.3 Correcdo ortografica

Por padrao, o Firefox verifica a ortografia enquanto que vocé digita em caixas de texto de véarias
linhas. As palavras com erros ortograficos sdo sublinhadas em vermelho. Para corrigir uma
palavra, clique o botdo direito do mouse nela e escolha a grafia correta no menu de contexto.

Também é possivel adicionar a palavra ao dicionério, se estiver correta.

Para mudar ou adicionar um dicionério, clique o botdo direito do mouse em qualquer lugar na
caixa de texto com vérias linhas e selecione a opcdo apropriada no menu de contexto. E possivel
também desabilitar a correcdo ortogréfica nesta caixa de texto. Para desabilitar globalmente a
correcdo ortografica, abra a janela Preferéncias, conforme descrito na Secdo 74.7.1, “Preferéncias”,

e va para a categoria Avancado. Desative Verificar ortografia ao digitar.

14.7.2 Complementos

As extensOes permitem personalizar o Firefox para ajustd-lo as suas necessidades. Com as
extensoes, é possivel mudar a aparéncia do Firefox, aprimorar as funcionalidades existentes e
adicionar funcées. Por exemplo, as extensdes podem aperfeicoar o gerenciador de downloads,
mostrar o clima ou controlar os players de misica da Web. Outras extensbes auxiliam os
desenvolvedores da Web ou reforcam a seguranca bloqueando tipos de contetido como antncios

ou scripts.

H& milhares de extensoes disponiveis para o Firefox. Com o gerenciador de complementos, é

possivel instalar, habilitar, desabilitar, atualizar e remover extensoes.

Se vocé nao gostar da aparéncia do Firefox, instale um novo tema. Os temas ndo mudam a

funcionalidade do browser, somente a aparéncia.

14.7.2.1 Instalando complementos

Para adicionar uma extensiao ou um tema, inicie o gerenciador de complementos em
Ferramentas > Complementos na barra de menus. Uma janela é aberta com a guia Adicionar
exibindo op¢oes de complementos recomendados ou os resultados da sua dltima pesquisa.
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Use o campo Pesquisar complementos para procurar por complementos especificos. Clique em
uma entrada na lista para ver uma breve descricdo. Instale o complemento clicando em Instalar

ou abra uma pagina da Web com as informacoes detalhadas clicando no link Mais.
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preferred size using only capabilities. It includes such skinned and animated.

HThI R imatiuree as donficating tah

FIGURA 14.6: INSTALANDO EXTENSOES DO FIREFOX

Para ativar as extensodes ou os temas recém-instalados, as vezes, o Firefox precisa ser reiniciado
clicando em Reiniciar agora no gerenciador de complementos. Reinicie dessa forma para garantir

que a sessdo de navegacao seja restaurada.

14.7.2.2 Gerenciando complementos

O Gerenciador de Complementos também oferece uma interface conveniente para gerenciar
extensodes, temas e plug-ins. As extensoes podem ser habilitadas, desabilitadas ou desinstaladas.
Se a extensdo for configurdvel, suas opcoes de configuracdo poderdo ser acessadas por meio
do botao Preferéncias. Na guia Aparéncia, é possivel Desinstalar um tema ou ativar um tema
diferente clicando em Ativar. Também aparecem na lista instalacoes pendentes de extensao e
tema. Selecione Cancelar para interromper a instalacdo. Apesar de nao ser possivel instalar Plug-
ins como um usudrio, vocé pode desabiliti-los ou habilita-los pelo Gerenciador de plug-ins.
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Alguns complementos exigem que vocé reinicie o browser ao desinstalad-los ou desabilita-
los. Nesses casos, depois de clicar em uma dessas a¢oes, um link Reiniciar agora aparece no

gerenciador de complementos.

14.8 Imprimindo no Firefox

Antes de imprimir realmente uma pagina da Web, vocé pode usar a funcao de visualizacdo de

impressao para controlar a aparéncia que a pagina impressa terd. Na barra de menus, escolha

Arquivo > Visualizar impressdo. Configure o tamanho do papel e a orientacdo por impressora em

Configuracdo de pdgina.

Para imprimir uma pagina da Web, na barra de menus, escolha Arquivo > Imprimir ou pressione
Ctrl —P . A caixa de didlogo Impressora é aberta. Para imprimir usando as op¢oes padrao, basta

clicar em Imprimir.

A caixa de didlogo Imprimir também oferece opcoes de configuracao abrangentes para ajustar a
impressao. Na guia Geral, escolha uma impressora, o intervalo de impressao, o namero de copias
e a ordem. Configuracdo de pdgina permite especificar o nimero de péginas por lado, o fator
de escala, a origem e o tipo de papel. Se for suportado pela impressora, serd possivel também
ativar a impressao em frente e verso. Na guia Op¢oes, controle como sera a impressao de frames,

planos de fundo, cabecalhos e rodapés.

14.9 Para obter mais informacoes
Para obter mais informacdes sobre o Firefox, acesse os seguintes links:

Foruns do Mogzilla: https://www.mozilla.org/about/forums/ 2

Referéncia do Menu Principal: http://support.mozilla.org/kb/Menu+reference 7
Referéncia de preferéncias: http://support.mozilla.org/kb/Options+window 2
Atalhos do teclado: http://support.mozilla.org/kb/Keyboard+shortcuts #
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15 Evolution: E-Mailing and Calendaring

Evolution makes storing, organizing, and retrieving your personal information easy, so you can
work and communicate more effectively with others. It is a professional groupware program

and an important part of the Internet-connected desktop.

Evolution can help you work in a group by handling e-mail, contact information, and one or
more calendars. It can do that on one or several computers, connected directly or over a network,

for one person or for large groups.

Evolution helps you accomplish common daily tasks quickly. For example, you can easily reuse
appointment or contact information sent to you by e-mail, or send e-mails to a contact or
appointment. If you receive lots of e-mail, you can use advanced features like search folders,

which let you save searches as though they were ordinary e-mail folders.

This chapter introduces you to Evolution and helps you get started. For more details, refer to
the Evolution application help.

15.1 Starting Evolution

To start Evolution, click Applications > Internet > Evolution.

15.2 Setup Assistant

The first time you start Evolution, it opens an assistant to help you set up e-mail accounts and

import data from other applications.

The Evolution Account Assistant helps you provide all the required information.

15.2.1 Restoring from a Backup File

When the assistant starts, the Welcome page is displayed. Proceed to the Restore from Backup
page. If you previously backed up your Evolution configuration and want to restore it, activate

the restoration option and select the backup file in the file chooser dialog.

Otherwise, proceed to Identity.
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15.2.2 Defining Your Identity

The Identity page is the next step in the assistant.

1. Type your full name in the Full Name field.
2. Type your e-mail address in the E-mail Address field.

3. (Opcional) (Optional) Type an address in the Reply-To field.
Only use this field if you want replies to e-mails from you to be sent to a different e-mail

address.

4. (Opcional) (Optional) Type your organization name in the Organization field.
This is the company where you work, or the organization you represent when you send

e-mails.

5. Proceed to the next page.

15.2.3 Receiving Mail

The Receiving E-mail page lets you determine the server that you want to use to receive e-mail.

You need to specify the type of server you want to receive mail from. If you are not sure about

the type of server, contact your system administrator or e-mail provider.

Select a server type in the Server Type list. The following is a list of available server types:

Exchange Web Services: Allows you to connect to newer Microsoft Exchange servers to
synchronize e-mail, calendar, and contact information. This is only available if you have installed

the connector for Microsoft* Exchange* which is packaged in evolution-ews .
IMAP+: Keeps the e-mail on your server, so you can access your e-mail from multiple systems.

POP: Downloads your e-mail to your hard disk for permanent storage, freeing up space on the

e-mail server.
USENET News: Connects to a news server and downloads a list of available news digests.

Local Delivery: If you want to move e-mail from the spool and store it in your home directory,
you need to provide the path to the mail spool you want to use. If you want to leave mail in

your system’s spool files, select Standard Unix Mbox Spool File instead.

MH Format Mail Directories: To download your e-mail using mh or an mh-style program, you

need to provide the path to the mail directory you want to use.
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Maildir Format Mail Directories: If you download your e-mail using Qmail or another Maildir-
style program, select this option. You need to provide the path to the mail directory you want

to use.

Standard Unix Mbox Spool File or Directory: To read and store e-mail in the mail spool on your
local system, select this option. You need to provide the path to the mail spool you want to use.

None: If you do not plan to check e-mail with this account, select this option. There are no

configuration options.

15.2.3.1  Configuration Options for IMAP+, POP, and USENET
If you selected IMAP +, POP, or USENET News as the server type, you need to specify additional
information.

If you are not sure about the correct server address, user name or security setting, contact your

system administrator or e-mail provider.
1. Type the host name of your e-mail server into the text box Server.
2. Type your user name for the account into the text box Username.

3. Choose a security setting supported by your mail server. For security reasons, avoid using

No Encryption.

4. Select your authentication type in the Authentication list. To have Evolution check for
supported authentication types, click Check for Supported Types. Then choose one of the
options without a strikeout.

Some servers do not announce the authentication mechanisms they support. Therefore
clicking this button is not a guarantee that the shown mechanisms actually work.

5. Proceed to the next page.

15.2.3.2 Configuration Options for Exchange Web Services

If you selected Exchange Web Services as the server type, you need to specify additional

information.

If you are not sure about the correct server address, user name or security setting, contact your

system administrator or e-mail provider.

1. Type your user name for the account into the text box Username.
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2. Type the EWS URL of your e-mail server into the text box Host URL.
If available, type the address of an Offline Address Book into the text box OAB URL.
If your login name and the name of your mailbox differ, select Open Mailbox of other user.

Then type the mailbox name into the text box below.

3. Select an authentication type in the Authentication list. To have Evolution check for
supported authentication types, click Check for Supported Types. Then choose one of the
options without a strikeout.

Some servers do not announce the authentication mechanisms they support. Therefore

clicking this button is not a guarantee that the shown mechanisms actually work.

4. Proceed to the next page.

15.2.3.3 Local Configuration Options

If you selected Local Delivery, MH-Format Mail Directories, Maildir-Format Mail Directories, or
Standard Unix Mbox Spool File or Directory, specify the path to the local files or directories in
the path field.

15.2.4 Receiving Options

After you have selected a mail delivery mechanism, you can set some preferences for its

behavior.

15.2.4.1 IMAP+ Receiving Options

If you selected IMAP + as the receiving server type, you will now see a page of options to specify

the behavior of Evolution.
1. You can choose from the following options:

Check for new messages every ... minutes
Select if you want Evolution to automatically check for new mail. Set how often to
check.

Check for new message in all folders

Select if you want to check for new messages in all folders.
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Check for new message in subscribed folders

Select if you want to check for new messages in subscribed folders.

Use Quick Resync if the server supports it

Select to use Quick Resync which makes browsing mail faster on supported servers.

Listen for server change notifications
Select if you want Evolution to listen for change notifications. If you activate this
option, Evolution will show you mail as it arrives. Therefore, you can usually

deactivate Check for new messages every ... minutes.

Show only subscribed folders
Select if you want Evolution to show only subscribed folders.
You can unsubscribe from folders to cut down on the number of irrelevant folders

shown in Evolution and to reduce the amount of mail that is downloaded.

Apply filters to new messages in all folders
Select if you want to apply filters to new messages, and whether to do so in all folders

or only in the Inbox folder.

Check new messages for Junk contents
Select if you want to check new messages for junk content, and whether to do so in

all folders or only in the Inbox folder.

Automatically synchronize remote mail locally

Select this to download all your mail, so you can read it offline.

2. Proceed to the next page.

15.2.4.2 POP Receiving Options

If you selected POP as the receiving server type, you will now see a page of options to specify

the behavior of Evolution.
1. You can choose from the following options:

Check for new messages every ... minutes
Select if you want Evolution to automatically check for new mail. Set how often to
check.
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Leave messages on server
Select if you want leave your mail on the server or delete it on the server when
you download it to your computer. You can also set a period of time for which the

messages will be kept on the server after they were downloaded.

Disable support for all POP3 extensions
Disabling POP3 extensions can help with old or misconfigured servers. Select if you

have trouble receiving mail.

2. Proceed to the next page.

15.2.4.3 USENET News Receiving Options

If you selected USENET News as the receiving server type, you will now see a page of options

to specify the behavior of Evolution.
1. You can choose from the following options:

Check for new messages every ... minutes
Select if you want Evolution to automatically check for new mail. Set how often to

check.

Apply filters to new messages in all folders

Select if you want to apply filters to new messages.

Show folders in short notations
Abbreviate folder names, for example, comp.os.linux appears as c.o.linux.

In the subscription dialog, show relative folder names
Display only the name of the folder. For example, the folder evolution.mail would

appear as evolution.

2. Proceed to the next page.

15.2.4.4 Exchange Web Services Receiving Options

If you selected Exchange Web Services as the receiving server type, you will now see a page of

options to specify the behavior of Evolution.
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1. You can choose from the following options:

Check for new messages every ... minutes
Select if you want Evolution to automatically check for new mail. Set how often to
check.

Check for new message in all folders

Select if you want to check for new messages in all folders.

Listen for server change notifications
Select if you want Evolution to listen for change notifications. If you activate this
option, Evolution will show you mail as it arrives. Therefore, you can usually

deactivate Check for new messages every ... minutes.

Apply filters to new messages in all folders

Select if you want to apply filters to new messages.

Check new messages for Junk contents
Select if you want to check new messages for junk content, and whether to do so in

all folders or only in the Inbox folder.

Automatically synchronize remote mail locally

Select this to download all your mail, so you can read it offline.

Connection timeout (in seconds)

Set maximum time to wait for an answer from the server.

Cache offline address book
If you provided an OAB URL in the prior step, you can select caching an address
book. This will make the address book available when offline.

2. Proceed to the next page.

15.2.4.5 Local Delivery Receiving Options

If you selected that you want to receive mail through Local Delivery, you will now see a page

of options to specify the behavior of Evolution.

142

1. Select Check for new messages every ... minutes if you want Evolution to automatically check

for new mail. Set how often to check.

Receiving Options | SLES 12 SP5



2. Proceed to the next page.

15.2.4.6 MH-Format Mail Directories Receiving Options

If you selected that you want to receive mail through MH-Format Mail Directories, you will now

see a page of options to specify the behavior of Evolution.

1. Select Check for new messages every ... minutes if you want Evolution to automatically check
for new mail. Set how often to check.

Select Use the .folders summary file to use the . folders summary file.

2. Proceed to the next page.

15.2.4.7 Maildir-Format Mail Directories Receiving Options

If you selected that you want to receive mail through Maildir-Format Mail Directories, you will

now see a page of options to specify the behavior of Evolution.

1. Select Check for new messages every ... minutes if you want Evolution to automatically check
for new mail. Set how often to check.

Select Apply filters to new messages in Inbox if you want to apply filters to new messages.

2. Proceed to the next page.

15.2.4.8 Standard Unix Mbox Spool or Directory Receiving Options

If you selected that you want to receive mail through a Unix mbox Spool File or Directories, you

will now see a page of options to specify the behavior of Evolution.

1. Select Check for new messages every ... minutes if you want Evolution to automatically check
for new mail. Set how often to check.

Select Apply filters to new messages in Inbox if you want to apply filters to new messages.

2. Select Store status headers in Elm/Pine/Mutt format to store status headers in a way

compatible with Elm, Pine, and Mutt.

3. Proceed to the next page.

143 Receiving Options | SLES 12 SP5



15.2.5 Sending Mail

Now that you have entered information about how you plan to receive mail, Evolution needs
to know about how you want to send it. Usually, a separate server configuration is necessary

for this. Otherwise, this page will be skipped.
Select a server type from the Server Type list.

The following server types are available:

Sendmail: Uses the Sendmail program to send mail from your system. Sendmail is more flexible,
but is not as easy to configure, so you should select this option only if you know how to set

up a Sendmail service.

SMTP: Sends mail using a separate mail server. This is the most common choice for sending

mail. If you choose SMTP, there are additional configuration options.
PROCEDIMENTO 15.1: SMTP CONFIGURATION

1. Type the host address in the Server field.
If you are not sure what your host address is, contact your system administrator or e-

mail provider.

2. Select if your server requires authentication.
If you selected that your server requires authentication, you need to provide the following

information:

a. Choose a security setting supported by your mail server. For security reasons, avoid

using No Encryption.

b. Select your authentication type in the Authentication list.
or
Click Check for Supported Types to have Evolution check for supported types. Then
choose one of the options without a strikeout.
Some servers do not announce the authentication mechanisms they support.
Therefore, clicking this button is not a guarantee that the shown mechanisms actually

work.

c. Type your user name in the Username field.

3. Proceed to the next page.
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15.2.6  Final Steps

Now that you have finished the e-mail configuration process, you need to give the account a

name. The name can be any name you prefer. Type your account name on the Name field.

Proceed to the next page and confirm your changes.

Depending on your configuration, you may now be asked for your e-mail passwords and whether

you want to save them or want to always enter them when starting Evolution.

The Evolution main window will then open for the first time.

15.3 Using Evolution

Now that the first-run configuration has finished, you are ready to begin using Evolution. This

section sums up the most important parts of the user interface.
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Menu Bar

The menu bar gives you access to nearly all of the features of Evolution.

Folder List
The folder list gives you a list of the available folders for each account. To see the contents

of a folder, click the folder name. The contents are displayed in the e-mail list.

Toolbar
The toolbar gives you fast and easy access to the frequently used features in each

component.

Search Bar
The search bar lets you search for e-mails. You can filter e-mails, contacts, and calendar
entries and tasks using different criteria: a label, a search term, and an account or folder.

The Search bar can also save frequently used searches to a search folder.

Message List
The message list displays a list of e-mails that you have received. To view an e-mail in the

preview pane, select the e-mail.

Shortcut Bar

The shortcut bar at the left lets you switch between folders and program components.

Statusbar
The statusbar periodically displays a message, or informs you about the progress of a task,
such as sending e-mail.
On the far left, you will find the Online/Offline indicator. Click the Online/Offline indicator

to switch between being using Evolution in online or offline mode.

Preview Pane

The preview pane displays the contents of the e-mails that are selected in the e-mail list.

15.3.1 The Menu Bar

The menu bar’s contents always provide all the possible actions for any view of your data.

File: Anything related to a file or to the operations of the application usually falls under this
menu, such as creating things, saving them to disk, printing them, and quitting the program
itself.
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Edit: Contains tools to edit text and most configuration options.
View: Allows configuring the appearance of Evolution.
Message: Contains actions that can be applied to a message.
Folder: Contains actions that can be performed on folders.

Search: Lets you search for messages, or phrases within a message. You can also see previous

searches you have made.

Help: Opens the Evolution application help.

15.3.2 The Shortcut Bar

The shortcut bar is the column on the left side of the main window. At the top, there is a list
of folders for the selected Evolution component. The buttons at the bottom are shortcuts to the

individual components, such as Mail and Contacts.

The folder list organizes your e-mail, calendars, contact lists, and task lists in a tree. Most
people find one to four folders at the base of the tree, depending on the component and their
system configuration. Each Evolution component has at least one, called On This Computer, for
local information. For example, the folder list for the e-mail component shows all your e-mail

accounts, local folders, and search folders.

If you receive large amounts of e-mail, you need additional ways to organize it. In Evolution,

you can create own e-mail folders, address books, calendars, task lists, or memo lists.

15.3.2.1 Creating a folder

To create a new folder:
1. Click File > New > Mail Folder.
2. Type the name of the folder in the Folder Name field.

3. Select the location of the new folder.

4. Click Create.
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15.3.2.2 Folder Management

Right-click a folder or subfolder to display a menu with the following options:
Mark All Messages As Read: Marks all the messages in the folder as read.
New Folder: Creates a new folder or subfolder in the same location.

Copy Folder To: Copies the folder to a different location. When you select this item, Evolution

offers a choice of locations to copy the folder to.
Move Folder To: Moves the folder to another location.
Delete: Deletes the folder and all contents.

Rename: Lets you change the name of the folder.
Refresh: Refreshes the folder.

Properties: Shows the number of total and unread messages in a folder.
You can also rearrange folders and messages by dragging and dropping them.

Any time new e-mail arrives in an e-mail folder, that folder label is displayed in bold text, along

with the number of new messages in that folder.

15.3.3 Using E-Mail

The e-mail component of Evolution has the following standout features:

e It supports multiple e-mail sources from many protocols.
¢ It lets you guard your privacy with encryption.
¢ It can speedily handle large amounts of e-mail.

¢ Search folders allow you to come back to often-used searches.
Below is a summary of the user interface elements of the e-mail window.

Message List
The message list displays all the e-mails that you have. This includes all your read and
unread messages and e-mail that is flagged to be deleted. With the Show drop-down box

above the message you can filter the message list view using predefined and custom labels.
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Preview Pane

This is where your e-mail is displayed.

If you find the preview pane too small, you can resize the pane, enlarge the whole window,
or double-click the message in the message list to have it open in a new window. To change
the size of a pane, drag the divider between the two panes.

As with folders, you can right-click messages in the message list and get a menu of possible
actions. This includes moving or deleting them, creating filters or search folders based on
them, and marking them as junk mail.

Actions related to e-mail, like Reply and Forward, appear as buttons in the toolbar and are

also located in the right-click menu.

Templates
Evolution allows you to create and edit message templates that you can use at any time

to send mail with the same pattern.

15.3.4 Calendaring

To begin using the calendar, click Calendars in the shortcut bar. By default, the calendar shows
today’s schedule on a ruled background. At the upper right, there is a Tasks list, where you
can keep a list of tasks separate from your calendar appointments. Below that, there is a list
for memos.

Appointment List

The appointment list displays all your scheduled appointments.

Month Pane
The month pane is a small view of a calendar month. You can also select a range of days

in the month pane to display a custom range of days in the appointment list.

Tasks
Tasks are distinct from appointments because they generally do not have times associated

with them. You can see a larger view of your task list by clicking Tasks in the shortcut bar.

Memos
Memos, like Tasks, do not have times associated with them. You can see a larger view of

your Memo list by clicking Memos in the shortcut bar.
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15.3.5 Managing Contacts

To use the contacts component, click Contacts in the shortcut bar. The Evolution contacts

component can handle all of the functions of an address book or phone book.

It does, however, also do more than a paper book. To share your address book on a network,
you can use LDAP directories. To create a new contact entry, right-click an e-mail address or
double-click an empty space in the right pane. You can also search contacts using the search bar.

By default, the display shows all your contacts in alphabetical order, in a card-based view. You

can select other views from the View menu.

15.4 For More Information

Get more information about Evolution from the application help available via F1 .

Find more information on the project home page https://wiki.gnome.org/Apps/Evolution 7.

150 Managing Contacts | SLES 12 SP5


https://wiki.gnome.org/Apps/Evolution

16 Empathy: Instant Messaging

Empathy is an instant messaging (IM) client that allows you to connect to multiple accounts
simultaneously. Chat live with your contacts in one tabbed interface, regardless of which IM
system they use. Empathy uses Telepathy for protocol support.

Empathy supports the following instant messaging protocols: Google Talk (Jabber/XMPP), MSN,
IRC, Salut, AIM, Facebook, Yahoo!, Gadu Gadu, Groupwise®, ICQ and QQ. (The supported
protocols depend on installed Telepathy Connection Manager components.)

In the following, learn how to set up Empathy and how to communicate with your contacts.

16.1 Starting Empathy

To start Empathy, select Applications > Internet > Empathy.

16.2 Configuring Accounts

To use Empathy, you must already have an account for the messaging service you want to use.

For example, to use Empathy to chat via AIM, you must first have an AIM account.

PROCEDIMENTO 16.1: ADDING AND EDITING ACCOUNTS IN EMPATHY

1. To start Empathy, select Applications > Internet > Empathy.
If you start Empathy for the first time, a message appears, prompting you to configure

an account.

2. Enter your account data. The Messaging and VoIP Accounts dialog shows the accounts that
have been configured so far.

3. To add another account:

a. In the Messaging and VoIP Accounts dialog, click the plus icon.

b. Choose the type of account you want to configure, enter your user ID and password
for the account and click Add. The dialog to add or modify accounts differs for each

type of account, depending on what setup options are available for that account.

4. To enter or modify connection data for an account:

a. Select the account and click Edit Connection Parameters > Advanced.
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b. Enter a server name and a port to use for the connection. Specify additional
parameters, such as encryption options, if necessary. If you are unsure which

parameters to use, refer to your system administrator or messaging service.

c. Click Apply to confirm your changes.

To go online with your account, turn the account switch on. When prompted for your password,

enter it.

To disable the account, turn the switch off. If you are finished with the configuration of your

accounts, close the Messaging and VoIP Accounts dialog.

16.3 Managing Contacts

Use the Contact List to manage your contacts. You can add and remove contacts and organize

them in groups, so they are easy to find.

PROCEDIMENTO 16.2: ADDING CONTACTS

1. To add a contact, click Contacts > Add Contacts.

2. Select the Account for which you want to add a contact.

3. As Identifier, enter the name or user ID of the person you want to add.

4. By default, Alias will show the same entry, but you can enter a different name or nickname
for the contact person here.
As soon as you start typing into the Identifier text box, the dialog will also show any groups
that you have already defined.

5. To add the new contact to a group, activate the respective group's check box.

6. To create a new group, type a group name into the text box next to Add Group and click
Add Group.

7. Click Add to confirm your changes and to close the dialog.

In case the groups or the newly added contacts are not displayed in the Contact List, check the
Empathy preferences by clicking Preferences > General. Activate Show offline contacts and Show
groups to make all contacts and groups appear in the Contact List.
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To remove a contact from the list, right-click the name of that contact, select Remove and confirm

your choice.

16.4 Chatting with Friends

To chat with other participants, you need to be connected to the Internet. After a successful login,
you are usually marked as Available in the Contact List, and thus visible to others. To change
your status, click the drop-down box at the top of the Contact List and select another option.
To open a chat session, double-click a contact name in the Contact List. The chat screen opens.
Type your message, then press Enter to send.

If you open more than one chat session, the new session appears as a tab in the existing chat
window. To see all messages of a session and to be able to write a reply, click the tab of that
session. To see multiple session side by side, use the mouse to drag a tab out of the window.

A second window will open.

To close a chat session, close the tab or window for it.

16.5 For More Information

This chapter explained the Empathy options you need to know about to set up Empathy and
communicate with your contacts. It does not explain all features and options available. For more

information, open Empathy, then click Help.

For updates about new features and for the latest information, refer to the home page of the

project at https://wiki.gnome.org/Apps/Empathy @.
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17 Ekiga: Using Voice over IP

Ekiga is an application you can use for making phone calls via Voice over IP (VoIP),

for video conferencing and for instant messaging.

@ Nota: Ekiga May Not Be Installed

Before proceeding, make sure that the package ekiga is installed.

Before starting, make sure that the following requirements are met:
® Your sound card is properly configured.
® A headset or a microphone and speakers are connected to your computer.

¢ For dialing in to regular phone networks, a SIP account is required. SIP (Signaling protocol
for Internet Telephony) is the protocol used to establish sessions for audio and video
conferencing or call forwarding.
There are many VoIP providers all over the world. One provider is the Ekiga project itself,

go to https://ekiga.im 2 to learn more.

® For video conferencing: A Web cam is connected to your computer.

17.1 Starting Ekiga

Start Ekiga by clicking Applications > Internet > Ekiga Softphone.

17.2 Configuring Ekiga

On first start, Ekiga opens a configuration assistant that requests all data needed to configure

Ekiga. Proceed as follows:

1. Click Forward.

2. Enter your full name (name and surname). Click Forward.

154 Starting Ekiga | SLES 12 SP5


https://ekiga.im

3. Enter your ekiga.net account data or choose not to register with http://www.ekiga.net 2.
Click Forward.

4. Enter your Ekiga Call Out Account data or choose not to register with http://

www.ekiga.net 2. Click Forward.
5. Set your connection type and speed. Click Forward.

6. Configure the audio devices to use by choosing the audio ringing, output and input device

driver. In general, you can keep the Default setting. Click Forward.
7. Choose a video input device, if available. Click Forward.

8. Check the summary of your settings and apply them.

9. If registration fails after making changes to your configuration, restart Ekiga.

Ekiga allows you to maintain multiple accounts. To configure an additional account, proceed

as follows:

1. Open Edit > Accounts.
2. Choose Accounts > Add <account type>. If you are unsure, select Add a SIP Account.

3. Enter the Registrar to which you have registered. This is usually an IP address or a host
name that will be given to you by your Internet Telephony Service Provider. Enter User,

and Password according to the data provided by your provider.

4. Make sure Enable account is activated and leave the configuration dialog with OK. The

account is displayed in the Ekiga main window, including its Status, which should change

to Registered.

17.3 The Ekiga User Interface

The user interface has different modes. To switch between views, use the toolbar. The first mode
is Contacts, the second is Dialpad and the last one is Call History. Click the camera icon to open
the Call Window. It displays images from your local Web cam (or from a remote Web cam during

a call).
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FIGURA 17.1: EKIGA USER INTERFACE

By default, Ekiga opens in the Contacts mode. This view shows you a local address book which
lets you quickly open connections to often-used numbers.
Many of the functions of Ekiga are available with key combinations. 7abela 17.1, “Key Combinations

for Ekiga” summarizes the most important ones.

TABELA 17.1: KEY COMBINATIONS FOR EKIGA

Key Combination Description
ctri —0 Initiate a call with the current number.
Esc Hang up.
Ctrl —N Add a contact to your address book.
Ctrl —B Open the Address Book dialog.
H Hold the current call.
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Key Combination Description

T Transfer the current call to another party.

M Suspend the audio stream of the current call.

J Suspend the video stream of the current call.

Ctrl —w Close the Ekiga user interface.

ctri —Q Quit Ekiga.

Ctrl —E Start the account manager.

ctrli -3 Activate Call Panel on the main user
interface.

ctrl —+ Zoom in to the picture from the Web cam.

ctrl — - Zoom out on the picture from the Web cam.

ctri — 0 Return to the normal size of the Web cam
display.

F11 Use full screen for the Web cam.

17.4 Making a Call

After Ekiga is properly configured, making a call is easy.

1. Switch to the Dialpad mode.

2. Enter the SIP address of the party to call at the bottom of the window. The address should
look like:

e for direct local calls: sip:username@domainname or username@hostname
® sip:username@domainname or userid@sipserver

3. Click Call or press ctrl —0 and wait for the other party to pick up the phone.
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4. To end the call, click Hang up or press Esc .

If you need to tweak the sound parameters, click Edit > Preferences.

17.5 Answering a Call

Ekiga can receive calls in two different ways. First, it can be called directly with sip:user@host,
or via SIP provider. Most SIP providers enable you to receive calls from a normal land-line to
your VoIP account. Depending on the mode in which you use Ekiga, there are several ways in

which you are alerted to an incoming call:

Normal Application
Incoming calls can only be received and answered if Ekiga is already started. You can hear
the ring sound on your headset or your speakers. If Ekiga is not started, the call cannot

be received.

Panel Applet
Normally, the Ekiga panel applet runs silently without giving any notice of its existence.
This changes when a call comes in. The main window of Ekiga opens and you hear a

ringing sound on your headset or speakers.

Once you have noticed an incoming call, click Accept to answer the call then start talking. If
you do not want to accept this call, click Reject. It is also possible to transfer the call to another
SIP address.

17.6 Using the Address Book

Ekiga can manage your SIP contacts. All of the contacts are displayed in the Contacts tab, shown
in the main window after start-up. To add a contact or a new contact group, select Chat > Add

Contact.

If you want to add a new group, enter the group name into the bottom text box and click Add.
The new group is then added to the group list and preselected.

The following entries are required for a valid contact:

Name
Enter the name of your contact. This may be a full name, but you can also use a nickname

here.
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Address

Enter a valid SIP address for your contact.

Groups

If you have many contacts, add your own groups.

To call a contact from the address book, double-click the contact. The call is initiated
immediately.

17.7 For More Information

The official home page of Ekiga is http://www.ekiga.org/ 7. This site offers answers to frequently

asked questions and more detailed documentation.

For information about the support of the H323 teleconferencing protocol in Linux, see http://
www.voip-info.org/wiki/view/H.323 2, This is also a good starting point when searching for

projects supporting VoIP.

To set up a private telephone network, you might be interested in the PBX software Asterisk

http://www.asterisk.org/ 7. Find information about it at http://www.voip-info.org/wiki-Asterisk 21,
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18 GIMP: Manipulating Graphics

GIMP (the GNU Image Manipulation Program) is a program for creating and

editing raster graphics. In most aspects, its features are comparable to those of
Adobe* Photoshop* and other commercial programs. Use it to resize and retouch
photographs, design graphics for Web pages, create covers for your custom CDs,

or almost any other graphics project. It meets the needs of both amateurs and
professionals.

GIMP is an extremely complex program. Only a small range of features, tools, and menu items

are discussed in this chapter. See Secdo 78.8, “For More Information” for ideas of where to find

more information about the program.

18.1 Graphics Formats

There are two main types of digital graphics: raster and vector. GIMP is intended for working

with raster graphics, which are most often used for digital photographs or scanned images.

Raster Images. A raster image is a collection of pixels: Small blocks of color that create an entire
image when put together. High resolution images contain a large number of pixels. Because of
this, such image files can easily become quite large. It is not possible to increase the size of a

raster image without losing quality.

GIMP supports most common formats of raster graphics, like JPEG, PNG, GIF, BMP, TIFF, PSD,

and more.

Vector Images. Unlike raster images, vector images do not store information about individual
pixels. Instead, they use geometric primitives such as points, lines, curves, and polygons. Vector
images can be scaled very easily. Depending on their content, vector image files can both be

very small or very large. However, their file size is usually independent of their display size.

The disadvantage of vector images is that they are not good at representing complex images with
many colors such as photographs. There are many specialized applications for vector graphics,
for example Inkscape. GIMP has very limited support for vector graphics. For example, GIMP
can open and rasterize vector graphics in SVG format or work with vector paths.
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GIMP supports only the most common color spaces:

* RGB images with 8 bits per channel. This equals 24 bits per pixel in RGB images without
an alpha channel (transparency). With an alpha channel, that equals 32 bits per pixel.

® Grayscale images with 8 bits per pixel.

® Indexed images with up to 255 colors.

Many high-end digital cameras produce image files with color depths above 8 bits per channel.
If you import such an image into GIMP, you will lose some color information. GIMP also does
not support a CMYK color mode for professional printing.

18.2 Starting GIMP

To start GIMP, select Applications > Graphics > GIMP.

18.3 User Interface Overview

By default, GIMP shows three windows. The toolbox, an empty image window with the menu
bar, and a window containing several docked dialogs. The windows can be arranged on the
screen as you need them. If they are no longer needed, they can also be closed. Closing the

image window when it is empty quits the application.

In the default configuration, GIMP saves your window layout when you quit. Dialogs left open

reappear when you next start the program.

If you want to combine all windows of GIMP, activate Windows > Single-Window Mode.

18.3.1 The Image Window

If there is currently no image open, the image window is empty, containing only the menu bar
and the drop area, which can be used to open any file by dragging and dropping it there. Every
new, opened, or scanned image appears in its own window. If there is more than one open

image, each image has its own image window. There is always at least one image window open.

In Single-Window Mode, all image windows are accessible from a tab bar at the top of the

window.
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The menu bar at the top of the window provides access to all image functions. You can also
access the menu by right-clicking the image or clicking the small arrow button in the top left

corner of the rulers.

The File menu offers the standard file operations, such as New, Open, Save, Print and Close. Quit

quits the application.

With the items in the View menu, control the display of the image and the image window.
New View opens a second display window of the current image. Changes made in one view
are reflected in all other views of that image. Alternate views are useful for magnifying a part
of an image for manipulation while seeing the complete image in another view. Adjust the
magnification level of the current window with Zoom. When Fit Image in Window is selected, the

image window is resized to fit the current image display exactly.

18.3.2 The Toolbox

The toolbox contains drawing tools, a color selector, and a freely configurable space for options
pages. If you accidentally close the toolbox, you can reopen it by clicking Tools > New Toolbox.

To find out what a particular tool does, hover over its icon. At the very top, there is a drop area

which can be used to open any image file by simply dragging and dropping it there.
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FIGURA 18.1: THE TOOLBOX
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The current foreground and background color are shown in two overlapping boxes. The default
colors are black for the foreground and white for the background. Swap the foreground and
background color with the bent arrow icon to the upper right of the boxes. Use the black and
white icon to the lower left to reset the colors to the default. Click the box to open a color

selection dialog.

Under the toolbox, a dialog shows options for the currently selected tool. If it is not visible, open
it by double-clicking the icon of the tool in the toolbox.

18.3.3 Layers, Channels, Paths, Undo

Layers shows the different layers in the current image and can be used to manipulate the layers.

Information is available in Secdo 78.6.6, “Layers”.
Channels shows the color channels of the current image and can manipulate them.

Paths are a vector-based method of selecting parts of an image. They can also be used for
drawing. Paths shows the paths available for an image and provides access to path functions.
Undo shows a limited history of modifications made to the current image. Its use is described

in Secdo 18.6.5, “Undoing Mistakes”.

18.4 Getting Started

Although GIMP can be a bit overwhelming for new users, most quickly find it easy to use after

they work out a few basics. Crucial basic functions are creating, opening, and saving images.

18.4.1 Creating a New Image

1. To create a new image, select File > New. This opens a dialog in which you can make

settings for the new image.

2. If desired, select a predefined setting called a Template.

@ Nota: Custom Templates

To create a custom template, select Windows > Dockable Dialogs > Templates and use

the controls offered by the window that opens.
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3. In the Image Size section, set the size of the image to create in pixels or another unit. Click

the name of the unit to select another unit from the list of available units.

4. (Opcional) To set a different resolution, click Advanced Options, then change the value for
Resolution.
The default resolution of GIMP is usually 72 pixels per inch. This corresponds to a common
screen display and is sufficient for most Web page graphics. For print images, use a higher
resolution, such as 300 pixels per inch.
In Color space, select whether the image should be in color (RGB) or Grayscale. For detailed
information about image types, see Secdo 18.6.7, “Image Modes”.
In Fill With select the color the image is filled with. You can choose between Foreground
Color and Background Color set in the toolbox, White or Transparency for a transparent

image. Transparency is represented by a gray checkerboard pattern.

5. When the settings meet your needs, click OK.

18.4.2 Opening an Existing Image

To open an existing image, select File > Open.

In the dialog that opens, select the desired file and click Open.

18.5 Saving and Exporting Images
GIMP makes a distinction between saving and exporting images.

Saving an Image. The image is stored with all its properties in a lossless format. This includes,
for example, layer and path information. This means that repeatedly opening and saving the

image will neither degrade its quality nor how well it can be edited.

To save an image, use File > Save or File > Save as. To be able to store all properties, only the

native format of GIMP is allowed in this mode: the XCF format.

Exporting an image. The image is stored in a format in which some properties can be lost. For
example, most image formats do not support layers. When exporting, GIMP will often tell you

which properties will be lost and ask you to decide how to proceed.
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To export an image, use File > Overwrite or File > Export As. Below is a selection of the most

common file formats that GIMP can export to:

JPEG

GIF

PNG

18.

A common format for photographs and Web page graphics without transparency.
Its compression method enables reduction of file sizes, but information is lost when
compressing. It may be a good idea to use the preview option when adjusting the
compression level. Levels of 85% to 75% often result in an acceptable image quality with
reasonable compression. Repeatedly opening a JPEG and then saving can quickly result

in poor image quality.

Although very popular in the past for graphics with transparency, GIF is less often used
now. GIF is also used for animated images. The format can only save indexed images. See
Secdo 18.6.7, “Image Modes” for information about indexed images. The file size can often

be quite small if only a few colors are used.

With its support for transparency, lossless compression, and good browser support, PNG is
the preferred format for Web graphics with transparency. An added advantage is that PNG
offers partial transparency, which is not offered by GIF. This enables smoother transitions
from colored areas to transparent areas (antialiasing). It also supports the full RGB color

space which makes it usable for photos. However, it cannot be used for animations.

6 Editing Images

GIMP provides several tools for making changes to images. The functions described here are

those most interesting for smaller edits.

18.6.1 Changing the Size of an Image

After an image is scanned or a digital photograph is loaded from the camera, it is often necessary

to modify the size for display on a Web page or for printing. Images can easily be made smaller

either by scaling them down or by cutting off parts of them.
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Enlarging an image is much more problematic. Because of the nature of raster graphics, quality

is lost when an image is enlarged. It is recommended to keep a copy of your original image

before scaling or cropping.

18.6.1.1  Cropping an Image

1. Select the crop tool from the toolbox (the paper knife icon) or click Tools > Transform

Tools > Crop.

Click a starting corner and drag to outline the area to keep. A rectangle showing the crop

area will appear.

To adjust the size of the rectangle, move your mouse pointer above any of the rectangle's
sides or corners, then click and drag to resize as desired. If you want to adjust both width
and height of the rectangle, use a corner. To adjust only one dimension, use a side. To
move the whole rectangle to a different position without resizing, click anywhere near its

center and drag to the desired position.

When you are satisfied with the crop area, click anywhere inside to crop the image or

press Enter . To cancel the cropping, click anywhere outside the crop area.

18.6.1.2 Scaling an Image
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1. Select Image > Scale Image to change the overall size of an image.

2. Select the new size by entering it in Width or Height.

To change the proportions of the image when scaling (this distorts the image), click the
chain icon to the right of the fields to break the link between them. When those fields
are linked, all values are changed proportionately. Adjust the resolution with X resolution
and Y resolution.

The Interpolation option controls the quality of the resulting image. The default Cubic

interpolation method usually is a good standard to use.

3. When you are finished, click Scale.
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18.6.1.3 Changing the Canvas Size

The canvas is the entire visible area of an image. Canvas and image are independent from each
other. If the canvas is smaller than the image, you can only see part of the image. If the canvas

is larger, you see the original image with extra space around it.

1. Select Image > Canvas Size.

2. In the dialog that opens, enter the new size. To make sure the dimensions of the image

stay the same, click the chain icon.

3. After adjusting the size, determine how the existing image should be positioned in
comparison to the new size. Use the Offset values or drag the box inside the frame at the

bottom.

4. When you are finished, click Resize.

18.6.2 Selecting Parts of Images

It is often useful to perform an image operation on only part of an image. To do this, the part
of the image with which you want to work must be selected. Areas can be selected using the
selection tools available in the toolbox, using the quick mask, or combining different options.
Selections can also be modified with the items under Select. The selection is outlined with a

dashed line, called marching ants.

18.6.2.1 Using the Selection Tools

The main selection tools are easy to use. The more complicated paths tool is not described here.

To determine whether a new selection should replace, be added to, be subtracted from, or

intersect with an existing selection, use the Mode row in the tool options.

Rectangle Select
This tool can be used to select rectangular or square areas. To select an area with a fixed
aspect ratio, width, height or size, activate the Fixed option and choose the relevant mode

in the Tool Options dialog. To create a square, hold shift while selecting a region.

Ellipse Select
Use this to select elliptical or circular areas. The same options are available as with the

rectangular selection. To create a circle, hold shift while selecting a region.
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Free Select (Lasso)

With this tool, you can create a selection based on a combination of freehand drawing and
polygonal segments. To draw a freehand line, drag the mouse over the image with the left
mouse button pressed. To create a polygonal segment, release the mouse button where the
segment should start and press it again where the segment should end. To complete the

selection, hover the pointer above the starting point and click inside the circle.

Fuzzy Select (Magic Wand)

Sel

This tool selects a continuous region based on color similarities. Set the maximum
difference between colors in the tool options dialog in Threshold. By default, the selection
is based only on the active layer. To base the selection on all visible layers, check Sample

merged.

ect by Color
With this tool, select all the pixels in the image with the same or a similar color as the
clicked pixel. The maximum difference between colors can be set in the tool options dialog
in Threshold. The important difference between this tool and Fuzzy Select is that Fuzzy
Select works on continuous color areas while Select by Color selects all pixels with similar

colors in the whole image regardless of their position.

Scissors

Click a series of points in the image. As you click, the points are connected based on
color differences. Click the first point to close the area. Convert it to a regular selection
by clicking inside it.

Foreground Selection

To
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The Foreground Selection tool lets you semi-automatically select an object in a photograph

with minimal manual effort.
use the Foreground Selection tool, follow these steps:

1. Activate the Foreground Selection tool by clicking its icon in the Toolbox or choosing

Tools » Selection Tools > Foreground Select from the menu.

2. Roughly select the foreground object you want to extract. Select as little as possible from
the background but include the whole object. At this point, the tool works like the Fuzzy
Select tool.

When you release the mouse button, the deselected part of the image is covered with a
dark blue mask.
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3. Draw a continuous line through the foreground object going over colors which will be
kept for the extraction. Do not paint over background pixels.
When you release the mouse button, the entire background is covered with a dark blue

mask. If parts of the object are also masked, paint over them. The mask will adapt.

4. When you are satisfied with the mask, press Enter . The mask will be converted to a new

selection.

18.6.2.2 Using the Quick Mask

The quick mask is a way of selecting parts of an image using the paint tools. A good way to
use it is to first create a rough selection using the Scissors or Free Select tool. Then start using
the Quick Mask:

1. To activate the Quick Mask, in the lower left corner of the image window, click the icon
with the dashed box. The Quick Mask icon now changes to a red box.
The Quick Mask highlights the deselected parts of the image with a red overlay. Areas

appearing in their normal color are selected.

@ Nota: Changing the Color of the Mask

To use a different color for displaying the quick mask, right-click the quick mask
button then select Configure Color and Opacity from the menu. Click the colored box

in the dialog that opens to select a new color.

2. To modify the selection, use the paint tools.
Painting with white selects the painted pixels. Painting with black deselects pixels. Shades
of gray (colors are treated as shades of gray) create a partial selection. Partial selections

allow a smooth transition between selected and deselected areas.

3. When you are finished, return to the normal selection view by clicking the icon in the lower

left corner of the image window. The selection is then displayed with the marching ants.

18.6.3 Applying and Removing Color

Most image editing involves applying or removing color. By selecting a part of the image, you
can limit where color can be applied or removed. When you select a tool and move the mouse

pointer onto an image, the appearance of the mouse pointer changes to reflect the chosen tool.
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With many tools, an icon of the current tool is shown along with the arrow. For paint tools, an
outline of the current brush is shown, allowing you to see exactly where you will be painting
in the image and how large of an area will be painted.

18.6.3.1 Selecting Colors

The GIMP toolbox always shows two color swatches. The foreground color is used by the paint
tools. The background color is used much more rarely, but it can easily be switched to become

the foreground color.

1. To change the color displayed in a swatch, click the swatch. A dialog with five tabs opens.

2. These tabs provide different color selection methods. Only the first tab, shown in
Figura 18.2, “The Basic Color Selector Dialog”, is described here. The new color is shown in

Current. The previous color is shown in Old.

EN=VARCH:: o H T 0
. s G
SV T 75
T (9]
G 38
OB PN 38
Notacdo HTML: bf2626 &
= e
Antiga:
Ajuda Restaurar Cancelar OK

FIGURA 18.2: THE BASIC COLOR SELECTOR DIALOG

The easiest way to select a color is by using the colored areas in the boxes to the left. In
the narrow vertical bar, click a color similar to the desired color. The larger box to the left
then shows available nuances. Click the desired color. It is then shown in Current.
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The arrow button to the right of Current allows saving colors. Click the arrow to copy the
current color to the history. A color can then be selected by clicking it in the history.

A color can also be selected by directly entering its hexadecimal color code in HTML
Notation.

The color selector defaults to selecting a color by hue. To select by saturation, value, red,
green, or blue, select the corresponding radio button to the right. The sliders and number
fields can also be used to modify the currently selected color. Experiment a bit to find out

what works best for you.

3. When you are finished, click OK.

To select a color that already exists in your image, use the eye dropper tool. With the tool
options, set whether the foreground or background color should be selected.

18.6.3.2 Painting and Erasing

To paint and erase, use the tools from the toolbox. There are a number of options available to
fine-tune each tool. Pressure sensitivity options apply only when a pressure-sensitive graphics

tablet is used.

The pencil, brush, airbrush, and eraser work much like their real-life equivalents. The ink
tool works like a calligraphy pen. Paint by clicking and dragging. The bucket fill is a method
of coloring areas of an image. It fills based on color boundaries in the image. Adjusting the

threshold modifies its sensitivity to color changes.

18.6.3.3 Adding Text

To add text, use the text tool. Use the tool options to select the desired font and text properties.

Click into the image, then start writing.

The text tool creates text in a special layer. To work with the image after adding text, read
Secdo 18.6.6, “Layers”. When the text layer is active, it is possible to modify the text by clicking
in the image to reopen the entry dialog.
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18.6.3.4 Retouching Images—The Clone Tool

The clone tool is ideal for retouching images. It enables you to paint in an image using
information from another part of the image. If desired, it can instead take information from a

pattern.

When retouching, use a small brush with soft edges. In this way, the modifications can blend

better with the original image.

To select the source point in the image, press and hold ctrt while clicking the desired source
point. Then paint with the tool. When you move the cursor while painting, the source point,

marked by a cross, moves as well.

If the Alignment is set to None (the default setting), the source resets to the original when you

release the left mouse button.

18.6.4 Adjusting Color Levels

Images often need a little adjusting to get ideal print or display results.
1. Select Colors > Levels. A dialog opens for controlling the levels in the image.

2. Good results can usually be obtained by clicking Auto. To make manual adjustments to
all channels, use the dropper tools in All Channels to pick areas in the image that should
be black, neutral gray, and white.

To modify an individual channel, select the desired channel in Channel. Then drag the
black, white, and middle markers in the slider in Input Levels. You can also use the dropper
tools to select points in the image that should serve as the white, black, and gray points
for that channel.

If Preview is checked, the image window shows a preview of the image with the

modifications applied.

3. When you are finished, click OK.

18.6.5 Undoing Mistakes

Most modifications made in GIMP can be undone. To view a history of modifications, use the
undo dialog included in the default window layout or open one from the image window menu
with Windows > Dockable Dialogs > Undo History.
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The dialog shows a base image and a series of editing changes that can be undone. Use the

buttons to undo and redo changes. In this way, you can often work back to the base image.

You can also undo and redo changes using Undo and Redo from the Edit menu. Alternatively,

use the shortcuts Ctrt —z and Ctrli-Y .

18.6.6 Layers

Layers are a very important aspect of GIMP. By drawing parts of your image on separate layers,

you can change, move, or delete those parts without damaging the rest of the image.

To understand how layers work, imagine an image created from a stack of transparent sheets.
Different parts of the image are drawn on different sheets. The stack can be arranged and sorted.
Individual layers or groups of layers can shift position, moving sections of the image to other

locations. New sheets can be added and others can be removed or made invisible.

Use the Layers dialog to view the available layers of an image. The text tool automatically creates
special text layers when used. The active layer is selected. The buttons at the bottom of the
dialog offer several functions. More are available in the menu opened when a layer is right-
clicked in the dialog. The two icon spaces before the image name are used for toggling image
visibility (eye icon when visible) and for linking layers. Linked layers are marked with the chain

icon and moved as a group.

18.6.7 Image Modes

GIMP has three image modes:

® RGB is a normal color mode and is the best mode for editing most images.
® Grayscale is used for black-and-white images.

¢ Indexed mode limits the colors in the image to a set number. The maximum number of

colors in this mode is 255. It is mainly used for GIF images.

If you need an indexed image, it is normally best to edit the image in RGB, then convert to
indexed right before exporting. If you export to a format that requires an indexed image, GIMP
offers to index the image when exporting.
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18.6.8 Special Effects

GIMP includes a wide range of filters and scripts for enhancing images, adding special effects to
them or making artistic manipulations. They are available in Filters. Experimenting is the best

way to find out what is available.

18.7 Printing Images

To print an image, select File > Print from the image menu. If your printer is configured in the
system, it should appear in the list. You can configure printing options on Page Setup and Image

Settings tabs.

{ 1
Geral | Configurar pagina | Configuracdes da imagem

Tamanho Pré-visualizag3o
Largura: | 89,96| -
Altura: 89,96 : mm ¥
Resolugdo X: | 71,999 : é
Resolugdo Y: | 71,999 o1 |pixelsin v
o
Posicio
Esquerdo: |53.67 _ Direito: 53,67 . :/
Superior: 93,23 : Inferior: | 93,23 : )
Centro: Ambos w7
Ignorar margens da pagina
Desenhar marcas de corte
Visualizar impressdo Cancelar Imprimir

FIGURA 18.3: THE PRINT DIALOG

When you are satisfied with the settings, click Print. Cancel aborts printing.

18.8 For More Information

The following resources are very useful for users of GIMP. They contain much more information
about GIMP than this chapter. If you want to use GIMP for more advanced tasks, you should

not miss these resources.
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http://www.gimp.org 7 is the official home page of The GIMP. News about GIMP and related
software are regularly posted on the front page.

Help provides access to the internal help system including the extensive GIMP User Manual.
The package gimp-help needs to be installed. This documentation is also available online
in HTML and PDF formats at http://docs.gimp.org #. Translations into many languages are

available.

A collection of many interesting GIMP tutorials is maintained at http://www.gimp.org/
tutorials/ #. It contains basic tutorials for beginners and tutorials for advanced or expert

users.

Printed books about GIMP are published regularly. You will find a selection of the best

ones with short annotations at http://www.gimp.org/books/ 2.

GIMP functionality can be extended with scripts and plug-ins. Many such scripts and plug-

ins are distributed in the GIMP package, but others can be downloaded from the Internet.

You can also use mailing lists or IRC channels to ask questions about GIMP. Always try to find

answers in the documentation mentioned above or in mailing list archives before asking your

question. The time of experienced users present on GIMP lists and channels is limited. Be polite

and patient. It may take some time before your question is answered.

176

¢ There are several mailing lists about GIMP. You will find them at http://www.gimp.org/

mail_lists.html 2. The GIMP User list is the most appropriate place to ask user questions.

¢ There is a whole IRC network dedicated to GIMP and GNOME desktop environment—

GIMPNet. You can connect to GIMPNet with your favorite IRC client by pointing it at the
irc.gimp.org server. The #gimp-users channel is the right place to ask question about
using GIMP. If you want to listen to developer's discussions, join the #gimp channel.
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19 GNOME Videos

GNOME Videos is the default movie player. GNOME Videos provides the following multimedia

features:

¢ Support for a variety of video and audio files

® A variety of zoom levels and aspect ratios, and a full screen view

Seek and volume controls

Playlists

Complete keyboard navigation

To start GNOME Videos, click Applications > Sound & Video > Videos.

19.1 Using GNOME Videos

When you start GNOME Videos, the following window is displayed.

Videos Canais

FIGURA 19.1: GNOME VIDEOS START-UP WINDOW
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19.1.1 Opening a Video or Audio File

1. Click Videos > Open.

2. Select the files you want to open, then click Add

You can also drag a file from another application (such as a file manager) to the GNOME Videos
window. GNOME Videos opens the file and plays the movie or song. GNOME Videos displays
the title of the movie or song beneath the display area and in the titlebar of the window.

@ Nota: Unrecognized File Format

If you try to open a file format that GNOME Videos does not recognize, the application

displays an error message and recommends a suitable codec.

You can double-click a video or audio file in GNOME Files to open it in the GNOME Videos

window by default.

19.1.2 Opening a Video or Audio File By URI Location

1. Click Videos > Open Location.

2. Specify the URI location of the file you want to open, then click Open.

19.1.3 Playing a DVD, VCD, or CD

To play a DVD, VCD, or CD, insert the disc in the optical device of your computer, then click
Movie > Play Disc.

To eject a DVD, VCD, or CD, click Movie > Eject.

To pause a movie or song that is playing, click the " button, or click Movie > Play/Pause. When
you pause a movie or song, the statusbar displays Paused and the time elapsed on the current

movie or song.
To resume playing a movie or song, click the ® button, or click Movie > Play/Pause.

To play or pause a movie, you can also press P .

178 Opening a Video or Audio File | SLES 12 SP5



To view properties of a movie or song, click View > Sidebar to make the sidebar appear. The
dialog contains the title, artist, year, and duration of movie or song, video dimensions, codec,
frame rate, and the audio bit rate.

19.1.4 Seeking Through Movies or Songs

To seek through movies or songs, use any of the following methods:

To skip forward

Click Go > Skip Forward. Alternatively, use « .

To skip backward
Click Go > Skip Backward. Alternatively, use - .

To move to next movie or song

Click Go > Next Chapter/Movie, or click the » button.

To move to previous movie or song

Click Go > Previous Chapter/Movie, or click the ¢ button.

19.1.5 Changing the Zoom Factor

To change the zoom factor of the display area, use any of the following methods:

To zoom to full screen mode
Click View > Fullscreen. Alternatively, press F .

To exit fullscreen mode, click Leave Fullscreen or press Esc .

To zoom to half size (50%) of the original movie or visualization
Click View > Fit Window to Movie » Resize 1:2.

To zoom to size (100%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 1:1.

To zoom to double size (200%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 2:1.

To switch between different aspect ratios, click View > Aspect Ratio.

The default aspect ratio is Auto.
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19.1.6  Showing or Hiding Controls

To hide the window controls of GNOME Videos, click View > Show Controls and deselect the
option. To show the controls on the GNOME Videos window, right-click the window, then select
Show Controls. If the Show Controls option is selected, GNOME Videos shows the menubar, time
elapsed slider, seek control buttons, volume slider, and statusbar on the window. If the Show
Controls option is not selected, the application hides these controls and shows only the display

area.

19.1.7 Managing Playlists

To show the playlist, click View > Sidebar. The Playlist sidebar is displayed.

You can use the Playlist dialog to do the following:

® Toadd atrack or movie: Click the Add button. Select the file you want to add to the playlist,
then click OK.

® To remove a track or movie: Select the file names from the file name list box, then click

Remove.
® To save a playlist to file: Click the Save Playlist button, then specify a file name.

® To move a track or movie up the playlist: Select the file name from the file name list box,
then click the Move Up button.

® To move a track or movie down the playlist: Select the file name from the file name list

box, then click the Move Down button.

To hide the playlist, click View > Sidebar, or click the Sidebar button.

To enable or disable repeat mode, click Edit > Repeat Mode. To enable or disable shuffle mode,
click Edit > Shuffle Mode.

19.1.8 Choosing Subtitles

To choose the language of the subtitles, click View > Subtitles > Select Text Subtitles, then select
the subtitles language (DVD) or subtitle file (AVI etc.) you want to display.

To disable the display of subtitles, click View > Subtitles > None.
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By default, GNOME Videos chooses the same language for the subtitles that you use on your

computer.

GNOME Videos automatically loads and displays subtitles if the file that contains them has the
same name as the video file. It supports the following subtitle file extensions: srt, asc, txt,

sub, smi, or ssa.

19.2 Modifying GNOME Videos Preferences

To modify GNOME Videos preferences, click Videos > Preferences.

19.2.1 General Preferences
The General Preferences let you select a network connection speed, specify if media files should

be played from the last used position, and change the font and encoding used to display subtitles.

Geral

Legendas externas

Carregar legendas quando o filme for carregado

Fonte: Sans Bold
Codificacdo:  Unicode (UTF-8)
Capitulos externos
+ Carregar arquivos dos capitulos quando o filme estiver carregado

Plug-ins

Plug-ins...

FIGURA 19.2: GNOME VIDEOS GENERAL PREFERENCES

General Preferences include the following:

Playback

Lets you specify whether to start playing the movie from the last position.

Networking

Select network connection speed from the Connection speed drop-down box.
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Text Subtitles

Lets you specify whether to load the subtitles automatically, and change the font and
encoding used to display the subtitles.

19.2.2 Display Preferences

The Display Preferences let you choose to automatically resize the window when a new video

is loaded, change the color balance, and configure visual effects when an audio file is played.

Monitor

Video

Desativar desentrelacamento de videos entrelacados

Balango de cor

Brilho:
Contraste:
Saturacao:
Tonalidade:

Resetar para o padrdo

FIGURA 19.3: GNOME VIDEOS DISPLAY PREFERENCES

Display Preferences include the following:

Automatically resize the window when a new video is loaded
Select this option if you want GNOME Videos to automatically resize the window when

a new video is loaded.

Disable the screen saver when playing video or audio
Select this option if you want GNOME Videos to automatically disable the desktop screen
saver while an audio file is playing.

Visual Effects
You can choose to show visual effects when an audio file is playing, select the type of

visualization you want to show, and the visualization size.

Color Balance

Specify the level of color brightness, contrast, saturation, and hue.
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19.2.3 Audio Preferences

The Audio Preferences dialog lets you select the audio output type.

Saida de audio

Tipo de saida de audio:  Estéreo

FIGURA 19.4: GNOME VIDEOS AUDIO PREFERENCES
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20 Brasero: Burning CDs and DVDs

Brasero is a GNOME program for writing data and audio CDs and DVDs. Start the

program from the main menu by clicking Applications > Sound & Video > Brasero.

The following sections are a quick introduction on how to create your own CD or
DVD.

20.1 Creating a Data CD or DVD

After starting Brasero for the first time, the main window appears as shown in Figura 20.7.

Projeto Editar Ferramentas Ajuda
Criar um novo projeto: Projetos recentes:

_ Nenhum projete usado recentemente
P B o
(. Projeto de audio

3 ] Criar um CD de audio comum

(", Projeto de dados

*._|=/ Criar um CD/DVD de dados

~ . Projeto de video
| g
N Criar um DVD ou um SVCD de video

(7 Cépia de disco

./ Criar uma cépia exata de um CD/DVD

= Gravar imagem
20 ) ‘ !
Grava uma imagem de CD/DVD existente

FIGURA 20.1: MAIN VIEW OF BRASERO
To create a data CD or DVD, proceed as follows:

1. Click Data project or select Project > New Project > New Data Project. The project view

appears.

2. Drag and drop the desired directories or individual files either from your file manager
or by clicking the plus icon. To show your directory structure directly in Brasero, select

View > Show Side Panel or press F7 .

3. Optionally, save the project under a name of your choice with Project > Save As.

4. Name your medium. The original label is Data disc (date).
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Choose the output medium from the pull down menu next to the Burn button (CD/DVD

or an ISO image file).

Click Burn. A new dialog appears, depending on what medium you have selected in the

previous step:

® CD/DVD. You can define some parameters, like the burning speed or where to
store temporary files. Under Options you can also choose whether to burn the image

directly, close the session, verify the written data, and others.
® ISO Image. Specify a file name for your ISO image file.

Start the process with Burn.

20.2 Creating an Audio CD

There are no significant differences between creating an audio CD and creating a data CD.

Proceed as follows:

1.

2.

Select Project > New Project > New Audio Project.

Drag and drop the individual audio tracks to the project directory. The audio data must
be in WAV or Ogg Vorbis format. Determine the sequence of the tracks by moving them

up or down in the project directory.
Click Burn. A dialog opens.

Specify a drive to write to.

. Click Properties to adjust burning speed and other preferences. When burning audio CDs,

choose a lower burning speed to reduce the risk of burn errors.

Click Burn.

20.3 Copying a CD or DVD

To copy a CD or DVD, proceed as follows:

1.

2.
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Click Disc Copy or go to Project > New Project > Copy Disc. The Copy CD/DVD dialog opens.

Specify the source drive you want to copy.
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3. Specify a drive or image file to write to.

4. If necessary, change the burning speed, the temporary directory and other options in

Properties.

5. Click Copy.

20.4 Writing ISO Images

If you already have an ISO image, click Burn image or go to Project > New Project > Burn Image.
Choose the image to write and a disc to write to. If necessary, change parameters by clicking
Properties. Choose the location of the image file with the pop-up menu labeled Path. Start the

burning process and click Burn.

20.5 Creating a Multisession CD or DVD

Multisession discs can be used to write data in more than one burning session. This is useful,
for example, for writing backups that are smaller than the media. In each session, you can add
another backup file. One note of interest is that you are not only limited to data CDs or DVDs.

You can also add audio sessions in a multisession disc.

To start a new multisession disc, do the following:

1. Start with a data disc first as described in Secdo 20.7, “Creating a Data CD or DVD". You cannot
start with an audio CD session. Make sure that you do not fill up the entire disc, because

otherwise you cannot append a new session.
2. Click Burn. The window Disc Burning Setup opens.

3. Select Leave the disc open to add other files later to make the disc multisession capable.

Configure other options if needed.

4. Start the burning session with Burn.

20.6 For More Information

You can find more information about Brasero at https://wiki.gnome.org/Apps/Brasero 4.
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A Ajuda e documentacao

O SUSE® Linux Enterprise Server vem com varias fontes de informacoes e

documentacao, muitas das quais ja integradas ao sistema instalado:

Centro de Ajuda da Area de Trabalho
O centro de ajuda da area de trabalho do GNOME (Ajuda) oferece acesso centralizado
aos recursos de documentacdo mais importantes no sistema de forma pesquisavel. Esses
recursos incluem ajuda online para os aplicativos instalados, paginas de manual, paginas
de informacodes e os manuais do SUSE fornecidos com o produto. Saiba mais na Secdo A.7,
“Usando a ajuda do GNOME”,

Pacotes de Ajuda separados para alguns aplicativos
Quando um novo software é instalado com o YaST, a respectiva documentacao é instalada
automaticamente e, em geral, aparece no centro de ajuda da area de trabalho. Porém,
alguns aplicativos, como o GIMP, podem ter diversos pacotes de ajuda online que podem
ser instalados separadamente com o YaST e que nao se integram aos centros de ajuda.

Documentacdo em /usr/share/doc
Este diretério de ajuda tradicional contém vérios arquivos de documentacao e as notas de
versao do seu sistema. Mais informacoes podem ser encontradas na Livro “Administration

Guide”, Capitulo 40 “Help and Documentation”, Se¢éo 40.1 “Documentation Directory”.

Paginas de manual e paginas de informacdes para comandos do shell
Ao trabalhar com o shell, vocé nao precisa saber de cor as opc¢des de comandos.
Tradicionalmente, o shell oferece ajuda integrada por meio das paginas de manual e de
informacdes. Leia mais na Livro “Administration Guide”, Capitulo 40 “Help and Documentation”,
Secdo 40.2 “Man Pages” e na Livro “Administration Guide”, Capitulo 40 “Help and Documentation”,
Secéio 40.3 “Info Pages”.

A.1 Usando a ajuda do GNOME

Na 4area de trabalho do GNOME, para iniciar a Ajuda diretamente de um aplicativo, clique
no botdo Ajuda ou pressione Fl1 . Ambas as opcoes o levam diretamente a documentacédo do
aplicativo no centro de ajuda. No entanto, vocé também pode iniciar a Ajuda abrindo um
terminal e digitando yelp ou, no menu principal, clicando em Aplicativos > Favoritos > Ajuda.
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Ajuda do GNOME

* Q

& Ajuda do GNOME

Encerrando sessio, desligando seu computador ou alternande usuarios
Aprenda como deixar sua conta de usuario, encerrando a sessao, alternando

usuarios e por ai vai.

Iniciando aplicativos

Inicie aplicativos a partir do panorama de Atividades.

Introdugio ac GNOME

Uma introducio visual a sua area de trabalho, a barra superior e o panorama

de Atividades.

Seu ambiente
Agenda, notificacdes,
atalhos de teclado,
janelas e espacos de
trabalho...

Rede, web & e-mail
Rede sem fio, rede
cabeada, problemas de
conexdo, Navegacao
web, contas de e-mail...

Som, video & imagens
Cameras digitais, iPods,
editando fotos,
reproduzindo videos...

Arquives, pastas & Usuario & Hardwares & drivers
pesquisa configuragdes do Problemas de
Pesquisar, excluir sistema hardware, impressoras,

Teclado, mouse,
monitor, idiomas,
contas de usuarios...

arguivos, copias de
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FIGURA A.1: JANELA PRINCIPAL DA AJUDA

Para obter uma visado geral dos manuais de aplicativos disponiveis, clique no icone de menu e

selecione a opcao para exibir toda a Ajuda.

O menu e a barra de ferramentas incluem op¢des para navegar no centro de ajuda para pesquisar
e imprimir o contetido da Ajuda. Os tépicos de ajuda sdo agrupados em categorias apresentadas
como links. Clique em um dos links para abrir uma lista de tépicos para essa categoria. Para
pesquisar um item, clique no icone de pesquisa e digite a string no campo na parte superior
da janela.
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A.2 Recursos de ajuda adicionais

Além dos manuais do SUSE instalados em /usr/share/doc, vocé pode acessar a documentacao
e os manuais especificos do produto na Web. Para uma visdo geral de toda a documentacdo
disponivel para o SUSE Linux Enterprise Server, visite a pAgina de documentacao especifica do

seu produto na Web em https://documentation.suse.com/ 7.

Se vocé estiver pesquisando mais informacoes relativas ao produto, também podera consultar
0s seguintes sites:

® SUSE Knowledgebase (http://www.suse.com/support/kb/) <

® Foruns do SUSE Linux Enterprise Server (https://forums.suse.com/forumdisplay.php?8-SUSE-

Linux-Enterprise-Server) @

Blog da SUSE (https://www.suse.com/communities/blog/) <

Site do GNOME na Web (http://www.gnome.org/) <

Site do KDE na Web (http://www.kde.org/) &

Vocé também pode experimentar mecanismos de pesquisa gerais. Por exemplo, use os termos
de pesquisa Linux CD-RW ajuda ou LibreOffice problema conversdo arquivos se estiver

com problemas de gravagdo de CD ou de conversao de arquivos no LibreOffice.

A.3 Para obter mais informacdes

Além dos recursos de ajuda especificos do produto, h4& uma ampla gama de informacoes
disponiveis sobre topicos relacionados ao Linux.

A.3.1 O Projeto de Documentacao do Linux

O TLDP (The Linux Documentation Project — O Projeto de Documentacdo do Linux) é
administrado por uma equipe de voluntarios que escrevem a documentacao relacionada ao Linux
(acesse http://www.tldp.org 7). O conjunto de documentos contém tutoriais para iniciantes, mas
é direcionado principalmente a usuérios experientes e administradores de sistema profissionais.
O TLDP publica HOWTOs, FAQs e guias (manuais) sob uma licenca gratuita. Partes da
documentacao do TLDP também estao disponiveis no SUSE Linux Enterprise Server.
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A.3.1.1  Perguntas frequentes (FAQ)

FAQs (perguntas frequentes) sdo uma série de perguntas e respostas. Elas provém de grupos
de discussdo da Usenet, onde o objetivo era reduzir a resposta continua das mesmas perguntas

basicas.

A.3.1.2 Guias

Vocé encontra manuais e guias sobre tépicos ou programas variados em http://www.tldp.org/
guides.html 7. Eles variam de Bash Guide for Beginners (Guia do Bash para Iniciantes), Linux File
System Hierarchy (Hierarquia do Sistema de Arquivos do Linux) ao Linux Administrator's Security
Guide (Guia de Seguranca do Administrador do Linux). Em geral, os guias sdo mais detalhados e
abrangentes do que os HOWTOs ou as perguntas frequentes (FAQs). Eles sdo geralmente escritos

por especialistas para especialistas.

A.3.2 Wikipédia: a enciclopédia livre online

Wikipedia é uma “enciclopédia multilingue que pode ser lida e editada por qualquer pessoa”
(consulte http://en.wikipedia.org #). O conteido da Wikipédia é criado por seus usudrios e
publicado sob uma licenca dual gratuita (GFDL e CC-BY-SA). No entanto, como qualquer
visitante pode editar a Wikipédia, ela deve ser usada apenas como um ponto de partida ou um

guia geral. H4 muita informacdo incompleta ou incorreta nela.

A.3.3 Padrdes e especificacbes

Ha vérias fontes que fornecem informacoes sobre padrdes ou especificacoes.

http://www.linux-foundation.org/en/LSB <
O Linux Foundation é uma organizacdo independente sem fins lucrativos que promove
a distribuicdo de software gratuito e de cédigo-fonte aberto. A organizacdo empenha-
se em obter isso definindo padrdes independentes de distribuicdo. A manutencdo de
véarios padrbes, como o importante LSB (Linux Standard Base - Base Padrao Linux), é

supervisionada por esta organizacao.
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http://www.w3.org <

O World Wide Web Consortium (W3C) é uma das organizagoes de padronizacdo mais
renomadas. Ela foi fundada em outubro de 1994 por Tim Berners-Lee e concentra-se na
padronizacdo de tecnologias da Web. O W3C promove a disseminacdo de especificacoes
livres, sem licenca e independentes de fabricante, como HTML, XHTML e XML. Esses
padrées da Web sao desenvolvidos em um processo de quatro etapas em grupos de trabalho

e sdo apresentados ao publico como recomendagdes do W3C (REC).

http://www.oasis-open.org <

A OASIS (Organization for the Advancement of Structured Information Standards -
Organizacdo para o Desenvolvimento dos Padroes de Informacdes Estruturadas) é um
consércio internacional especializado no desenvolvimento de padrdes para seguranca
da Web, e-business, transacOes comerciais, logistica e interoperabilidade entre vérios
mercados.

http://www.ietf.org 2

A Internet Engineering Task Force (IETF) é uma cooperativa ativa internacionalmente
de pesquisadores, projetistas de rede, fornecedores e usudrios. Ela concentra-se no
desenvolvimento da arquitetura da Internet e a operagdo uniforme da Internet através de
protocolos.

Cada padrao da IETF é publicado como uma RFC (Request for Comments - solicitacao
de comentérios) e estd disponivel gratuitamente. H4 seis tipos de RFC: padroes
propostos, esbocos de padroes, padroes da Internet, protocolos experimentais, documentos
informativos e padroes histéricos. Somente os trés primeiros (propostos, esbocos e
completos) sdo padrdes da IETF no sentido mais restrito (consulte http://www.ietf.org/rfc/
rfc1796.txtA).

http://www.ieee.org <

O IEEE (Institute of Electrical and Electronics Engineers - Instituto de Engenheiros Elétricos
e Eletronicos) é uma organizacao que cria padroes nas areas de tecnologia da informacao,
telecomunicacdes, medicina e saide, transporte e outros. Os padrdes IEEE estdao sujeitos

a cobranca.

http://www.iso.org @
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O comité ISO (International Organization for Standards - Organizacdo Internacional de
Padronizacao) é o maior desenvolvedor de padroes do mundo e mantém uma rede de
institutos nacionais de padronizacao em mais de 140 paises. Os padroes ISO estao sujeitos
a cobranca.
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http://www.din.de# ,

http://www.din.com 2
O DIN (Deutsches Institut fiir Normung - Instituto Alemdo para Normatizacdo) é uma
associacao técnica e cientifica registrada. Ela foi fundada em 1917. De acordo com o DIN, a
organizacao é “a instituicao responsavel por padroes na Alemanha e representa interesses
alemaes em organizacoes de padroes mundiais e europeus.”
A associacdo retne fabricantes, consumidores, profissionais do comércio, empresas de
servico, cientistas e outros que tém um interesse no estabelecimento de padroes. Os padroes

estdo sujeitos a cobranca e podem ser pedidos através da home page da DIN.
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B GNU licenses

This the GNU Free

Documentation License version 1.2.

appendix contains

GNU Free Documentation License

Copyright (C) 2000, 2001, 2002 Free Software Foundation, Inc. 51 Franklin St, Fifth Floor,
Boston, MA 02110-1301 USA. Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

0. PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful
document "free" in the sense of freedom: to assure everyone the effective freedom to copy
and redistribute it, with or without modifying it, either commercially or non-commercially.
Secondarily, this License preserves for the author and publisher a way to get credit for their

work, while not being considered responsible for modifications made by others.

This License is a kind of "copyleft", which means that derivative works of the document must
themselves be free in the same sense. It complements the GNU General Public License, which
is a copyleft license designed for free software.

We have designed this License to use it for manuals for free software, because free software
needs free documentation: a free program should come with manuals providing the same
freedoms that the software does. But this License is not limited to software manuals; it can
be used for any textual work, regardless of subject matter or whether it is published as a
printed book. We recommend this License principally for works whose purpose is instruction

or reference.

1. APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice placed
by the copyright holder saying it can be distributed under the terms of this License. Such a
notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under
the conditions stated herein. The "Document", below, refers to any such manual or work. Any
member of the public is a licensee, and is addressed as "you". You accept the license if you
copy, modify or distribute the work in a way requiring permission under copyright law.

A "Modified Version" of the Document means any work containing the Document or a portion
of it, either copied verbatim, or with modifications and/or translated into another language.
A "Secondary Section" is a named appendix or a front-matter section of the Document that
deals exclusively with the relationship of the publishers or authors of the Document to the
Document's overall subject (or to related matters) and contains nothing that could fall directly
within that overall subject. (Thus, if the Document is in part a textbook of mathematics, a
Secondary Section may not explain any mathematics.) The relationship could be a matter
of historical connection with the subject or with related matters, or of legal, commercial,

philosophical, ethical or political position regarding them.

The "Invariant Sections" are certain Secondary Sections whose titles are designated, as being
those of Invariant Sections, in the notice that says that the Document is released under this
License. If a section does not fit the above definition of Secondary then it is not allowed to be
designated as Invariant. The Document may contain zero Invariant Sections. If the Document
does not identify any Invariant Sections then there are none.

The "Cover Texts" are certain short passages of text that are listed, as Front-Cover Texts or
Back-Cover Texts, in the notice that says that the Document is released under this License. A
Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.
A "Transparent" copy of the Document means a machine-readable copy, represented in a
format whose specification is available to the general public, that is suitable for revising
the document straightforwardly with generic text editors or (for images composed of pixels)
generic paint programs or (for drawings) some widely available drawing editor, and that
is suitable for input to text formatters or for automatic translation to a variety of formats
suitable for input to text formatters. A copy made in an otherwise Transparent file format
whose markup, or absence of markup, has been arranged to thwart or discourage subsequent
modification by readers is not Transparent. An image format is not Transparent if used for
any substantial amount of text. A copy that is not "Transparent" is called "Opaque".
Examples of suitable formats for Transparent copies include plain ASCII without markup,
Texinfo input format, LaTeX input format, SGML or XML using a publicly available DTD,
and standard-conforming simple HTML, PostScript or PDF designed for human modification.
Examples of transparent image formats include PNG, XCF and JPG. Opaque formats include

proprietary formats that can be read and edited only by proprietary word processors, SGML or
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XML for which the DTD and/or processing tools are not generally available, and the machine-
generated HTML, PostScript or PDF produced by some word processors for output purposes
only.

The "Title Page" means, for a printed book, the title page itself, plus such following pages as
are needed to hold, legibly, the material this License requires to appear in the title page. For
works in formats which do not have any title page as such, "Title Page" means the text near the
most prominent appearance of the work's title, preceding the beginning of the body of the text.
A section "Entitled XYZ" means a named subunit of the Document whose title either is precisely
XYZ or contains XYZ in parentheses following text that translates XYZ in another language.
(Here XYZ stands for a specific section name mentioned below, such as "Acknowledgements",
"Dedications", "Endorsements", or "History".) To "Preserve the Title" of such a section when
you modify the Document means that it remains a section "Entitled XYZ" according to this

definition.

The Document may include Warranty Disclaimers next to the notice which states that this
License applies to the Document. These Warranty Disclaimers are considered to be included
by reference in this License, but only as regards disclaiming warranties: any other implication
that these Warranty Disclaimers may have is void and has no effect on the meaning of this

License.

2. VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or non-
commercially, provided that this License, the copyright notices, and the license notice saying
this License applies to the Document are reproduced in all copies, and that you add no other
conditions whatsoever to those of this License. You may not use technical measures to obstruct
or control the reading or further copying of the copies you make or distribute. However, you
may accept compensation in exchange for copies. If you distribute a large enough number of
copies you must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly
display copies.

3. COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the
Document, numbering more than 100, and the Document's license notice requires Cover Texts,
you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts:
Front-Cover Texts on the front cover, and Back-Cover Texts on the back cover. Both covers
must also clearly and legibly identify you as the publisher of these copies. The front cover
must present the full title with all words of the title equally prominent and visible. You may
add other material on the covers in addition. Copying with changes limited to the covers, as
long as they preserve the title of the Document and satisfy these conditions, can be treated
as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the
first ones listed (as many as fit reasonably) on the actual cover, and continue the rest onto
adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you
must either include a machine-readable Transparent copy along with each Opaque copy,
or state in or with each Opaque copy a computer-network location from which the general
network-using public has access to download using public-standard network protocols a
complete Transparent copy of the Document, free of added material. If you use the latter
option, you must take reasonably prudent steps, when you begin distribution of Opaque copies
in quantity, to ensure that this Transparent copy will remain thus accessible at the stated
location until at least one year after the last time you distribute an Opaque copy (directly or
through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before
redistributing any large number of copies, to give them a chance to provide you with an

updated version of the Document.
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4. MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of
sections 2 and 3 above, provided that you release the Modified Version under precisely this
License, with the Modified Version filling the role of the Document, thus licensing distribution
and modification of the Modified Version to whoever possesses a copy of it. In addition, you
must do these things in the Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the
Document, and from those of previous versions (which should, if there were any,
be listed in the History section of the Document). You may use the same title as a

previous version if the original publisher of that version gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for
authorship of the modifications in the Modified Version, together with at least five
of the principal authors of the Document (all of its principal authors, if it has fewer

than five), unless they release you from this requirement.

C. State on the Title page the name of the publisher of the Modified Version, as the
publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other

copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the public
permission to use the Modified Version under the terms of this License, in the form
shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and required Cover

Texts given in the Document's license notice.
H. Include an unaltered copy of this License.

I. Preserve the section Entitled "History", Preserve its Title, and add to it an item
stating at least the title, year, new authors, and publisher of the Modified Version
as given on the Title Page. If there is no section Entitled "History" in the Document,
create one stating the title, year, authors, and publisher of the Document as given
on its Title Page, then add an item describing the Modified Version as stated in
the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to
a Transparent copy of the Document, and likewise the network locations given in
the Document for previous versions it was based on. These may be placed in the
"History" section. You may omit a network location for a work that was published
at least four years before the Document itself, or if the original publisher of the

version it refers to gives permission.

K. For any section Entitled "Acknowledgements" or "Dedications", Preserve the Title
of the section, and preserve in the section all the substance and tone of each of the

contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and
in their titles. Section numbers or the equivalent are not considered part of the
section titles.

M. Delete any section Entitled "Endorsements". Such a section may not be included
in the Modified Version.

N. Do not retitle any existing section to be Entitled "Endorsements" or to conflict in
title with any Invariant Section.

0. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as
Secondary Sections and contain no material copied from the Document, you may at your
option designate some or all of these sections as invariant. To do this, add their titles to the
list of Invariant Sections in the Modified Version's license notice. These titles must be distinct
from any other section titles.

You may add a section Entitled "Endorsements', provided it contains nothing but
endorsements of your Modified Version by various parties--for example, statements of peer
review or that the text has been approved by an organization as the authoritative definition
of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25
words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only
one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through
arrangements made by) any one entity. If the Document already includes a cover text for the
same cover, previously added by you or by arrangement made by the same entity you are
acting on behalf of, you may not add another; but you may replace the old one, on explicit

permission from the previous publisher that added the old one.
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The author(s) and publisher(s) of the Document do not by this License give permission to use
their names for publicity for or to assert or imply endorsement of any Modified Version.

5. COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under
the terms defined in section 4 above for modified versions, provided that you include in the
combination all of the Invariant Sections of all of the original documents, unmodified, and
list them all as Invariant Sections of your combined work in its license notice, and that you
preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical
Invariant Sections may be replaced with a single copy. If there are multiple Invariant Sections
with the same name but different contents, make the title of each such section unique by
adding at the end of it, in parentheses, the name of the original author or publisher of that
section if known, or else a unique number. Make the same adjustment to the section titles in
the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled "History" in the various original
documents, forming one section Entitled "History"; likewise combine any sections Entitled
"Acknowledgements", and any sections Entitled "Dedications". You must delete all sections
Entitled "Endorsements".

6. COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under
this License, and replace the individual copies of this License in the various documents with a
single copy that is included in the collection, provided that you follow the rules of this License
for verbatim copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under
this License, provided you insert a copy of this License into the extracted document, and follow
this License in all other respects regarding verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent
documents or works, in or on a volume of a storage or distribution medium, is called an
"aggregate" if the copyright resulting from the compilation is not used to limit the legal rights
of the compilation's users beyond what the individual works permit. When the Document is
included in an aggregate, this License does not apply to the other works in the aggregate
which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then
if the Document is less than one half of the entire aggregate, the Document's Cover Texts
may be placed on covers that bracket the Document within the aggregate, or the electronic
equivalent of covers if the Document is in electronic form. Otherwise they must appear on

printed covers that bracket the whole aggregate.

8. TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the
Document under the terms of section 4. Replacing Invariant Sections with translations requires
special permission from their copyright holders, but you may include translations of some
or all Invariant Sections in addition to the original versions of these Invariant Sections. You
may include a translation of this License, and all the license notices in the Document, and
any Warranty Disclaimers, provided that you also include the original English version of this
License and the original versions of those notices and disclaimers. In case of a disagreement
between the translation and the original version of this License or a notice or disclaimer, the
original version will prevail.

If a section in the Document is Entitled "Acknowledgements", "Dedications", or "History", the
requirement (section 4) to Preserve its Title (section 1) will typically require changing the
actual title.

9. TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly
provided for under this License. Any other attempt to copy, modify, sublicense or distribute the
Document is void, and will automatically terminate your rights under this License. However,
parties who have received copies, or rights, from you under this License will not have their

licenses terminated so long as such parties remain in full compliance.
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10. FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free
Documentation License from time to time. Such new versions will be similar in spirit to the
present version, but may differ in detail to address new problems or concerns. See https://
www.gnu.org/copyleft/ 2.

Each version of the License is given a distinguishing version number. If the Document specifies
that a particular numbered version of this License "or any later version" applies to it, you have
the option of following the terms and conditions either of that specified version or of any
later version that has been published (not as a draft) by the Free Software Foundation. If the
Document does not specify a version number of this License, you may choose any version ever
published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents

Copyright (c) YEAR YOUR NAME.
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2

or any later version published by the Free Software Foundation;

with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts.
A copy of the license is included in the section entitled “GNU

Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the
“with...Texts.” line with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three,
merge those two alternatives to suit the situation.
If your document contains nontrivial examples of program code, we recommend releasing

these examples in parallel under your choice of free software license, such as the GNU General
Public License, to permit their use in free software.
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