10

11

12

13

14

15

16

EWE SUSE

Configuring virtual machines
with Virtual Machine Manager

Publication Date: 27 Jun 2024

Contents

Environment 3
Introduction 3
Requirements 3
Viewing detailed information 3
Overview 4
Performance statistics 5
Basic hardware 6

Boot options 10
Storage 10

Controllers 12
Networking 13

Input devices 14

Video 16

USB redirectors 17
Miscellaneous 18

Adding a CD/DVD-ROM device with Virtual Machine Manager 19

Configuring virtual machines with Virtual Machine Manager



17

18

19

20

21

22

23

Adding a floppy device with Virtual Machine Manager 20

Ejecting and changing floppy or CD/DVD-ROM media with Virtual Machine

Manager 21

Assigning a host PCl device to a VM Guest 21

Assigning a host USB device to a VM Guest 23

Summary 24
Troubleshooting 25

Related topics 25

Configuring virtual machines with Virtual Machine Manager

*



1 Environment

This document applies to the following products and product versions:

e SUSE Linux Enterprise Server 15 SP5, 15 SP4, 15 SP3, 15 SP2, 12 SP5

2 Introduction

Virtual Machine Manager is a GUI (graphical user interface) application for configuring virtual
machines managed by libvirt. This article will help you configure your virtual machine using

Virtual Machine Manager.

3 Requirements

® Any SUSE Linux Enterprise-based desktop environment with the Virtual Machine Manager

application installed.

® At least one connection to a valid VM Host Server configured by Virtual Machine Manager

or libvirt.

® An existing libvirt-based virtual machine on the VM Host Server.

4 Viewing detailed information

Virtual Machine Manager's Details view offers in-depth information about the VM Guest's com-
plete configuration and hardware equipment. Using this view, you can also change the guest
configuration or add and modify virtual hardware to an existing virtual machine. To access

Details, do the following:

1. Start Virtual Machine Manager by running the virt-manager command from the com-

mand line.

2. Left-click the virtual machine that you need to view or modify from the list of virtual

machines and select Open.

3. In the virtual machine's console window, select View > Details from the menu, or click Show

virtual hardware details in the toolbar.

3 Configuring virtual machines with Virtual Machine Manager
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The left panel of the window lists VM Guest overview information and already installed hard-

ware. After clicking an item in the list, you can access its detailed settings in the right view. You

can change the hardware parameters to match your needs, then click Apply to confirm them.

@ Tip

Some changes take effect immediately, while others need a reboot of the machine—and

Virtual Machine Manager warns you about that fact.

To remove installed hardware from a VM Guest, select it from the left panel and then click

Remove in the bottom right of the window.

To add new hardware, click Add Hardware below the left panel, then select the type of the

hardware you want to add in the Add New Virtual Hardware window. Modify its parameters and

confirm with Finish.

5 Overview

The Overview shows basic details about the VM Guest and the hypervisor.
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FIGURE 2: OVERVIEW DETAILS

The Name, Title, and Description fields are editable, and will help you to identify the VM Guest

in the Virtual Machine Manager list of machines.

Name ~ CPUusage
~ QEMUJKVM

SLES125P5.
Shutoff

esting supported upgrade paths

FIGURE 3: VM GUEST TITLE AND DESCRIPTION

UUID shows the Universally Unique IDentifier of the virtual machine, while Status shows its

current status: Running, Paused, or Shutoff.

The Hypervisor Details section shows the hypervisor type, CPU architecture, the emulator in use

(if any), and the chipset type. None of the hypervisor parameters can be changed.

6 Performance statistics

Performance shows regularly updated charts of CPU and memory usage, and disk and network
I/0.
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@ Tip: Enabling disabled charts

Not all the charts in the Graph view are enabled by default. To enable these charts, go to
File > View Manager, then select Edit > Preferences > Polling, and check the charts that you

want to see.
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FIGURE 5: STATISTICS CHARTS

7 Basic hardware

This section describes the setup of the virtualized processor and memory. These components are

vital to a VM Guest, so you cannot remove them.

6 Configuring virtual machines with Virtual Machine Manager
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7.1 Processor

CPU includes detailed information about the processor configuration of the VM Guest .
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FIGURE 6: PROCESSOR VIEW

In the CPUs section, you can configure the number of virtual CPUs allocated to the VM Guest.
Logical host CPUs shows the number of online and usable CPUs on the VM Host Server.

The Configuration section lets you configure the CPU model and topology.
When activated, the Copy host CPU configuration option uses the host CPU model for VM Guest.

You can see the details of the host CPU model in the output of the virsh capabilities
command. When deactivated, the CPU model needs to be specified from the models available
in the drop-down box.

The host CPU model generally provides a good trade-off between CPU features and ability to
migrate the VM Guest. libvirt does not model every aspect of each CPU, so the VM Guest
CPU will not match the VM Host Server CPU exactly. However, the ABI provided to the VM

*
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Guest is reproducible, and during migration, the complete CPU model definition is transferred
to the destination VM Host Server, ensuring that the migrated VM Guest will see the exact same

CPU model on the destination.

The host-passthrough model provides the VM Guest with a CPU that is exactly the same as
the VM Host Server CPU. This can be useful when the VM Guest workload requires CPU features
not available in libvirt's simplified host-model CPU. The host-passthrough model is also
required in some cases, for example, when running VM Guests with more than 4 TB of memory.
The host-passthrough model comes with the disadvantage of reduced migration capability.
A VM Guest with host-passthrough model CPU can only be migrated to a VM Host Server

with identical hardware.

For more information on libvirt's CPU model and topology options, see the CPU model and

topology documentation at https://libvirt.org/formatdomain.html#cpu-model-and-topology 7.

After you activate Manually set CPU topology, you can specify a custom number of sockets, cores
and threads for the CPU.

7.2 Memory

Memory contains information about the memory that is available to the VM Guest.

8 Configuring virtual machines with Virtual Machine Manager
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FIGURE 7: MEMORY VIEW

Total host memory

- + MiB

+ MiB

Total amount of memory installed on the VM Host Server.

Current allocation

The amount of memory currently available to VM Guest. You can hotplug more memory

by increasing this value up to the value of Maximum allocation.

Maximum allocation

The maximum value to which you can hotplug the currently available memory. Any change

to this value will take effect after the next VM Guest reboot.

o Important: Large memory VM Guests

VM Guests with memory requirements of 4 TB or more currently need to use the host-

passthrough CPU model.
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8 Boot options

Boot Options introduces options affecting the VM Guest boot process.
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FIGURE 8: BOOT OPTIONS

In the Autostart section, you can specify whether the virtual machine should automatically start

during the VM Host Server boot phase.

In the Boot device order, activate the devices that will be used for booting the VM Guest. You can
change their order with the up and down arrow buttons on the right side of the list. To choose

from a list of bootable devices on VM Guest start, activate Enable boot menu.

To boot a different kernel than the one on the boot device, activate Enable direct kernel boot and
specify the paths to the alternative kernel and initrd placed on the VM Host Server file system.
You can also specify kernel arguments that will be passed to the loaded kernel.

9 Storage

This section gives you a detailed description of configuration options for storage devices. It
includes both hard disks and removable media, such as USB or CD-ROM drives.

10 Configuring virtual machines with Virtual Machine Manager
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PROCEDURE 1: ADDING A NEW STORAGE DEVICE

1. Below the left panel, click Add Hardware to open the Add New Virtual Hardware window.
There, select Storage.
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FIGURE 9: ADD A NEW STORAGE

2. To create a qcow2 disk image in the default location, activate Create a disk image for the
virtual machine and specify its size in gigabytes.
To gain more control over the disk image creation, activate Select or create custom storage
and click Manage to manage storage pools and images.

@ Tip: Supported storage formats

SUSE only supports the following storage formats: raw and qcow2.

3. After you manage to create and specify the disk image file, specify the Device type. It can

be one of the following options:

® Disk device

® CDROM device: Does not allow using Create a disk image for the virtual machine.

1" Configuring virtual machines with Virtual Machine Manager
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* Floppy device: Does not allow using Create a disk image for the virtual machine.

® LUN Passthrough: Required to use an existing SCSI storage directly without adding

it into a storage pool.

4. Select the Bus type for your device. The list of available options depends on the device type

you selected in the previous step. The types based on VirtIO use paravirtualized drivers.
5. In the Advanced options section, select the preferred Cache mode.

6. Confirm your settings with Finish. A new storage device appears in the left panel.

10 Controllers

This section focuses on adding and configuring new controllers.

PROCEDURE 2: ADDING A NEW CONTROLLER

1. Below the left panel, click Add Hardware to open the Add New Virtual Hardware window.

There, select Controller.
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FIGURE 10: ADD A NEW CONTROLLER

2. Select the type of the controller. You can choose from IDE, Floppy, SCSI, SATA, VirtlO Serial
(paravirtualized), USB, or CCID (smart card devices).

3. Optionally, in the case of a USB or SCSI controller, select a controller model.

4. Confirm your settings with Finish. A new controller appears in the left panel.

11  Networking

This section describes how to add and configure new network devices.

PROCEDURE 3: ADDING A NEW NETWORK DEVICE

1. Below the left panel, click Add Hardware to open the Add New Virtual Hardware window.
There, select Network.
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FIGURE 11: ADD A NEW NETWORK INTERFACE

2. From the Network source list, select the source for the network connection. The list includes
the VM Host Server's available physical network interfaces, network bridges, or network

bonds. You can also assign the VM Guest to a virtual network that was already defined.

3. Specify a MAC address for the network device. While Virtual Machine Manager pre-fills a
random value for your convenience, it is recommended to supply a MAC address appro-

priate for your network environment to avoid network conflicts.

4. Select a device model from the list. You can either leave the Hypervisor default, or specify

one of e1000, rtl8139, or virtio models. Note that virtio uses paravirtualized drivers.

5. Confirm your settings with Finish. A new network device appears in the left panel.

12 Input devices

This section focuses on adding and configuring new input devices such as mouse, keyboard,
or tablet.

*
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PROCEDURE 4: ADDING A NEW INPUT DEVICE

1. Below the left panel, click Add Hardware to open the Add New Virtual Hardware window.
There, select Input.
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FIGURE 12: ADD A NEW INPUT DEVICE

2. Select a device type from the list.

3. Confirm your settings with Finish. A new input device appears in the left panel.

@ Tip: Enabling seamless and synchronized mouse pointer

15

movement

When you click within a VM Guest's console with the mouse, the pointer is captured by
the console window and cannot be used outside the console unless it is explicitly released
(by pressing Alt —ctrl ). To prevent the console from grabbing the key and to enable
seamless pointer movement between host and guest instead, follow the instructions in
Procedure 4, “Adding a new input device” to add an EvTouch USB Graphics Tablet to the VM
Guest.

Configuring virtual machines with Virtual Machine Manager
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Adding a tablet has the additional advantage of synchronizing the mouse pointer move-
ment between the VM Host Server and the VM Guest when using a graphical environment
on the guest. With no tablet configured on the guest, you will often see two pointers with

one dragging behind the other.

13 Video

This section describes how to add and configure new video devices.

PROCEDURE 5: ADDING A VIDEO DEVICE

16

1. Below the left panel, click Add Hardware to open the Add New Virtual Hardware window.

There, select Video.
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FIGURE 13: ADD A NEW VIDEO DEVICE
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3. Select a model from the list. You can choose from:

® Cirrus

s QXL

* VGA

e Virtio

VMVGA

® Xen

@ Note: Secondary video devices

Only QXL and Virtio can be added as secondary video devices.

4. Confirm your settings with Finish. A new video device appears in the left panel.

14 USB redirectors

USB devices that are connected to the client machine can be redirected to the VM Guest by

using USB Redirectors.
PROCEDURE 6: ADDING A USB REDIRECTOR

1. Below the left panel, click Add Hardware to open the Add New Virtual Hardware window.
There, select USB Redirection.
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FIGURE 14: ADD A NEW USB REDIRECTOR

2. Select a device type from the list. Depending on your configuration, you can either select
a Spice channel or a TCP redirector.

3. Confirm your settings with Finish. A new USB redirector appears in the left panel.

15 Miscellaneous

Smartcard
Smartcard functionality can be added via the Smartcard element. A physical USB smartcard

reader can then be passed through to the VM Guest.

Watchdog
Virtual watchdog devices are also supported. They can be created via the Watchdog ele-

ment. The model as well as the action of the device can be specified.

@ Tip: Requirements for virtual watchdog devices

QA virtual watchdog devices require a specific driver and daemon to be installed in
the VM Guest. Otherwise the virtual watchdog device does not work.

18 Configuring virtual machines with Virtual Machine Manager
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TPM
You can use the Host TPM device in the VM Guest by adding TPM functionality via the
TPM element.

@ Tip: Virtual TPMs

The Host TPM can only be used in one VM Guest at a time.

16 Adding a CD/DVD-ROM device with Virtual
Machine Manager

KVM supports CD or DVD-ROMs in VM Guest either by directly accessing a physical drive on
the VM Host Server or by accessing ISO images. To create an ISO image from an existing CD
or DVD, use dd:

> sudo dd if=/dev/CD DVD DEVICE of=my distro.iso bs=2048

To add a CD/DVD-ROM device to your VM Guest, proceed as follows:

1. Double-click a VM Guest entry in the Virtual Machine Manager to open its console and

switch to the Details view with View > Details.
2. Click Add Hardware and choose Storage in the pop-up window.
3. Change the Device Type to IDE CDROM.

4. Select Select or create custom storage.

a. To assign the device to a physical medium, enter the path to the VM Host Server's
CD/DVD-ROM device (for example, /dev/cdrom) next to Manage. Alternatively, use
Manage to open a file browser and then click Browse Local to select the device. As-
signing the device to a physical medium is only possible when the Virtual Machine

Manager was started on the VM Host Server.

b. To assign the device to an existing image, click Manage to choose an image from a
storage pool. If the Virtual Machine Manager was started on the VM Host Server,
alternatively choose an image from another location on the file system by clicking

Browse Local. Select an image and close the file browser with Choose Volume.

*
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5. Save the new virtualized device with Finish.

6. Reboot the VM Guest to make the new device available. For more information, see Sec-

tion 18, “Ejecting and changing floppy or CD/DVD-ROM media with Virtual Machine Manager”.

17 Adding a floppy device with Virtual Machine
Manager

Currently KVM only supports the use of floppy disk images—using a physical floppy drive is not
supported. Create a floppy disk image from an existing floppy using dd:

> sudo dd if=/dev/fd0 of=/var/lib/libvirt/images/floppy.img

To create an empty floppy disk image use one of the following commands:
Raw image

> sudo dd if=/dev/zero of=/var/lib/libvirt/images/floppy.img bs=512 count=2880
FAT formatted image

> sudo mkfs.msdos -C /var/lib/libvirt/images/floppy.img 1440

To add a floppy device to your VM Guest, proceed as follows:

1. Double-click a VM Guest entry in the Virtual Machine Manager to open its console and
switch to the Details view with View > Details.

2. Click Add Hardware and choose Storage in the pop-up window.
3. Change the Device Type to Floppy Disk.

4. Choose Select or create custom storage and click Manage to choose an existing image from a
storage pool. If Virtual Machine Manager was started on the VM Host Server, alternatively
choose an image from another location on the file system by clicking Browse Local. Select

an image and close the file browser with Choose Volume.
5. Save the new virtualized device with Finish.

6. Reboot the VM Guest to make the new device available. For more information, see Sec-

tion 18, “Ejecting and changing floppy or CD/DVD-ROM media with Virtual Machine Manager”.

*
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18 Ejecting and changing floppy or CD/DVD-ROM
media with Virtual Machine Manager

Whether you are using the VM Host Server's physical CD/DVD-ROM device or an ISO/floppy
image: Before you can change the media or image of an existing device in the VM Guest, you

first need to disconnect the media from the guest.

1. Double-click a VM Guest entry in the Virtual Machine Manager to open its console and

switch to the Details view with View > Details.
2. Choose the Floppy or CD/DVD-ROM device and “eject” the medium by clicking Disconnect.
3. To “insert” a new medium, click Connect.

a. If using the VM Host Server's physical CD/DVD-ROM device, first change the media
in the device (this may require unmounting it on the VM Host Server before it can be
ejected). Then choose CD-ROM or DVD and select the device from the drop-down box.

b. If you are using an ISO image, choose ISO image Location and select an image by
clicking Manage. When connecting from a remote host, you may only choose images

from existing storage pools.

4. Click OK to finish. The new media can now be accessed in the VM Guest.

19 Assigning a host PCl device to a VM Guest

You can directly assign PCI devices on the VM Host Server to guests (PCI pass-through). When
the PCI device is assigned to one VM Guest, it cannot be used on the host or by another VM
Guest unless it is re-assigned. A prerequisite for this feature is a VM Host Server configuration

as described in FIXME .

19.1 Adding a PCl device with Virtual Machine Manager

The following procedure describes how to assign a PCI device from a VM Host Server to a VM

Guest using Virtual Machine Manager:

1. Double-click a VM Guest entry in the Virtual Machine Manager to open its console and

switch to the Details view with View s> Details.

21 Configuring virtual machines with Virtual Machine Manager
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2. Click Add Hardware and choose the PCI Host Device category in the left panel. A list of
available PCI devices appears in the right part of the window.
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FIGURE 15: ADDING A PCI DEVICE

3. From the list of available PCI devices, choose the one you want to pass to the guest.

Confirm with Finish.

o Important: SLES 11 SP4 KVM guests

On a newer QEMU machine type (pc-i440fx-2.0 or higher) with SLES 11 SP4 KVM guests,
the acpiphp module is not loaded by default in the guest. This module must be loaded
to enable hotplugging of disk and network devices. To load the module manually, use
the command modprobe acpiphp. It is also possible to autoload the module by adding
install acpiphp /bin/true to the /etc/modprobe.conf.local file.

o Important: KVM guests using QEMU Q35 machine type

22

KVM guests using the QEMU Q35 machine type have a PCI topology that includes a pcie-
root controller and seven pcie-root-port controllers. The pcie-root controller does
not support hotplugging. Each pcie-root-port controller supports hotplugging a single
PClIe device. PCI controllers cannot be hotplugged, so plan accordingly and add more
pcie-root-port s if more than seven PCle devices will be hotplugged. A pcie-to-pci-
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bridge controller can be added to support hotplugging legacy PCI devices. See https://
libvirt.org/pci-hotplug.html# for more information about PCI topology between QEMU

machine types.

20 Assigning a host USB device to a VM Guest

Analogous to assigning host PCI devices (see Section 19, “Assigning a host PC/ device to a VM Guest”),
you can directly assign host USB devices to guests. When the USB device is assigned to one VM
Guest, it cannot be used on the host or by another VM Guest unless it is re-assigned.

20.1 Adding a USB device with Virtual Machine Manager

To assign a host USB device to VM Guest using Virtual Machine Manager, follow these steps:

1. Double-click a VM Guest entry in the Virtual Machine Manager to open its console and

switch to the Details view with View > Details.

2. Click Add Hardware and choose the USB Host Device category in the left panel. A list of

available USB devices appears in the right part of the window.
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FIGURE 16: ADDING A USB DEVICE

3. From the list of available USB devices, choose the one you want to pass to the guest.

Confirm with Finish. The new USB device appears in the left pane of the Details view.

@ Tip: USB device removal

To remove the host USB device assignment, click it in the left pane of the Details

view and confirm with Remove.

21 Summary

Your virtual machine is properly configured to suit your needs and you can monitor its perfor-

mance statistics.

*
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22 Troubleshooting

Virtual Machine Manager cannot establish connection to VM Host Server

Verify that the libvirtd service is running on VM Host Server:

> sudo systemctl status libvirtd.service

@ libvirtd.service - Virtualization daemon
Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled; vendor preset:
enabled)
Active: active (running) since Thu 2021-08-19 07:46:07 UTC; 2 weeks 0 days ago

[...]

Virtual Machine Manager cannot execute a guest VM with more than 255 vCPU's assigned.

See https://www.suse.com/support/kb/doc/?id=000019723 @ for a workaround.

23 Related topics

¢ See FIXME for more information on setting up virtual networks with Virtual Machine Man-

ager.
® See FIXME for more details on managing storage with Virtual Machine Manager.

e For more information on disk cache modes, see FIXME .
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