Jump to contentJump to page navigation: previous page [access key p]/next page [access key n]
documentation.suse.com / SUSE Linux Enterprise Server Documentation / Upgrade Guide / Finishing the upgrade
Applies to SUSE Linux Enterprise Server 15 SP4

6 Finishing the upgrade

After the upgrade, you need to perform some additional tasks. The following chapter guides you through these steps.

6.1 Post-upgrade checks

  • Check for any orphaned packages. During an upgrade procedure, packages may be renamed, removed, merged, or split. As a result, certain packages can become orphaned and unsupported. Orphaned packages are not automatically removed. The following command gives you a list of these:

    > zypper packages --orphaned --unneeded

    Use the list to determine which packages are still needed and which packages can be safely removed.

  • Check for any *.rpmnew and *.rpmsave files, examine their content, and possibly merge desirable changes. When an upgrade includes changes to a default configuration file, instead of overwriting the configuration file, the package creates one of these file types. While *.rpmnew contains the new default configuration and leaves your original file untouched, *.rpmsave is a copy of your original configuration that has been replaced by the new default file.

    You do not need to search the whole file system for *.rpmnew and *.rpmsave files, the most important are stored in the /etc directory. Use the following command to list them:

    > find /etc/ -name "*.rpmnew" -o -name "*.rpmsave"

6.2 Enable the Python 3 module

SUSE Linux Enterprise Server 15 uses Python 3.6 by default. Python 3.9 was added in SLES 15 SP3 as a more recent alternative. This version is no longer supported as of SLES 15 SP4. Instead, recent Python versions with important updates and security fixes are available through the Python 3 module.

If you installed Python 3.9 under SUSE Linux Enterprise Server 15 SP3, enable the Python 3 module with:

> sudo SUSEConnect -p sle-module-python3/15.4/x86_64.

Alternatively, you can return to the default Python version by removing 3.9 with zypper remove -u python39.

6.3 Reformat XFS v4 devices

SUSE Linux Enterprise Server supports the on-disk format (v5) of the XFS file system. The main advantages of this format are automatic checksums of all XFS metadata, file type support, and support for a larger number of access control lists for a file.

Note that this format is not supported by SUSE Linux Enterprise kernels older than version 3.12, by xfsprogs older than version 3.2.0, and GRUB 2 versions released before SUSE Linux Enterprise 12.

Important
Important: V4 is deprecated

XFS is deprecating file systems with the V4 format. This file system format was created by the command:

> sudo mkfs.xfs -m crc=0 DEVICE

The format was used in SLE 11 and older releases, and it currently creates a warning message by dmesg:

Deprecated V4 format (crc=0) will not be supported after September 2030

If you see the message above in the output of the dmesg command, it is recommended that you update your file system to the V5 format:

  1. Back up your data to another device.

  2. Create the file system on the device.

    > sudo mkfs.xfs -m crc=1 DEVICE
  3. Restore the data from the backup on the updated device.