Upgrade the Database

To successfully perform a major SUSE Manager update, you might need to upgrade the underlying database.

To upgrade to the latest PostgreSQL, see upgrade:db-migration-xy.adoc.

This table shows the PostgreSQL version required for each version of SUSE Manager and SUSE Linux Enterprise Server:

Table 1. PostgreSQL Versions
SUSE Manager version Operating System version PostgreSQL version

SUSE Manager 3.1.4

SLES 12 SP3

Postgres 9.6

SUSE Manager 3.1.11

SLES 12 SP3

Postgres 9.6

SUSE Manager 3.2.10

SLES 12 SP3

Postgres 9.6

SUSE Manager 3.2.10

SLES 12 SP3

Postgres 10

SUSE Manager 3.2.10

SLES 12 SP4

Postgres 10

SUSE Manager 4.0.0

SLES 15 SP1

Postgres 10

SUSE Manager 4.1.0

SLES 15 SP2

Postgres 12

SUSE Manager 4.2.0

SLES 15 SP3

Postgres 13

If you are using an older database version, such as version 9.4 or 9.6, you must migrate PostgreSQL to version 10 before you begin the SUSE Manager migration. To upgrade from PostgreSQL 9 to version 10, see https://documentation.suse.com/external-tree/en-us/suma/4.1/suse-manager/upgrade/db-migration-10.html